Bug 159876 - Wish: Using mousewheel on desktop cycles through virtual desktops
Summary: Wish: Using mousewheel on desktop cycles through virtual desktops
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 167497 173971 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-26 06:15 UTC by Daniel Veillette
Modified: 2009-02-01 19:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Veillette 2008-03-26 06:15:48 UTC
Version:            (using KDE 4.0.2)
Installed from:    Ubuntu Packages

In KDE3 it was possible to use the mousewheel on the desktop to cycle through virtual desktops -- it appears that this is not yet implemented in KDE4 (or may have been removed on purpose?).  You can scroll over the pager, but that's a much smaller target.  It'd be nice to be able to go into the "Configure Desktops" dialogue and enable this capability.
Comment 1 Ryan J Redding 2008-08-05 20:16:04 UTC
Agreed. Please implement this feature. It was -very- useful in KDE3.
Comment 2 Aaron J. Seigo 2008-08-06 02:40:11 UTC
*** Bug 167497 has been marked as a duplicate of this bug. ***
Comment 3 Aaron J. Seigo 2008-08-06 03:25:19 UTC
SVN commit 842821 by aseigo:

wheel scroll == desktop switch; no configuration, let's see how people react.

moment of philosophy: there are some features used almost exclusively by people who can't (or can't be bothered to) write code, but know where our bug tracker is, my blog is, what my email address is, etc... this is one such feature. amazing. or sad. i'm not sure which.

BUG:159876


 M  +22 -0     containment.cpp  
 M  +1 -0      containment.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=842821
Comment 4 lucas 2008-10-31 13:36:11 UTC
*** Bug 173971 has been marked as a duplicate of this bug. ***
Comment 5 Adrian Friedli 2009-02-01 19:51:58 UTC
I'd like to have this configurable. When I'm using a mouse with a scroll wheel I really like this feature, but when I'm using a touchpad with two-finger scrolling I would like to have it turned off.