Bug 158895 - change file icons in file association dialog
Summary: change file icons in file association dialog
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_filetypes (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 167031 167481 176534 186747 187460 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-07 08:25 UTC by Khalil Moriello
Modified: 2010-05-24 18:15 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Khalil Moriello 2008-03-07 08:25:19 UTC
Version:            (using KDE 4.0.2)
Installed from:    Debian testing/unstable Packages

You should change a file icon if you don't want. In KDE3 you could change it, but now in systemsettings when you try to replace an icon with another, systemsettings doesn't allow you.
Comment 1 Pino Toscano 2008-03-07 11:50:18 UTC
Do you mean the icons for the file associations (the mime types)?
Comment 2 Khalil Moriello 2008-03-09 09:27:31 UTC
yes
Comment 3 Peter Paulsen 2008-07-30 12:56:34 UTC
That's really bad, I agree! It should be up to the user to use own icon associations without having to change the whole theme or replace the icon in the theme!
Comment 4 FiNeX 2008-11-14 00:35:27 UTC
*** Bug 167481 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2009-01-01 03:19:31 UTC
*** Bug 176534 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Kofler 2009-01-10 19:42:46 UTC
See also downstream Fedora bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=477489
Comment 7 David Faure 2009-01-12 10:54:12 UTC
Yes I had to disable that functionality for kde-4.0 because shared-mime-info didn't allow this. It does now, but not everyone is using shared-mime-info >= 0.40, and the addition of <icon> in the xml files makes shared-mime-info < 0.40 barf errors. So the code is mostly ready, but I have to wait until everyone is using shared-mime-info >= 0.40 before I can enable this functionality. (I know, I could do a runtime check of the version with `update-mime-database -v`... it just makes the whole thing more complex than expected so I didn't have time to finish it yet). Planned for KDE-4.3.
Comment 8 Harald Sitter 2009-01-24 17:16:01 UTC
David, could you please attach a patch if you get a chance? I suppose distributions which ship with shared-mime-info >= 0.40 could patch it into 4.2 :)
Comment 9 Kevin Kofler 2009-01-24 17:22:22 UTC
Seconded.

FYI, koji latest-pkg tells me:
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
shared-mime-info-0.51-6.fc11              dist-f11              hadess
shared-mime-info-0.51-5.fc10              dist-f10-updates      belegdol
shared-mime-info-0.30-3.fc9               dist-f9-updates       hadess
so Fedora >= 10 have a version high enough. Fedora 9 doesn't, we'd have to talk to the maintainers to see if we can get shared-mime-info upgraded, but we could ship this feature in at least Fedora 10 and Rawhide (future Fedora 11).
Comment 10 David Faure 2009-01-26 11:21:01 UTC
The code isn't fully finished so my current patch wouldn't help you (unless you want to finish the coding ;)
I'll work on finishing this, hmm, somewhen (various crash reports keep coming in, meanwhile...)
Comment 11 David Faure 2009-02-20 02:36:29 UTC
SVN commit 928753 by dfaure:

Support for letting the user change mimetype icons. The GUI part is done but has to wait until Monday since it will use this new API.
CCBUG: 158895


 M  +14 -2     kdecore/services/kmimetype.cpp  
 M  +17 -10    kdecore/services/kmimetype.h  
 M  +20 -11    kdecore/services/kmimetype_p.h  
 M  +1 -1      kdecore/sycoca/ksycoca.cpp  
 M  +14 -6     kded/kbuildmimetypefactory.cpp  
 M  +4 -0      kio/kio/kfileitem.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=928753
Comment 12 David Faure 2009-02-23 11:42:02 UTC
SVN commit 930394 by dfaure:

Allow users to change mimetype icons if they use shared-mime-info >= 0.40
BUG: 158895


 M  +1 -0      konqueror/settings/filetypes/CMakeLists.txt  
 M  +23 -22    konqueror/settings/filetypes/filetypedetails.cpp  
 M  +3 -6      konqueror/settings/filetypes/filetypedetails.h  
 D             konqueror/settings/filetypes/filetypes-config.h  
 M  +7 -8      konqueror/settings/filetypes/mimetypedata.cpp  
 M  +0 -1      konqueror/settings/filetypes/mimetypedata.h  
 M  +7 -10     konqueror/settings/filetypes/mimetypewriter.cpp  
 A             konqueror/settings/filetypes/sharedmimeinfoversion.cpp   [License: GPL (v2/3+eV)]
 A             konqueror/settings/filetypes/sharedmimeinfoversion.h   [License: GPL (v2/3+eV)]
 M  +6 -1      konqueror/settings/filetypes/tests/CMakeLists.txt  
 M  +1 -1      nsplugins/CMakeLists.txt  
 M  +1 -1      nsplugins/pluginscan.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=930394
Comment 13 Pino Toscano 2009-03-10 15:21:10 UTC
*** Bug 186747 has been marked as a duplicate of this bug. ***
Comment 14 Pino Toscano 2009-03-17 23:56:42 UTC
*** Bug 187460 has been marked as a duplicate of this bug. ***
Comment 15 David Faure 2009-03-25 18:06:59 UTC
*** Bug 167031 has been marked as a duplicate of this bug. ***
Comment 16 Chris 2010-05-24 18:15:11 UTC
Has this definitely been fixed? I am currently unable to change some file type icons in system preferences as of kde sc 4.4.