Bug 157255 - Wish KMplayer / Phonon supported KIO slaves like fish, ftp and smb. See bug #157143
Summary: Wish KMplayer / Phonon supported KIO slaves like fish, ftp and smb. See bug #...
Status: RESOLVED DUPLICATE of bug 157143
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-06 13:02 UTC by Rune Jensen
Modified: 2012-02-29 13:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rune Jensen 2008-02-06 13:02:15 UTC
Version:            (using KDE 4.0.0)
Installed from:    SuSE RPMs
OS:                Linux

See bug #157143.

It would have been nice if KMplayer supported KIO slaves and URLS like fish://rune@tvbox/movie.avi and smb:// urls for samba shares.

Especially fish would have been nice :-).

Regards
Rune Jensen
Comment 1 Jordi Polo 2008-04-21 13:47:09 UTC
It is working for me in KDE Version 4.00.70 (KDE 4.0.70 >= 20080418)
in dragon and KMplayer 

At least fish, I have no smb:// to test
Comment 2 Médéric Boquien 2008-11-08 21:43:28 UTC
Hello Rune,

Please test with the latest released KDE if your wish has been fulfilled or not.

Thanks.
Comment 3 Rune Jensen 2008-11-10 21:59:15 UTC
It works, but kmplayer copies the entire file locally before starting playback, meaning you have to wait until gigabytes of data is copied over the network first.
Maybe this is a KIO fault ?

Regards
Rune
Comment 4 Stephan Sokolow 2009-01-28 19:20:39 UTC
I'd assume that behaviour stems from the use of MPlayer as a backend. Since it's a slave process rather than a decoding library, you can't just hook in arbitrary I/O backends. MPlayer only supports a minimal subset of the schemes KIOSlaves are available for. The only real workaround would require a FUSE filesystem or something else that could fool MPlayer into thinking it's doing local file I/O when it's really going through KIO.
Comment 5 Jonathan Marten 2012-02-29 13:23:24 UTC

*** This bug has been marked as a duplicate of bug 157143 ***