Bug 154836 - KMail using (online) IMAP shows one more duplicate folder entry per refresh
Summary: KMail using (online) IMAP shows one more duplicate folder entry per refresh
Status: RESOLVED DUPLICATE of bug 152756
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: SVN trunk (KDE 4)
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-29 23:56 UTC by Naga
Modified: 2007-12-30 00:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Naga 2007-12-29 23:56:30 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

When starting KMail from SVN (r747509) or when refreshing folder list, KMail adds a duplicate to each folder that I subscribe to. This leads to a looong list of folders.
*I'm using online IMAP to a Dovecot server.

Ex.

INBOX
   ...
   Drafts
   Drafts
   ...

Wireshark trace of startup leading to the first duplicate.

* OK Dovecot ready.

149 CAPABILITY

* CAPABILITY IMAP4rev1 SASL-IR SORT THREAD=REFERENCES MULTIAPPEND UNSELECT LITERAL+ IDLE CHILDREN NAMESPACE LOGIN-REFERRALS STARTTLS AUTH=PLAIN

149 OK Capability completed.

150 LOGIN "xxxx" "xxxx"

150 OK Logged in.

151 NAMESPACE

* NAMESPACE (("INBOX." ".")) NIL NIL

151 OK Namespace completed.

152 LIST "" ""

* LIST (\Noselect) "." ""

152 OK List completed.

153 STATUS "INBOX" (UNSEEN)

* STATUS "INBOX" (UNSEEN 0)

153 OK Status completed.

154 LSUB "" "INBOX.%"

...
* LSUB () "." "INBOX.Drafts"

...
154 OK Lsub completed.

155 LIST "" "INBOX.%"

...
* LIST (\HasNoChildren) "." "INBOX.Drafts"

...
155 OK List completed.

156 LIST "" "INBOX"

* LIST (\HasChildren) "." "INBOX"

156 OK List completed.

157 SELECT "INBOX"

* FLAGS (\Answered \Flagged \Deleted \Seen \Draft KMAILFORWARDED KMAILTODO KMAILWATCHED KMAILIGNORED $FORWARDED $TODO $WATCHED $IGNORED)

* OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft KMAILFORWARDED KMAILTODO KMAILWATCHED KMAILIGNORED $FORWARDED $TODO $WATCHED $IGNORED \*)] Flags permitted.

* 1836 EXISTS

* 0 RECENT

* OK [UIDVALIDITY 1179415003] UIDs valid

* OK [UIDNEXT 2490] Predicted next UID

157 OK [READ-WRITE] Select completed.

...
168 LSUB "" "INBOX.Drafts.%"

168 OK Lsub completed.

169 LIST "" "INBOX.Drafts.%"
Comment 1 Thomas McGuire 2007-12-30 00:03:20 UTC
Supposed to be fixed in rev. 754433, please update and try again.

*** This bug has been marked as a duplicate of 152756 ***