Bug 152756 - [PATCH] Duplicate folders when collapsing imap folder
Summary: [PATCH] Duplicate folders when collapsing imap folder
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Unclassified
Component: IMAP (show other bugs)
Version: SVN trunk (KDE 4)
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 154836 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-23 00:36 UTC by Frederik V
Modified: 2018-09-04 18:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Duplicate folders patch (616 bytes, patch)
2007-12-29 07:23 UTC, Ryan Winter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik V 2007-11-23 00:36:55 UTC
Version:            (using KDE KDE 3.96.0)
Installed from:    Ubuntu Packages

When collapsing an then uncollapsing a toplevel imap folder (imap account) i get another duplicate of the subfolders: e.g:
Myaccount (collapse/uncollapse)
 - kdebugs
 - kdebugs
 - kdebugs
 - rockbox
 - rockbox
 - rockbox
I don't get the standard Draft, sendt and trash folders either. 
All works in KMail for KDE3.
Comment 1 Thorsten Staerk 2007-12-07 21:53:04 UTC
Confirmed
Comment 2 Ryan Winter 2007-12-16 12:59:49 UTC
I have seen duplicated folders too.
Comment 3 Michael Braun 2007-12-28 23:36:55 UTC
Will it be solved for KDE 4.0?
Comment 4 Thomas McGuire 2007-12-28 23:44:42 UTC
> Will it be solved for KDE 4.0?

KDEPIM is not going to be released with KDE 4.0, because it has to many bugs 
(like this one).
It will be released when the worst bugs are gone, and I think this is one of 
the bugs which need to be fixed.
Comment 5 Ryan Winter 2007-12-29 07:23:15 UTC
Created attachment 22747 [details]
Duplicate folders patch
Comment 6 Thomas McGuire 2007-12-29 20:25:36 UTC
Patch looks fine, thanks very much.
I'll commit it in the next days if nobody else does it first.
Comment 7 Allen Winter 2007-12-29 21:01:37 UTC
SVN commit 754433 by winterz:

Fix bug "Duplicate folders when collapsing imap folder"
Patch by Ryan Winter (great last name, btw) :)
Thanks Ryan!
BUG: 152756



 M  +9 -17     kmfolderimap.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=754433
Comment 8 Thomas McGuire 2007-12-30 00:03:21 UTC
*** Bug 154836 has been marked as a duplicate of this bug. ***
Comment 9 Thorsten Staerk 2008-01-16 10:08:14 UTC
Verified
Comment 10 Andrew Crouthamel 2018-09-04 18:18:08 UTC
Hello! Sorry to be the bearer of bad news, but this version of Kmail has been unmaintained for many years so I am closing this bug. Please try using the latest version of Kmail to see if your issue persists. If it does, please submit a new bug in "kmail2". Thank you!