Bug 154755 - Alt key does not open menu, Alt+<key> shortcuts do not work when terminal has focus
Summary: Alt key does not open menu, Alt+<key> shortcuts do not work when terminal has...
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.7.1
Platform: Compiled Sources Linux
: NOR normal with 50 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 155925 184448 206498 248236 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-28 15:17 UTC by mutlu inek
Modified: 2012-05-04 18:18 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments
new global option for enabling menu accelerators (55.53 KB, image/png)
2012-01-22 11:20 UTC, Jekyll Wu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mutlu inek 2007-12-28 15:17:43 UTC
Version:           1.9.2 (svn r753658) (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.2.2 
OS:                Linux

When I press the "Alt" key while the terminal has focus, the menu is not opened. Also, Alt+<key> shortcuts do not work. However, the latter work if the menu is already open (i.e. has focus.
Comment 1 FiNeX 2008-01-16 23:50:58 UTC
*** Bug 155925 has been marked as a duplicate of this bug. ***
Comment 2 Rafał Miłecki 2008-02-02 19:11:10 UTC
I can confirm this (regression?) bug with Konsole 2.1 from SVN. What I wanted to say is that this bug didn't exist in Konsole 1.6.6. Maybe it is possible to check what has changed in keyboard support between 1.6.6 and 2.1 and fix this bug in some easy way?
Comment 3 mutlu inek 2008-07-27 19:22:00 UTC
This is still the case with the final 4.1 (from Arch's testing repo).
Comment 4 Robert Knight 2008-07-27 23:39:47 UTC
Yes, the fix did not make 4.1.0 but I will try to backport it for a
patch release so it should hit this Autumn's round of distro releases.

2008/7/27 mutlu inek <mutlu_inek@yahoo.de>:
[bugs.kde.org quoted mail]
Comment 5 charly ghislain 2009-01-29 00:24:31 UTC
Should the menu open, or even get focus, by pressing the alt key alone? 

IMHO, its better to keep focus on terminal until a menu shortcut (ALT+F) has been performed. Usually, a press of the alt key highlights the shortcut letter but dont give focus to menu.
As the alt key is used in a lot of global shortcuts, this would avoid unintended actions. This would also make the bug 155388 duplicate.

The bug is still present in konsole 2.2, KDE 4.2.60 (KDE 4.3 >= 20090116)
Comment 6 mutlu inek 2009-07-21 12:23:07 UTC
As far as I can tell, this bug is still there in Kopete 2.3, using KDE 4.2.96 (KDE 4.3 RC2). Robert, you had written about a patch about a year ago. If this patch has ever been applied, I am certainly not aware of any way to open the menu. The Handbook does not offer a solution, either.

I thik the idea of a second shortcut to activate the menu or adding a third modifier key would be an acceptable solution.

Thank you for your attention (and an amazing console app!).
Comment 7 mutlu inek 2009-12-21 04:56:16 UTC
This is still the case is both KDE SC 4.3.4 and KDE SC 4.4 beta 2.
Comment 8 mutlu inek 2010-06-07 10:57:16 UTC
The bug appears to still be there in KDE SC 4.5 beta 2 (4.4.82).
Comment 9 Shriramana Sharma 2011-06-13 13:06:01 UTC
Bug persists in Kubuntu Natty KDE 4.6.2. 

Really, while not allowing Alt+[Key] shortcuts to access the menu is quite understandable, why can't just hitting Alt and releasing push the focus to the menu after which the user can navigate using the cursor keys? 

Come on guys, please look into this! Thanks! :) 

[If I had enough C++/Qt/KDE experience I would submit a patch, but I don't, so I have to rely on you experts to do it!]
Comment 10 Jekyll Wu 2011-07-24 20:10:19 UTC
My current wrokaround is to setup the shortcut of 'Activate menu' to 'Alt+F'. Then I can use that to activate the menu and use arrow keys to navigate.

That works well for me with 2.7.999
Comment 11 Kurt Hindenburg 2011-07-27 13:18:47 UTC
Is the ability to make a shortcut to open the menu not enough?
Comment 12 Kurt Hindenburg 2011-07-27 13:19:09 UTC
*** Bug 248236 has been marked as a duplicate of this bug. ***
Comment 13 Kurt Hindenburg 2011-07-28 12:39:43 UTC
*** Bug 206498 has been marked as a duplicate of this bug. ***
Comment 14 Jekyll Wu 2011-07-30 13:40:06 UTC
*** Bug 184448 has been marked as a duplicate of this bug. ***
Comment 15 Elias Probst 2011-09-10 07:51:39 UTC
Still valid for Konsol 2.7.1 in KDE SC 4.7.1
Comment 16 Jekyll Wu 2011-09-11 11:22:59 UTC
(In reply to comment #15)
> Still valid for Konsol 2.7.1 in KDE SC 4.7.1

There is the "Activate Menu" action in the shortcuts dialog. I think it works very well for the problem mentioned in this report.
Comment 17 rottex 2011-10-02 17:12:43 UTC
Well I think, with this menu activation workaround we will not hit the jackpot.
Without properly being able to access the menu items it's rather boring...

For instance I have a lot of commands and locations in bookmarks menu (which I like meanwhile pretty much !)

If I want to access a bookmark via keyboard I have to:

1) Ctrl-Shift-10 (3 keystrokes) or some other shortcut (at least 2 keystrokes).
2) 4 times cursor-right key (because the first item in view-menu has a sub-menu.
3) again 4 times cursor-down in order to hop over the config lines for bookmarks
   (which I use infrequently)
4) the necessary cursor-down-strokes for my selection.

So at least 10 keys to much.

a) Please provide a way to set a shortcut for bookmarks or all the main-menu items straight away, like a normal user is used to it...)
b) Please move the configuration stuff (add bookmark, ...) to the bottom of the bookmarks sub-menu

or c) maybe it is possible to provide a possibility to assign shortcuts to bookmark-entries straight away ?!

Please reconsider. THX
Comment 18 Jekyll Wu 2012-01-22 11:20:18 UTC
Created attachment 68086 [details]
new global option for enabling menu accelerators

In Konsole 2.9 or KDE SC 4.9, there will be a "Configure Konsole" dialog for various global options, and one of them is whether enabling menu accelerators (disabling is the default behavior, the same as now). I think that solves the main problem in this report.

(In reply to comment #17)

rottex, your problem sounds similar to bug 284555. Please follow that report or open another report for your problem and suggestion.
Comment 19 mutlu inek 2012-05-04 18:18:52 UTC
Awesome, that you!