Bug 154550 - Underline below hyperlink does not disappear when terminal is scrolled
Summary: Underline below hyperlink does not disappear when terminal is scrolled
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.9
Platform: Compiled Sources Linux
: NOR minor with 150 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 154012 222937 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-23 20:32 UTC by Akarsh Simha
Modified: 2017-11-07 17:31 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Akarsh Simha 2007-12-23 20:32:49 UTC
Version:           3.97.1 (using KDE Devel)
Installed from:    Compiled sources
Compiler:          g++ 4.2.3 
OS:                Linux

To reproduce this:

1. Open a terminal tab listing a lot of hyperlinks
2. Hover on any hyperlink, it is underlined.
3. Scroll the terminal, either using the keyboard
4. The underline remains as it is

Another related problem:

1. Open a terminal tab listing a lot of hyperlinks
2. Hover on any hyperlink, it is underlined.
3. Scroll the terminal using the mouse's scroll buttons
4. The underline moves along with the link but does not vanish
5. Hovering on another link now creates another underline below it
Comment 1 FiNeX 2007-12-24 11:31:59 UTC
Confirmed on revision 752242.
Comment 2 BeteNoire 2008-11-04 15:07:40 UTC
I can confirm this strange Konsole behavior in Konsole 4.1.2 compiled on three different computers.
Comment 3 Kurt Hindenburg 2009-01-04 01:38:09 UTC
*** Bug 154012 has been marked as a duplicate of this bug. ***
Comment 4 Kurt Hindenburg 2009-01-04 01:40:06 UTC
Here's Robert's explanation for this (from bug 154012)

Confirmed.  The reason for this bug is that the information about 'hot spots'
(areas of the display containing text of interest) is not updated, for
performance reasons, until the mouse is moved after a change in the display's
contents.
---
So until you move the mouse the screen won't be updated.
Comment 5 Pykler 2009-05-21 00:50:23 UTC
Hi,

I have also seen this issue and signed up to report it. I am not sure about the screen not updating, but definetly the underlines are not updated. Could it be possible that the underline is overlayed ontop of the screen rather than printed along with the text.

Here is how I found the bug.

 1. Start `konsole`
 1. run `screen`
 1. type: http://bugs.kde.org
 1. Hover with the mouse, over the URL such that it is underlined
 1. press Ctrl-a + c
 1. The underline is still there
Comment 6 Jekyll Wu 2011-08-16 07:01:49 UTC
*** Bug 222937 has been marked as a duplicate of this bug. ***
Comment 7 Von Random 2013-09-26 09:08:15 UTC
still present
Comment 8 George 2014-06-20 17:49:12 UTC
I am experiencing the same but in 14.04 LTS

My specific experience with this bug on a tri-head two video card system (both nvidia running open source driver) is as follows:

When konsole is on primary video card display the problem does not present itself.

When konsole is on secondary video card display the problem is absolute and the screen does not refresh until the mouse moves on the screen or a key is pressed.

When the konsole spans Primary->Secondary monitors, the portion of the window on the primary display updates immediately whereas the portion of the window on the secondary display only updates as described above (on mouse event etc).

I hope this helps someone smarter than I figure out the issue!