Bug 153376 - right click on tab doesn't open context menu anymore
Summary: right click on tab doesn't open context menu anymore
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 257 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 153248 161083 163972 164100 185108 186120 194431 199477 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-03 22:24 UTC by Tobias Powalowski
Modified: 2010-10-20 20:16 UTC (History)
20 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Preliminary Patch to Add a Context Menu (5.85 KB, patch)
2010-01-08 16:45 UTC, Shlomi Fish
Details
A Newer Patch that also adds "Rename Session". (6.49 KB, patch)
2010-01-08 18:11 UTC, Shlomi Fish
Details
Patch that corrects the issues. (6.29 KB, patch)
2010-01-09 20:17 UTC, Shlomi Fish
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Powalowski 2007-12-03 22:24:15 UTC
Version:           3.96.2 (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.2.2 
OS:                Linux

In kde 3.5.8 it was possible to get a menu about closing and such things on konsoles tab, by clicking with the right mouse on it.
This is not in kde 3.96.2 anymore, bug or feature?
Comment 1 Robert Knight 2007-12-11 05:03:14 UTC
> This is not in kde 3.96.2 anymore, bug or feature? 

Neither really.  This a request for enhancement, marking as a wishlist item.  
Comment 2 Robert Knight 2007-12-11 05:22:07 UTC
*** Bug 153248 has been marked as a duplicate of this bug. ***
Comment 3 Robert Knight 2008-05-23 22:25:16 UTC
*** Bug 161083 has been marked as a duplicate of this bug. ***
Comment 4 FiNeX 2008-06-13 16:51:33 UTC
*** Bug 163972 has been marked as a duplicate of this bug. ***
Comment 5 Robert Knight 2008-06-14 22:06:52 UTC
*** Bug 164100 has been marked as a duplicate of this bug. ***
Comment 6 Panagiotis Papadopoulos 2008-09-13 00:43:10 UTC
Will this ever be implemented?
Because I think it is a great idea
Comment 7 Jiri Tyr 2008-11-10 17:05:18 UTC
I am missing this menu as well. Please implement it in the new Konsole.
Comment 8 Pedro Morgan 2008-11-10 17:23:41 UTC
I also expect and miss this menu. Would be possible to implement it please. TIA.
Comment 9 FiNeX 2008-11-10 17:29:32 UTC
To all people which would like this feature, please vote for it :-)
Comment 10 Kurt Hindenburg 2009-03-04 18:07:51 UTC
*** Bug 185108 has been marked as a duplicate of this bug. ***
Comment 11 Kurt Hindenburg 2009-03-04 18:08:04 UTC
*** Bug 186120 has been marked as a duplicate of this bug. ***
Comment 12 FiNeX 2009-07-08 22:41:23 UTC
*** Bug 194431 has been marked as a duplicate of this bug. ***
Comment 13 FiNeX 2009-07-08 22:41:31 UTC
*** Bug 199477 has been marked as a duplicate of this bug. ***
Comment 14 Giorgos Pallas 2009-10-13 12:43:17 UTC
But it was there! Why it disappeared???
Comment 15 mark 2009-11-05 02:19:36 UTC
I voted for this bug as well. I currently prefer Konsole 3.5.x to the 4.x series because it has this feature. 

This has been classified as a "wishlist" item, but I think many of us see it as a regression-- a useful feature is now absent. The 3 options I used frequently were:  Monitor for Silence, Monitor for Activity and Rename Tab.  Sure, there are other ways to do this, but the ability to right-click on the tab was convenient and familiar.
Comment 16 oneforall 2009-11-05 08:37:22 UTC
I agree, there is a difference with a wish for a new feature , compared to something that was always there and is now missing. The renaming feature all and just the fact you were on the tab you want to do these things to. So your not accidentally changing the wrong one too
Comment 17 revola 2009-11-05 09:17:34 UTC
I do agree with the last 2 comments. From my point of view it was really easiest to rightclick on tabs to get some features like rename or monitor.

Any chance we could see this re-implemented in konsole 4.x ?
Comment 18 Shlomi Fish 2009-11-23 10:34:25 UTC
I agree that this feature should be implemented as well. It's a regression from earlier konsoles.
Comment 19 p 2009-12-09 14:57:07 UTC
yes it got my votes. This request is more than 2 years old! all what is needed is a context menu which calls the same actions than in the normal menu, doesn't sound like a high effort. Does that mean entering wishes, comments, votes is just a waste of time?
Comment 20 oneforall 2009-12-11 17:46:33 UTC
yeah another thing thats MISSING is not a darn wish. So it shouldn't be on the wish list but delt with as a regression/bug period. So many great feature that are gone. :(
Comment 21 mark 2009-12-11 19:11:02 UTC
> Does that mean entering wishes, comments, votes is just a waste of time?

I think the next step is either for one of the commenters to volunteer to address the issue, or to track down a specific Konsole contributor, and ask them nicely about the possibility. You can review the "Changes" file or the source code commit logs to find out who has been contributing to Konsole recently. You might also ask politely on the developer mailing list.
Comment 22 p 2009-12-14 11:01:51 UTC
No idea how to look that up. I would do it if I knew how. Though, what is the point of having a bugzilla if one has to beg via e-mail? Can someone post how to exactly look up these possible contributors?
Comment 23 Robert Knight 2009-12-14 12:44:47 UTC
> Though, what is the point of having a bugzilla if one has to beg via e-mail?

Bugzilla is indeed the right place to make feature requests.  reviewboard.kde.org is the right place to submit patches to fix bugs or add features.
Comment 24 mark 2009-12-14 15:41:11 UTC
> Robert Knight <robertknight@gmail.com> changed:

Robert,

Thanks for the clarification. 

Are you the same person as the "knight" user that's seen as a recent
Konsole committer here?

 http://websvn.kde.org/trunk/KDE/kdebase/apps/konsole/src/

If you are a Konsole committer, your feedback on this change request
would be appreciated. 

   Mark
Comment 25 Robert Knight 2009-12-14 19:54:16 UTC
> Are you the same person as the "knight" user that's
> seen as a recent Konsole committer here?

Yes.  Kurt Hindenburg and myself have been the most active developers of Konsole over the past few years, although I'm not doing a lot of work on it at the moment - though I do try to review any patches that get posted.

I have no objections to adding a right-click menu to the tabs.  I'm not able to promise that I will do it myself soon though, though I will try to find the time to review a patch if one is produced.
Comment 26 Shlomi Fish 2010-01-08 16:45:38 UTC
Created attachment 39694 [details]
Preliminary Patch to Add a Context Menu

This is a preliminary patch against the svn trunk that adds a context menu with two items - "Detach Session" and "Close Session". It is made against:

svn://anonsvn.kde.org/home/kde/trunk/KDE/kdebase/apps/konsole

Regards,

-- Shlomi Fish
Comment 27 Shlomi Fish 2010-01-08 18:11:45 UTC
Created attachment 39695 [details]
A Newer Patch that also adds "Rename Session".

This is a newer patch that also adds rename session.
Comment 28 Robert Knight 2010-01-08 18:34:23 UTC
Hello,

Please post this patch on reviewboard.kde.org.

Some initial comments:

* ViewContainer::_contextMenuTabIndex needs to be initialized in the ViewContainer constructor
* kDebug() should be used if you need debugging information (in ViewManager::detachView())
* I think you can leave out the dynamic_cast in TabbedViewContainer::contextMenuTabDetach()
* The temporary memory leak from the QMenu which is created but not later destroyed needs to be fixed as per the TODO comment
* I suggest renaming the TabbedViewContainer::contextMenuTabRename() method to TabbedViewContainer::contextMenuRenameTab() (and likewise for the other context menu methods)
* When specifying types in SLOT() arguments you can leave out the 'const' and '&' parts of 'const T&'.  eg.  'SLOT(contextMenu(int, const QPoint &))' can be more compactly written as 'SLOT(contextMenu(int,QPoint))'
* The captions of the context menu items need to match those in the main menus.  eg. 'Rename Tab' instead of 'Rename Session'.  For consistency I would suggest changing the caption of the detach action to 'Detach Tab' in both the main menu and in the context menu.
* Re these lines:               

TabbedViewContainer * tabbedContainer;
container = tabbedContainer = 
 new TabbedViewContainer(position,_viewSplitter);

The 'tabbedContainer' variable is unnecessary since QObject::connect() uses duck-typing.  You can pass it a pointer of type ViewContainer (the 'container' variable) and still connect a signal or slot which is specific to a sub-class of ViewContainer.
Comment 29 Shlomi Fish 2010-01-09 20:17:33 UTC
Created attachment 39718 [details]
Patch that corrects the issues.

This is a patch in response to Robert Knight's comments, which fixes all the issues he pointed to. It was also posted on reviewboard
Comment 30 mark 2010-03-08 17:18:02 UTC
Has there been any update on this since it was submitted for review 2 months ago? 

I'm hoping the updates still have time to make there way into the Ubuntu/Kubuntu release coming out in April.
Comment 31 Robert Knight 2010-03-08 19:47:49 UTC
I'm afraid it is too late for Lucid.  The KDE packagers will only be accepting fixes for critical bugs now.
Comment 32 p 2010-04-06 21:57:48 UTC
Does anyone know when this regression is fixed? The discussed fix should be in by now, shouldnt it? KDE 4.4.2 still has the same issue. Thanks.
Comment 33 Shlomi Fish 2010-04-17 13:55:46 UTC
(In reply to comment #32)
> Does anyone know when this regression is fixed? The discussed fix should be in
> by now, shouldnt it? KDE 4.4.2 still has the same issue. Thanks.

I second that. Please review the patch. I didn't include the "monitor session" / "demonitor session" menu entries in the context-menu due to laziness, but it's still much better than nothing. So please look into the patch and hopefully apply it. I am willing to give any further assistance as necessary, but believe the patch is pretty solid.
Comment 34 Kurt Hindenburg 2010-04-17 21:49:37 UTC
SVN commit 1115877 by hindenburg:

Implement 'Rename Tab...' and 'Close Tab' in tab context menu.
Original patch by Shlomi Fish.  I did some hacking on it and removed 'Detach Tab' option for this commit.

CCBUG: 153376


 M  +40 -2     ViewContainer.cpp  
 M  +6 -1      ViewContainer.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1115877
Comment 35 Shlomi Fish 2010-04-17 22:13:47 UTC
Hi!

Thanks for commiting the patch. I hope we'll see it in KDE-4.5.x.

(In reply to comment #34)
> SVN commit 1115877 by hindenburg:
> 
> Implement 'Rename Tab...' and 'Close Tab' in tab context menu.
> Original patch by Shlomi Fish.  I did some hacking on it and removed 'Detach
> Tab' option for this commit.

May I ask why did you remove the "Detach Tab" option? Are you planning on adding it later? 

Regards,

-- Shlomi Fish



> 
> CCBUG: 153376
> 
> 
>  M  +40 -2     ViewContainer.cpp  
>  M  +6 -1      ViewContainer.h  
> 
> 
> WebSVN link: http://websvn.kde.org/?view=rev&revision=1115877
Comment 36 Kurt Hindenburg 2010-04-17 22:22:25 UTC
#35 - It will be in KDE 4.5;  the code for 'Detach Tab' was a bit more complex then the above.  I just wanted to separate them to make it easier for me.  It should be committed for 4.5 also.
Comment 37 Shlomi Fish 2010-04-17 22:24:56 UTC
(In reply to comment #36)
> #35 - It will be in KDE 4.5;  the code for 'Detach Tab' was a bit more complex
> then the above.  I just wanted to separate them to make it easier for me.  It
> should be committed for 4.5 also.

OK, thanks for the reply.
Comment 38 mark 2010-04-19 15:27:45 UTC
> I second that. Please review the patch. I didn't include the "monitor session"
> / "demonitor session" menu entries in the context-menu

I hope these can re-appear over time. I use them regularly. 

   Mark
Comment 39 Shlomi Fish 2010-04-23 15:04:58 UTC
(In reply to comment #38)
> > I second that. Please review the patch. I didn't include the "monitor session"
> > / "demonitor session" menu entries in the context-menu
> 
> I hope these can re-appear over time. I use them regularly. 
> 

Sure, I guess I can try to add them, at least after the detach tab code was integrated. I didn't bother adding them at first because they appeared hard-to-implement and because I never used them myself. 

Regards,

-- Shlomi Fish
>    Mark
Comment 40 Kurt Hindenburg 2010-04-26 03:54:05 UTC
The only issue I see with the detach menu is that you can still detach a tab even it is the only one.

It still works but is kinda awkward.

If you want other menu items please create separate wish lists.
Comment 41 Kurt Hindenburg 2010-04-26 04:06:09 UTC
SVN commit 1118851 by hindenburg:

Add 'Detach Tab' to the tab context menu.

Original patch by Shlomi Fish.  I did some hacking on it.

BUG: 153376


 M  +9 -0      ViewContainer.cpp  
 M  +5 -0      ViewContainer.h  
 M  +24 -7     ViewManager.cpp  
 M  +2 -0      ViewManager.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1118851
Comment 42 p 2010-10-20 12:24:00 UTC
Hi, I don't think that this is resolved. In KDE 4.5.2 I still cannot use the context menu to create a new tab. This is still a regression to KDE 3.
Comment 43 Shlomi Fish 2010-10-20 20:16:37 UTC
(In reply to comment #42)
> Hi, I don't think that this is resolved. In KDE 4.5.2 I still cannot use the
> context menu to create a new tab. This is still a regression to KDE 3.

In this bug, we discussed the context menu of an individual tab - not of the unoccupied space in the tab bar. You can still create a new tab by pressing the "new tab" button or double clicking the tab bar. If you still miss that context menu, then file a new bug. (And CC me on it.)