Bug 152266 - toolbar icon size gets lost
Summary: toolbar icon size gets lost
Status: RESOLVED DUPLICATE of bug 168480
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_icons (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Marie Loise Nolden
URL:
Keywords:
: 155888 155889 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-13 19:55 UTC by René Buffat
Modified: 2009-01-02 17:41 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Buffat 2007-11-13 19:55:11 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.1.2 
OS:                Linux

tested with konqueror and dolpin after a clean .kde directory:

After I have selected "Only Icons" for the toolbar, then "Default Icon size", there aren't any icons displayed anymore. Now, under Systemsettings > Apperance > Icons > Advanced the select box for size is empty. (The select wehre you can normally select values like 22,32,48...)

This message is shown several times in the konsole where I started Dolphin from: 
QPainter::begin: Cannot paint on a null pixmap
Comment 1 Will Stephenson 2007-12-02 16:04:47 UTC
Works for me with today's SVN, can you reproduce with RC1 or newer?
Comment 2 René Buffat 2007-12-03 01:04:15 UTC
I updated to todays svn and I can say that definitely something dosen't work like it should by me. I removed the .kde directory and the first thing I did was setting in systemsetting the default Iconsize from the Toolbar and the Main Toolbar to 32. Then I started Konqueror, it has the Medium Icon size as default. If I change to "default" it is set to medium again when I open the menu the second time. If I changed randomly to different Icon sizes with the right-click menu in Konqueror, sometimes it changes to the right size, sometimes not.

Comment 3 Ivo Anjo 2007-12-19 18:56:56 UTC
I think I'm also seeing this. I set my icon size on systemsettings, and it simply gets ignored by the applications.
Comment 4 Christoph Feck 2008-06-24 16:43:44 UTC
*** Bug 155888 has been marked as a duplicate of this bug. ***
Comment 5 FiNeX 2008-06-26 15:11:20 UTC
About kde and dolphin, actually they remember the settings.

About Comment #3, global settings are not used by applications yet.
Comment 6 Peter Paulsen 2008-07-30 12:51:08 UTC
Even in KDE 4.1.00 applications don't remember the toolbar icon size. I have to set it again to 32x32 after every login in every application!
Comment 7 Dario Andres 2008-07-30 21:47:22 UTC
May be related to bug 167280 and bug 167659
Comment 8 bgn66922 2008-08-11 10:38:33 UTC
Same problem here on KDE 4.1.0.
Hope to be fixed soon.
Comment 9 Daniel Dumitrache 2008-09-04 21:51:15 UTC
I can confirm this bug on KDE 4.1.1 (Ubuntu packages)
Comment 10 Janet 2008-09-07 22:10:36 UTC
I can confirm this for KDE 4.1.1 Debian Experimental packages too. I have to change the icon size to 32x32 every start of every application. In kontact the size of some toolbars (calendar: day, week, month etc. & akregator part: back, forward, refresh) even doesn't persist when changing from one kontact part to another.  

Are you sure this is a systemsettings bug? Isn't it up to something else like kdelibs or so to make the applications remember their toolbar icon size settings? When I set the toolbar size to 48 in konq and 32 in dolphin (and it is not remembered) this has nothing to do with systemsettings. 

Is this bug report about two different things? a) the totally ignored global toolbar size setting (systemsettings) and b) the toolbar size setting per application which works but isn't remembered? Do both things go together so that Bug 167280 is a duplicate of this one?
Comment 11 Jeremy Kerr 2008-11-03 00:26:52 UTC
Same problem here, on KDE 4.1.2 (kubuntu packages):

 * Application toolbars don't respect the global toolbar icon size setting
 * After manually changing the icon size in a specific application, the setting
   is reset when the application is restarted.
Comment 12 Dario Andres 2009-01-02 14:38:23 UTC
*** Bug 155889 has been marked as a duplicate of this bug. ***
Comment 13 Dario Andres 2009-01-02 14:41:33 UTC
Here using:

Qt: 4.4.3 + qt-copy-patches-889120
KDE: 4.1.86 (KDE 4.1.86 (KDE 4.2 >= 20081221))
kdelibs svn rev. 904448 / kdebase svn rev. 904448
on ArchLinux x86_64 - Kernel 2.6.27.10

The apps remember their toolbar icon size after restart. Can anyone else
confirm this with a recent KDE 4.2 build ? Thanks
Comment 14 George Kiagiadakis 2009-01-02 17:41:38 UTC

*** This bug has been marked as a duplicate of bug 168480 ***