Bug 149441 - kmail deletes all emails in inbox when I check for new mail with IMAP
Summary: kmail deletes all emails in inbox when I check for new mail with IMAP
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: enterprise
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 149749 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-01 04:37 UTC by Aaron Williams
Modified: 2018-09-04 18:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Williams 2007-09-01 04:37:32 UTC
Version:           1.9.6 (enterprise 20070731.694771) (using KDE 3.5.7 "release 69.1" , openSUSE )
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.18.8-0.5-default

Sometimes when I check for new mail in Kmail it will suddenly begin deleting all emails in my inbox. I am connecting to an Exchange 2003 server. I have all email filters disabled as well.

The emails are quickly deleted from the inbox, but if I kill Kmail and restart it, all of my emails are fine. This does not happen all of the time, but maybe 10-25% of the time.

If Imap would just work with Kmail like it does with Thunderbird, I'd drop Thunderbird in an instant!
Comment 1 Thomas McGuire 2007-09-05 15:59:43 UTC
Does this happen with the normal KMail version (1.9.7) as well or only with the enterprise version?

So the mails are not deleted, but just not shown in KMail, right?

Could this be the same problem as in bug 122621?
Comment 2 Aaron Williams 2007-09-05 22:10:52 UTC
Not quite the same. The emails are just deleted from within Kmail, but I can actively watch it delete the emails.

As far as I know I am running the normal version (whatever is included with OpenSuSE 10.2), though I have used the latest from SuSE's repository (3.5.7.x)
Comment 3 Björn Ruberg 2010-01-10 23:30:15 UTC
Does this still happen for you with a recent kmail version?
Comment 4 Björn Ruberg 2010-01-10 23:37:46 UTC
*** Bug 149749 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Crouthamel 2018-09-04 18:23:15 UTC
Hello! Sorry to be the bearer of bad news, but this version of Kmail has been unmaintained for many years so I am closing this bug. Please try using the latest version of Kmail to see if your issue persists. If it does, please submit a new bug in "kmail2". Thank you!