Bug 148217 - kmail crashes when moving an imap folder with subfolders to another imap subfolder
Summary: kmail crashes when moving an imap folder with subfolders to another imap subf...
Status: RESOLVED DUPLICATE of bug 143627
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.7
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-26 09:59 UTC by Sebastian Reitenbach
Modified: 2007-07-26 17:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Reitenbach 2007-07-26 09:59:59 UTC
Version:           1.9.7 (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
OS:                Linux

I am on openSUSE 10.2, i586
I was moving an imap folder that contains two subfolders to another imap folder. After a short time later, kmail crashed with the following backtrace:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1248799024 (LWP 3296)]
[New Thread -1278936176 (LWP 3303)]
[New Thread -1270543472 (LWP 3302)]
[New Thread -1262150768 (LWP 3301)]
[New Thread -1253758064 (LWP 3300)]
[KCrash handler]
#9  0xb7cd2aa7 in KMFolderNode::parent ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb7c3480b in KMFolderTree::writeIsListViewItemOpen ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0xb7c35046 in KMFolderTree::reload ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb7c2b82c in KMFolderTree::doFolderListChanged ()
   from /opt/kde3/lib/libkmailprivate.so
#13 0xb7c34563 in KMFolderTree::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#14 0xb7363e81 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb7364b5d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb7ccfea9 in KMFolderMgr::changed ()
   from /opt/kde3/lib/libkmailprivate.so
#17 0xb7ccff68 in KMFolderMgr::contentsChanged ()
   from /opt/kde3/lib/libkmailprivate.so
#18 0xb7cd21c6 in KMFolderMgr::removeFolderAux ()
   from /opt/kde3/lib/libkmailprivate.so
#19 0xb7cd2351 in KMFolderMgr::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#20 0xb7363f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb7c874e8 in KMFolder::removed () from /opt/kde3/lib/libkmailprivate.so
#22 0xb7c882cf in KMFolder::qt_emit () from /opt/kde3/lib/libkmailprivate.so
#23 0xb7363f61 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb7ca5308 in FolderStorage::removed ()
   from /opt/kde3/lib/libkmailprivate.so
#25 0xb7ca7f07 in FolderStorage::remove ()
   from /opt/kde3/lib/libkmailprivate.so
#26 0xb7d41cef in KMFolderImap::slotRemoveFolderResult ()
   from /opt/kde3/lib/libkmailprivate.so
#27 0xb7d486dc in KMFolderImap::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#28 0xb7363f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb62e86fe in KIO::Job::result () from /opt/kde3/lib/libkio.so.4
#30 0xb632b17d in KIO::Job::emitResult () from /opt/kde3/lib/libkio.so.4
#31 0xb632b5ee in KIO::SimpleJob::slotFinished ()
   from /opt/kde3/lib/libkio.so.4
#32 0xb632ad11 in KIO::SimpleJob::qt_invoke () from /opt/kde3/lib/libkio.so.4
#33 0xb7363f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb7364b5d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb62e43bc in KIO::SlaveInterface::finished ()
   from /opt/kde3/lib/libkio.so.4
#36 0xb6354cd0 in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#37 0xb634489a in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#38 0xb62f9a1c in KIO::Slave::gotInput () from /opt/kde3/lib/libkio.so.4
#39 0xb6345fc0 in KIO::Slave::qt_invoke () from /opt/kde3/lib/libkio.so.4
#40 0xb7363f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0xb7364a62 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0xb769fe80 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb7382150 in QSocketNotifier::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0xb73049c7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0xb7305791 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0xb79bb202 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#47 0xb72f9371 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0xb72b3b74 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0xb731b7f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0xb731b686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0xb730457f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#52 0x0804a0fb in main ()
Comment 1 Sebastian Reitenbach 2007-07-26 10:04:31 UTC
and it happened again, with the same backtrace, moving another folder, without subfolders.

The IMAP server I am connected to is a cyrus:
cyrus-imapd-2.2.13p0, running on OpenBSD 4.0
Comment 2 Thomas McGuire 2007-07-26 17:32:19 UTC

*** This bug has been marked as a duplicate of 143627 ***