Bug 143627 - KMail crashed when creating a new IMAP folder (debug backtrace)
Summary: KMail crashed when creating a new IMAP folder (debug backtrace)
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.6
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 148217 157847 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-30 12:25 UTC by Daniel Hahler
Modified: 2010-01-22 00:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Hahler 2007-03-30 12:25:05 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages

I've deleted a folder with subfolders (all empty) from an IMAP account and straight afterwards created a new folder on another IMAP account.

KMail crashed:
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1250646320 (LWP 20343)]
[New Thread -1281516656 (LWP 20348)]
[New Thread -1273123952 (LWP 20347)]
[New Thread -1264731248 (LWP 20346)]
[New Thread -1256338544 (LWP 20345)]
[KCrash handler]
#6  KMFolderNode::parent (this=0xbfb5089c)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfoldernode.cpp:45
#7  0xb7dbfc5b in KMFolderTree::writeIsListViewItemOpen (this=0x86ffac8, 
    fti=0x91bc628) at /build/buildd/kdepim-3.5.6/./kmail/kmfoldertree.cpp:1225
#8  0xb7dc0866 in KMFolderTree::reload (this=0x86ffac8, openFolders=false)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfoldertree.cpp:523
#9  0xb7b795cc in KMFolderTree::doFolderListChanged (this=0x86ffac8)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfoldertree.cpp:742
#10 0xb7dd34c0 in KMFolderTree::qt_invoke (this=0x86ffac8, _id=121, 
    _o=0xbfb509fc) at ./kmfoldertree.moc:475
#11 0xb7046940 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb70472b8 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb7ba26f9 in KMFolderMgr::changed (this=0x81fa9f0)
    at ./kmfoldermgr.moc:140
#14 0xb7ba27b8 in KMFolderMgr::contentsChanged (this=0x2f0065)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfoldermgr.cpp:397
#15 0xb7d856b6 in KMFolderMgr::removeFolderAux (this=0x81fa9f0, 
    aFolder=0x851de08, success=true)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfoldermgr.cpp:372
#16 0xb7d85841 in KMFolderMgr::qt_invoke (this=0x81fa9f0, _id=4, 
    _o=0xbfb50b50) at ./kmfoldermgr.moc:247
#17 0xb7046813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#18 0xb7bc0a98 in KMFolder::removed (this=0x851de08, t0=0x851de08, t1=true)
    at ./kmfolder.moc:349
#19 0xb7cb8b7d in KMFolder::qt_emit (this=0x851de08, _id=17, _o=0xbfb50c40)
    at ./kmfolder.moc:389
#20 0xb70467e7 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#21 0xb7bbf338 in FolderStorage::removed (this=0x85228d0, t0=0x851de08, 
    t1=true) at ./folderstorage.moc:415
#22 0xb7db3eb2 in FolderStorage::remove (this=0x85228d0)
    at /build/buildd/kdepim-3.5.6/./kmail/folderstorage.cpp:740
#23 0xb7db3fb4 in KMFolderImap::slotRemoveFolderResult (this=0x85228d0, 
    job=0x9127950) at /build/buildd/kdepim-3.5.6/./kmail/kmfolderimap.cpp:251
#24 0xb7e43f6c in KMFolderImap::qt_invoke (this=0x85228d0, _id=33, 
    _o=0xbfb50e24) at ./kmfolderimap.moc:326
#25 0xb7046813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#26 0xb59ba58e in KIO::Job::result (this=0x9127950, t0=0x9127950)
    at ./jobclasses.moc:162
#27 0xb59fcf6d in KIO::Job::emitResult (this=0x9127950)
    at /build/buildd/kdelibs-3.5.6/./kio/kio/job.cpp:235
#28 0xb59fd3ce in KIO::SimpleJob::slotFinished (this=0x9127950)
    at /build/buildd/kdelibs-3.5.6/./kio/kio/job.cpp:601
#29 0xb59fcb01 in KIO::SimpleJob::qt_invoke (this=0x9127950, _id=7, 
    _o=0xbfb5102c) at ./jobclasses.moc:417
#30 0xb7046813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#31 0xb70472b8 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#32 0xb59b5b1c in KIO::SlaveInterface::finished (this=0x87454e8)
    at ./slaveinterface.moc:226
#33 0xb5a1a970 in KIO::SlaveInterface::dispatch (this=0x87454e8, _cmd=104, 
    rawdata=@0xbfb51240)
    at /build/buildd/kdelibs-3.5.6/./kio/kio/slaveinterface.cpp:243
#34 0xb5a22f0a in KIO::SlaveInterface::dispatch (this=0x87454e8)
    at /build/buildd/kdelibs-3.5.6/./kio/kio/slaveinterface.cpp:173
#35 0xb59c9e8c in KIO::Slave::gotInput (this=0x87454e8)
    at /build/buildd/kdelibs-3.5.6/./kio/kio/slave.cpp:300
#36 0xb5a13410 in KIO::Slave::qt_invoke (this=0x87454e8, _id=4, _o=0xbfb51368)
    at ./slave.moc:113
#37 0xb7046813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#38 0xb704712a in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#39 0xb73d36b3 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#40 0xb70693d2 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#41 0xb6fdd9e8 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#42 0xb6fdf817 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#43 0xb7719ce2 in KApplication::notify (this=0xbfb51a14, receiver=0x87549c8, 
    event=0xbfb51698)
    at /build/buildd/kdelibs-3.5.6/./kdecore/kapplication.cpp:550
#44 0xb6f701e9 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#45 0xb6fcfde1 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#46 0xb6f84d07 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#47 0xb6ff80be in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#48 0xb6ff7ece in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#49 0xb6fdf591 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#50 0x0804a2de in main (argc=-1208846520, argv=0xb78dc1c2)
    at /build/buildd/kdepim-3.5.6/./kmail/main.cpp:110
#51 0xb77b3ebc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#52 0x0804a041 in _start ()
Comment 1 Thomas McGuire 2007-07-26 17:32:22 UTC
*** Bug 148217 has been marked as a duplicate of this bug. ***
Comment 2 Thomas McGuire 2008-02-15 16:20:56 UTC
*** Bug 157847 has been marked as a duplicate of this bug. ***
Comment 3 Björn Ruberg 2010-01-04 01:05:45 UTC
Can you still reproduce this in recent kmail?
Comment 4 Daniel Hahler 2010-01-22 00:19:08 UTC
I'm not sure if it was reproducible before, therefore I cannot say if it still is.

FWIW, I've just created a new folder, two empty folders in there, deleted the parent folder and then created another folder on another account. No crash happened.
This is probably fixed with the IMAP improvements/fixes being done.