Bug 148010 - kmail screws up imap folder and uploads a bunch of message data
Summary: kmail screws up imap folder and uploads a bunch of message data
Status: RESOLVED DUPLICATE of bug 125084
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.7
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-19 09:02 UTC by Aaron Williams
Modified: 2007-07-19 21:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Williams 2007-07-19 09:02:22 UTC
Version:           1.9.7 (using KDE 3.5.7 "release 56.1" , openSUSE )
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.18.8-0.3-default

It seems every time I start up KMail and click on one of my Imap accounts it uploads a ton of messages and tends to screw up all the email dates when sorting. It also causes duplicate messages to appear on the Imap server.

I have seen this with several KDE installations with earlier versions as well and with different IMAP servers.

I am seeing this with both Cyrus and Exchange.  If this Imap problem could be fixed, I'd dump Thunderbird in an instant.
Comment 1 Aaron Williams 2007-07-19 09:16:43 UTC
On further inspection, it looks like it is downloading emails and uploading them back after deleting the original.  This seems to cause problems with sorting, especially with pine, though I have seen it also affect Thunderbird. Kmail also is screwed up from then on with the sorting order, with older emails appearing as the latest when they are often several weeks old.

Also note that I alternate between imap mail clients and sometimes have more than one active at a time.
Comment 2 Thomas McGuire 2007-07-19 17:42:34 UTC
Are you using filters?
If so, this is probably the same as bug 125084.
Comment 3 Aaron Williams 2007-07-19 18:26:23 UTC
I am running Sieve on the Cyrus mail server but I also have what looks like are the default filters, Bogofilter Check, Spam handling, Classify as spam and Classify as NOT spam.  I guess I can disable the filters since the mail is filtered by the server which catches most of it.
Comment 4 Thomas McGuire 2007-07-19 21:41:45 UTC
Ah yes, that is either bug 125084 or bug 134802.

*** This bug has been marked as a duplicate of 125084 ***