Bug 134802 - Spam filter downloads&uploads ALL mail on IMAP
Summary: Spam filter downloads&uploads ALL mail on IMAP
Status: RESOLVED DUPLICATE of bug 125084
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.4
Platform: unspecified Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-28 20:36 UTC by Ronny Standtke
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronny Standtke 2006-09-28 20:36:43 UTC
Version:           1.9.4 (using KDE 3.5.4, Debian Package 4:3.5.4-3 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17-2-686

Mail access im my company was switched from POP3 to IMAP. Users of Outlook and Thunderbird didn't have any problem.
After I switched my account in KMail to IMAP it was downloading, filtering (Spamassassin filers were enabled in KMail) and uploading all unread mails in the IMAP inbox again and again while I was still reading mails in another folder.
Suddenly KMail displayed an error message: "Die Nachricht vom ... von ... mit dem Betreff ... kann nicht auf den Server hochgeladen werden." The error message from the server was "Over Quota".
All my incoming mails IMAP were lost. This bug is catastrophic in a business environment. Please show users of KMail a big warning that KMail and IMAP is a very experimental thing or disable IMAP as long as it is not fixed.
Comment 1 Tommi Tervo 2006-09-29 09:46:44 UTC
Are you using IMAP or disconnect IMAP? 
http://bugs.kde.org/show_bug.cgi?id=104956
Comment 2 Ronny Standtke 2006-09-29 11:01:30 UTC
I am using IMAP.
Comment 3 Thomas McGuire 2007-05-07 22:25:29 UTC
This is somewhat related to bug 125084, but there they talk only about a single mail, not ALL mails.

Raising severity due to mail loss.
Comment 4 Thomas McGuire 2007-05-07 22:26:03 UTC
*** Bug 145162 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Hahler 2007-05-24 00:13:33 UTC
This is a duplicate of bug 125084.
Comment 6 Thomas McGuire 2007-07-19 21:43:07 UTC
>This is a duplicate of bug 125084. 
OK, marking as duplicate.

*** This bug has been marked as a duplicate of 125084 ***