Bug 147851 - Canceling IMAP login prompt: Login prompt shown again soon
Summary: Canceling IMAP login prompt: Login prompt shown again soon
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.5
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 138552 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-07-13 19:48 UTC by Dave Cohen
Modified: 2018-09-04 18:23 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch vs KDE 3.5.5 (2.49 KB, patch)
2007-07-16 13:58 UTC, Will Stephenson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Cohen 2007-07-13 19:48:24 UTC
Version:           1.9.5 (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
OS:                Linux

I had an IMAP account on fastmail.fm, and configured kmail to read it along with other accounts.  I took a long trip, and during that time, fastmail.fm deleted the IMAP account (because it had to be used periodically).  Now, I'm back home using kmail again.  But bad things happen when I start up.

I start up kmail and shortly after wards I get error #1 in a dialog box:

Unable to login. Probably the password is wrong.
The server fastmail.fm replied:
The account you are trying to access is unavailable. Please login to the web interface for more details
[followed by OK button]

I click OK, and kmail prompts me for the username and password for that account.  The account has been deleted, so I cancel out of that dialog box.

A few seconds later, I get error #1 popping up again.  Note that the dialog box steals all focus, so I have to address it.  I can't for example, read email on other accounts.

So I try to delete from kmail the old IMAP account.  During the few seconds I have between error messages, I bring up Settings => Configure Kmail...

But when the error appears, it steals focus.  And either it appearing, or the next dialog box with the password prompt causes the Configure Kmail window to disappear.  There is simply not enough time to ever delete the old account.  So the error messages never stop.  That is why I say this bug renders Kmail useless.  As far as I can tell there's no way I can use it.
Comment 1 Dave Cohen 2007-07-13 19:52:55 UTC
Also, this bug renders all of Kontact useless, for the same reason.  So I can't say configure kmail from within Kontact.  I can't use anything in Kontact for more than a few seconds at a time.
Comment 2 Thomas McGuire 2007-07-15 14:38:04 UTC
*** Bug 138552 has been marked as a duplicate of this bug. ***
Comment 3 Thomas McGuire 2007-07-15 14:43:45 UTC
See also bug 140667.
Might be the same, but I am not sure.
Comment 4 Dave Cohen 2007-07-15 20:05:35 UTC
Bug 140667 has much in common, but also describes a freeze which does not happen to me.

I haven't used kmail since this problem started.  Can anyone suggest a workaround?  I.e. tell me a file to delete so kmail will forget my cancelled account.  Otherwise recommend another client!  ;)
Comment 5 Thomas McGuire 2007-07-15 20:35:53 UTC
>Can anyone suggest a workaround?  I.e. tell me a file to delete so kmail will forget my cancelled account.
The KMail configuration is stored in $HOME/.kde/share/config/kmailrc.
You can remove that file, but then all KMail settings will be lost, including filters etc.
You can also try manually editing that file. Then, you'll have to decrement accounts=xx under [General] and remove the account group [Account xx] of the old IMAP account. You probably also need to remove all other references to the old account if you find more in the config file.
Comment 6 Will Stephenson 2007-07-16 13:52:16 UTC
This should be fixed in kmail 1.9.7 (KDE 3.5.7) by my commit r649622.  Please try with an uptodate KDE or with the attached patch and let me know if it helps.  
Comment 7 Will Stephenson 2007-07-16 13:58:13 UTC
Created attachment 21161 [details]
Patch vs KDE 3.5.5
Comment 8 Michael Leupold 2009-04-05 10:57:35 UTC
Any news regarding the fix? Did the problem go away?
Comment 9 Björn Ruberg 2010-01-09 01:01:55 UTC
Good question
Comment 10 Andrew Crouthamel 2018-09-04 18:23:11 UTC
Hello! Sorry to be the bearer of bad news, but this version of Kmail has been unmaintained for many years so I am closing this bug. Please try using the latest version of Kmail to see if your issue persists. If it does, please submit a new bug in "kmail2". Thank you!