Bug 147605 - Replies to meeting don't work anymore with older Kontact version
Summary: Replies to meeting don't work anymore with older Kontact version
Status: RESOLVED WORKSFORME
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: 1.2
Platform: Ubuntu Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 146755 147910 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-07-06 13:57 UTC by Davide Ferrari
Modified: 2008-03-17 15:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Ferrari 2007-07-06 13:57:28 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages

I know in KDE 3.5.7 Kontact got better support for Outlook invitations, but something seems broken now between different versions of contact.
Scenario:

- user A with Kontact 1.2.3 (KDE 3.5.5) create a meeting with user B
- user B, using Kontact 1.2.5 (KDE 3.5.7) receives the request and accept it
- user A receive a mail with the answer from B but Kmail fails to interpret it correctly as a positive answer to the meeting request. it just shows a mail with a 1 byte attachment.

This always worked before use B (myself) upgraded to KDE 3.5.7.
We both uses a localized version of KDE (spanish), if you need the attachment or any other info, please ask.
Comment 1 Axel Müller 2007-08-22 09:02:29 UTC
I have the same problem here. After upgrading from 3.5.5 to 3.5.7 (Gentoo platform) all my answers to invitations are ical attachements of the size 1 byte i.e empty.
Comment 2 Axel Müller 2007-08-22 09:11:26 UTC
Seems to be a duplicate of bug #147910.
Comment 3 Davide Ferrari 2007-08-25 03:10:01 UTC
ehm, 147910 > 147605, so I'm the original bug :P
Comment 4 Tommi Tervo 2007-08-27 11:12:35 UTC
*** Bug 147910 has been marked as a duplicate of this bug. ***
Comment 5 Allen Winter 2007-09-27 14:31:18 UTC
*** Bug 146755 has been marked as a duplicate of this bug. ***
Comment 6 Axel Müller 2007-12-05 09:42:32 UTC
Nobody interested in fixing this bug? This bug renders Kmail/Kontact as totally unusable in a corporate environment. This bug was newly introduced with KDE 3.5.7. Everything worked fine in 3.5.5. 
Comment 7 Davide Ferrari 2007-12-05 09:59:27 UTC
sorry, I forgot to update it (I'm the reporter). With KDE 3.5.8 (at least Kubuntu version,  1.9.6 (enterprise 0.20070907.709405) it seems fixed againg.
Comment 8 Brian DeRocher 2008-03-06 01:44:52 UTC
The problem still exists for Kmail 1.9.7 in KDE 3.5.8 from Debian Sid.  Kmail still sends a 1 byte attachment in the answer.
Comment 9 Axel Müller 2008-03-14 18:24:34 UTC
The problem can be circumvented with the proper settings :) 

I have checked the following groupware compatibility options in 
Settings->Configure Kontact->Mail->Misc->Groupware:
* Mangle From:/To: headres in replies to invitations
* Exchange compatible invitation naming

That is the first and third entry if you have a localized version of Kontact.

This even works in KDE 3.5.7

Any other combination of these options does not work.
Comment 10 Davide Ferrari 2008-03-14 18:32:25 UTC
I don't have these option checked and as I said it works for me, both with Kontact adn Outlook invitations. (Kontact 1.2.9)
Comment 11 Axel Müller 2008-03-17 14:21:35 UTC
Hmm, I have KDE 3.5.8 installed (Gentoo) and Kontact is version 1.2.5
Comment 12 Davide Ferrari 2008-03-17 15:35:30 UTC
If you have KDE 3.5.8 then the Kontact "enterprise branch" was still out of the main tree (it was merged with KDE 3.5.9), so this is probably the reason why you're still experiencing the problem.