Bug 147464 - No way to select items in the message structure viewer with keyboard
Summary: No way to select items in the message structure viewer with keyboard
Status: RESOLVED DUPLICATE of bug 127181
Alias: None
Product: kmail
Classification: Unclassified
Component: messageviewer (show other bugs)
Version: 1.9.7
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2007-07-02 21:08 UTC by jgoerzen
Modified: 2010-01-09 00:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jgoerzen 2007-07-02 21:08:06 UTC
Version:           1.9.7 (using KDE 3.5.7, Debian Package 4:3.5.7.dfsg.1-1 (lenny/sid))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18-4-k7

I can find no way to select the HTML alternative in a message containing both text and HTML without using the mouse.

This is both a usability and an accessibility issue.

No way is documented in the manual.  I also tried Google and the shortcuts configuration, and found nothing relevant either place.

It is also unclear how to "click" the render HTML link with only the keyboard on a pure HTML document.
Comment 1 Thomas McGuire 2007-07-03 19:42:53 UTC
>It is also unclear how to "click" the render HTML link with only the keyboard on a pure HTML document.
See bug 127181 for this.
Comment 2 Michael Leupold 2009-04-05 09:39:11 UTC
My KMail (1.11.0) has a "Prefer HTML to plain-text" shortcut which can be used to show the HTML part. This presumably fixes this bug.
Comment 3 Björn Ruberg 2010-01-09 00:51:09 UTC
Because of comment #2 this is a plain duplicate now

*** This bug has been marked as a duplicate of bug 127181 ***