Bug 127181 - Keyboard key/menu to switch from brut HTML view to formatted HTML view of message body
Summary: Keyboard key/menu to switch from brut HTML view to formatted HTML view of mes...
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: Git (master)
Platform: OpenSUSE Linux
: NOR wishlist with 22 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 147464 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-05-12 00:44 UTC by Franck Bourdonnec
Modified: 2013-03-26 21:35 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Franck Bourdonnec 2006-05-12 00:44:44 UTC
Version:           1.9.1 (using KDE KDE 3.5.2)
Installed from:    SuSE RPMs

Hello,

It is annoying to have to 'click' (search the mouse, find the small link), to switch from brut to formatted HTML.

A keyboard default key (H?) should do that. With 'shift' modifier, to resolve also externals links!


Thank you for great work.

Franck
Comment 1 Juha Tuomala 2006-05-12 08:17:14 UTC
Not annoying but it doesn't look very professional and probably doesn't follow any GUI guidelines or best practices.

Keyboard short cut would be fine and just proper button for it. It could be in toolbar rather than in message rendering area as it's related to the whole message. Same entries to view menu also.

Like Franck said, great work, I nowdays can use kmail very well when I got my old kmailrc working with 3.5.x version and it crashes perhaps once a day but I guess that gets polished in further 3.5.x series.
Comment 2 Björn Ruberg 2010-01-09 00:51:09 UTC
*** Bug 147464 has been marked as a duplicate of this bug. ***
Comment 3 Myriam Schweingruber 2012-08-18 08:32:15 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 4 Luigi Toscano 2012-08-19 00:34:50 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.
Comment 5 Bernd Oliver Sünderhauf 2012-11-24 09:34:37 UTC
Still valid for kmail2, component "UI"
Comment 6 Laurent Montel 2013-03-26 21:35:12 UTC
Git commit c157b7ac7aff596fffe1591091276d38ba2f988b by Montel Laurent.
Committed on 26/03/2013 at 22:34.
Pushed by mlaurent into branch 'master'.

Fix Bug 127181 - Keyboard key/menu to switch from brut HTML view to formatted HTML view of message body

FIXED-IN: 4.11

M  +18   -1    messageviewer/viewer_p.cpp
M  +1    -0    messageviewer/viewer_p.h

http://commits.kde.org/kdepim/c157b7ac7aff596fffe1591091276d38ba2f988b