Bug 146761 - Improve keyword-assignment through enhanced drag and drop
Summary: Improve keyword-assignment through enhanced drag and drop
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Drag&Drop (show other bugs)
Version: 0.9.2
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-13 22:45 UTC by Thomas Thrainer
Modified: 2019-08-14 18:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Thrainer 2007-06-13 22:45:25 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages
OS:                Linux

Would it be possible to further enhance drag and drop of keywords?

I don't like to select every time an item out of the context-menu. Wouldn't it be better to highlight somehow the images which get a keyword assigned when we release the mouse-button right now? We could discard one click, which gets realy disturbing when you assign keywords for many files.

It would also be great if I could assign more than one keyword via drag and drop. I would first select (with Ctrl, for example) all the keywords I want to assign, and then drop all of them to one (or possible more) photos at once.
Comment 1 Arnd Baecker 2007-06-13 23:19:23 UTC
I use this procedure:
select one more images and then use the right Comments/Tags sidebar
to tick all the relevant tags. On apply these
get applied to all selected images.
In addition I use the incremental search filter a lot.
Give it a try (with a sufficiently recent digikam version...;-)

By now I don't use D&D anymore, but I understand you suggestion
for selecting several tags and apply them on several images.

Best, Arnd
Comment 2 caulier.gilles 2008-12-06 15:20:36 UTC
Andi,

Multiple selection of tags ?

Gilles Caulier
Comment 3 Andi Clemens 2008-12-06 19:40:31 UTC
Sure, I think multiple selection of albums, tags etc is highly needed.
It is so annoying if you get images from somebody and then need to delete like 50 tags at once because you wouldn't like them to be in the database.
Also it would be nice to have multiple selection on albums (for deletion or moving around).
I know I had made a patch for KDE3, but maybe we should wait for the Qt4 implementation after 0.10 and skip KDE3 completely?

Would make things easier I guess.

Andi
Comment 4 caulier.gilles 2008-12-06 19:43:32 UTC
Andi,

I think this file is a duplicate in this case

Gilles
Comment 5 Andi Clemens 2008-12-06 19:53:26 UTC
Yes... since this can be handled with multiple selection it can be seen as a duplicate.

There are more reports similar to that:

https://bugs.kde.org/show_bug.cgi?id=102413
https://bugs.kde.org/show_bug.cgi?id=159209
https://bugs.kde.org/show_bug.cgi?id=158791

Andi
Comment 6 caulier.gilles 2009-06-19 12:41:28 UTC

*** This bug has been marked as a duplicate of bug 158791 ***
Comment 7 caulier.gilles 2019-08-14 18:51:21 UTC
Fixed with bug #158791