Bug 146488 - Japanese input methods don't work properly in composer
Summary: Japanese input methods don't work properly in composer
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.9.7
Platform: Mandriva RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 118296 139801 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-07 14:08 UTC by Yukiko Bando
Modified: 2015-04-12 10:10 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yukiko Bando 2007-06-07 14:08:10 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Mandriva RPMs
OS:                Linux

I'm using SCIM and UIM input methods with Qt immodule in en_US.UTF-8 locale.  In this environment, both don't work properly in KMail composer.  I cannot insert any words and preedit (characters before being sent to the application) gets lost under certain conditions. 

It appears that it has something to do with spell checking.  If I select Hspell Hebrew (which is not installed on my system) for the spell checker, I can type Japanese normally.  The problem also disappears if I start kmail from konsole with LANGUAGE=ja_JP.UTF-8 or LC_MESSAGES=ja_JP.UTF-8.  It's annoying that I have to restart KMail to write a Japanese mail. 

Since the same input methods work without problems in KWord even with auto spell check is on, I guess there's something wrong with KMail composer.
Comment 1 Thomas McGuire 2007-06-07 17:04:45 UTC
*** Bug 118296 has been marked as a duplicate of this bug. ***
Comment 2 Thomas McGuire 2007-06-07 17:05:08 UTC
Bug 141974 might be related.
Comment 3 Thomas McGuire 2007-07-11 20:49:49 UTC
*** Bug 139801 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas L. 2010-01-04 08:56:11 UTC
is it still valid with KDE4 ?

Kde pim team what do you think ?
Comment 5 Thomas McGuire 2010-01-04 15:55:05 UTC
> is it still valid with KDE4 ?
> Kde pim team what do you think ?

No idea if it is still valid. In any case this would be a kdelibs bug, as we're using KTextEdit from there, which provides the spell checking functions. Other parts of KDE would have the same problem, e.g. the text edit boxes in HTML forms in Konqueror.
Comment 6 Laurent Montel 2015-04-12 10:10:44 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.