Bug 146285 - Add "fit columns to width" option
Summary: Add "fit columns to width" option
Status: RESOLVED DUPLICATE of bug 147708
Alias: None
Product: kmail
Classification: Applications
Component: message list (show other bugs)
Version: 1.10.0
Platform: OpenSUSE Linux
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-02 13:33 UTC by Maciej Pilichowski
Modified: 2010-01-07 02:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Pilichowski 2007-06-02 13:33:32 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs

Problems:
1) how to set the width for icon-column (todo for example) so you can be sure it takes _minimal_ required space to display the icon
2) how to set the width in total of all columns that they take exactly the width of the pane

It would be good to see KMail gives user a hand. My suggestions:
1) being able to set the column is fixed-width, adjusted-to-content (but note -- potential content, user does not have to have todo icon in the list)
2.1) being able to set that width (in total) is dynamic -- when user changes the size of the pane, the width of columns change (I don't like it)
2.2) being able to just tell in given moment "adjust to pane" -- so it fits well now, but when the user change the pane size, the columns are not change (I like it better -- the reason: most of the time I work with KMail with fixed size, i.e. maximized; once set I can work another 10 years without changing anything)
Comment 1 Thomas McGuire 2007-06-05 23:34:13 UTC
Point 1: double-click the line between to columns in the column header.
Point 2.1: Already reported in bug 74619.

So only Point 2.2 is left, I'll change the summary to that.
Comment 2 Maciej Pilichowski 2007-06-06 08:01:23 UTC
Thomas, thanks for the reply

1) it changes the column size, ok, but it is not minimal required space (it is about ~4 times larger than icon)
Comment 3 Thomas McGuire 2007-06-07 18:21:08 UTC
>1) it changes the column size, ok, but it is not minimal required space (it is about ~4 times larger than icon) 
Hmm, it works for the other columns though. 
Comment 4 Maciej Pilichowski 2007-06-07 21:09:29 UTC
1) ok, but my wish concerns the iconic ones -- reason: they are fixed size, so want to set the width for good (and correctly), the subject column on the other hand is variable-width so such option does not make so much (any?) sense as for (for example) to-do column
Comment 5 Thomas McGuire 2007-07-09 17:36:11 UTC
See also bug 147708.
Comment 6 Björn Ruberg 2010-01-07 02:34:11 UTC

*** This bug has been marked as a duplicate of bug 147708 ***