Bug 145547 - syntax highlighting confused by <<<
Summary: syntax highlighting confused by <<<
Status: RESOLVED DUPLICATE of bug 142904
Alias: None
Product: kate
Classification: Unclassified
Component: syntax (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-17 12:03 UTC by Thomas Winkler
Modified: 2007-10-12 11:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Winkler 2007-05-17 12:03:04 UTC
Version:           kate 2.5.5 (using KDE KDE 3.5.5)
Installed from:    SuSE RPMs
Compiler:          Target: i586-suse-linux 
OS:                Linux

in the following script the <<< redirect asigns the content of the variable to the third file descriptor. The command works, but syntax highlighting does not recognize the three < as being valid

#! /bin/sh
# encrypt tar files
for file in $TMPDIR/*; do
  mkisofs -R $file | aespipe -e aes256 -p3 3<<<$PASS >$file.aes256.iso
done
Comment 1 Sebastian Pipping 2007-10-12 11:10:25 UTC
SVN commit 724425 by sping:

Proper highlighting of "\d*<<<" redirection.
This feature seems not mentioned in the Bash Manual.
Please attach a link to documentation about it to this
bug report if you know any.
BUG: 142904
CCBUG: 145547
CCMAIL: webmaster@hartwork.org


 M  +2 -2      bash.xml  


WebSVN link: http://websvn.kde.org/?view=rev&revision=724425
Comment 2 Sebastian Pipping 2007-10-12 11:11:22 UTC

*** This bug has been marked as a duplicate of 142904 ***