Bug 142904 - bug in kate syntax highlighting for bash
Summary: bug in kate syntax highlighting for bash
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: syntax (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 145547 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-13 09:02 UTC by David L Emerson
Modified: 2007-10-12 18:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David L Emerson 2007-03-13 09:02:50 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages
OS:                Linux

VERSION INFO
============
from /usr/share/apps/katepart/syntax/bash.xml
language name="Bash" version="2.06" kateversion="2.4"
author: Wilbert Berendsen, wilbert kde nl

THE BUG
=======
load kate with a bash-highlighted document, and type this:

exec 0<<<"$var"
# highlighting is now in "here-document" mode

it appears that, when already in the context of redirection, a here-string is being erroneously treated as a here-document.

Fortunately, there's a workaround (which might be another bug in action):

# <"$var
# ends the here-document highlighting
# (notice there's no end quote)
Comment 1 Sebastian Pipping 2007-10-12 11:10:26 UTC
SVN commit 724425 by sping:

Proper highlighting of "\d*<<<" redirection.
This feature seems not mentioned in the Bash Manual.
Please attach a link to documentation about it to this
bug report if you know any.
BUG: 142904
CCBUG: 145547
CCMAIL: webmaster@hartwork.org


 M  +2 -2      bash.xml  


WebSVN link: http://websvn.kde.org/?view=rev&revision=724425
Comment 2 Sebastian Pipping 2007-10-12 11:11:23 UTC
*** Bug 145547 has been marked as a duplicate of this bug. ***
Comment 3 Mrugesh Karnik 2007-10-12 14:31:32 UTC
The following is being quoted from 
$ man 1 bash
$ echo "${BASH_VERSINFO[@]}"
3 2 17 1 release i686-pc-linux-gnu

<quote>

Here Strings
 A variant of here documents, the format is: 


 
<<<word



 The word is expanded and supplied to the command on its standard input.

</quote>
Comment 4 Sebastian Pipping 2007-10-12 16:32:11 UTC
I read that, but it doesn't speak of file descriptors in front of that.
Comment 5 Sebastian Pipping 2007-10-12 18:22:29 UTC
SVN commit 724550 by sping:

Fix HereDoc bug mentioned as a side note in #142904.
CCBUG: 142904
CCMAIL: mw_triad@users.sourceforge.net
CCMAIL: webmaster@hartwork.org


 M  +6 -5      bash.xml  


WebSVN link: http://websvn.kde.org/?view=rev&revision=724550