Bug 144839 - force sending message even if there is a bad email in to fields
Summary: force sending message even if there is a bad email in to fields
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: kmail
Classification: Applications
Component: sending (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 144509 151679 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-04-29 22:48 UTC by Anders Lund
Modified: 2012-08-19 00:27 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Lund 2007-04-29 22:48:19 UTC
Version:           1.9.6 (using KDE 3.5.6, Kubuntu (feisty) 4:3.5.6-0ubuntu14)
Compiler:          Target: x86_64-linux-gnu
OS:                Linux (x86_64) release 2.6.20-9-generic

When i send a message to 30 people, and one of the addresses fails some sort of validation (?) the message isn't sent but sits in the outbox and blocks everything.

I think kmail should just send the message, ot at least offer me a configuration option to have it do that. And kmail should offer some way out, such as removing the reciepient blocking the process.

When deleting such a reciepient manually, i held the backspace key down and kmails behavior (moving to the next field) led to more reciepients being removed, and kmail couldn't restore those.
Comment 1 Anders Lund 2007-05-01 22:37:14 UTC
Why isn't this a bug????????? My mail doesn't get sent!!
Comment 2 Ingo Klöcker 2007-05-01 23:28:04 UTC
KMail refuses to send a wrongly addressed message. That's definitely no bug, but absolutely sensible behavior.

Besides, which of the following two options is easier:
a) You open the message, fix the wrong email address and send the message.
b) You send the message to all correct addresses, then you go to the sent-mail folder, click on send again, delete all previous recipients and add the recipients the first message was not sent to (taking extra care that you don't forget a recipient and not add a recipient the message was already sent to).
Comment 3 Anders Lund 2007-05-02 17:52:39 UTC
On Tuesday 01 May 2007, Ingo Klöcker wrote:
> Besides, which of the following two options is easier:
> a) You open the message, fix the wrong email address and send the message.
> b) You send the message to all correct addresses, then you go to the
> sent-mail folder, click on send again, delete all previous recipients and
> add the recipients the first message was not sent to (taking extra care
> that you don't forget a recipient and not add a recipient the message was
> already sent to).


I'd love it if the dialog that now only offers 'OK' and places the message in 
the outbox would offer

Fix now (option a, opens the mail in composer again)
Send anyways (option b)
Comment 4 Thomas McGuire 2007-05-02 21:33:22 UTC
>Why isn't this a bug????????? My mail doesn't get sent!! 
I changed it to a wish because you requested a different behavior (new config option or dialog). Not sending the message is the intended behavior, even if this is potentially confusing.
Comment 5 Thomas McGuire 2007-07-01 11:35:59 UTC
*** Bug 144509 has been marked as a duplicate of this bug. ***
Comment 6 Björn Ruberg 2010-01-06 01:21:17 UTC
I strongly agree with Thomas. Knowing that the mail is not send is much better than not knowing who got a mail and who not. Moreover such an invalid mail adress is often the result of something really bad happening - a missing comma or casually deleted adresses. So if something is wrong with the adresses, kmail should stop until you fix that.

As the developers have no intention of changing this - and there are no more votes on this wish, can we close it?
Comment 7 Björn Ruberg 2010-01-12 00:51:29 UTC
*** Bug 151679 has been marked as a duplicate of this bug. ***
Comment 8 Bartosz Kwitniewski 2010-01-12 13:51:58 UTC
I also agree that KMail should not send a message if there is something wrong with the addresses but it would be nice to have any information about what is going on ("Parse error in ..." or something).

I had no clue why KMail didn't want to send my email until I changed "Your name" in my identity. I don't know why KMail does not want to send a message if there are double-quotes and polish characters in "Your name" - it works in Thunderbird. Everything would be ok if I had a warning that there is a parsing error in "From:" field.
Comment 9 Myriam Schweingruber 2012-08-18 09:00:40 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 10 Luigi Toscano 2012-08-19 00:27:40 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.