Bug 144176 - In right-click popup, large amounts of tags run off the screen and cannot be accesed.
Summary: In right-click popup, large amounts of tags run off the screen and cannot be ...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Tags-Engine (show other bugs)
Version: 0.9.2
Platform: Fedora RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-13 14:53 UTC by Dotan Cohen
Modified: 2016-07-15 21:15 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments
Just before opening parent tag with many subtags (721.89 KB, image/png)
2008-03-27 22:21 UTC, Dotan Cohen
Details
With subtags open (210.11 KB, image/png)
2008-03-27 22:22 UTC, Dotan Cohen
Details
my sidebar - no "Captions / Tags" text here in 9.3 (19.02 KB, image/png)
2008-06-16 15:40 UTC, Ferdinand Gassauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2007-04-13 14:53:30 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Fedora RPMs
OS:                Linux

I have hundreds of tags in Digikam. When I right-click an image and select Add Tag, I only see the first hundred or so tags, as the remainder run off the screen. They are unaccessible by either mouse or arrow keys.
Comment 1 Dotan Cohen 2008-01-05 23:42:44 UTC
I can confirm this bug in Digikam 0.92 installed from Ubuntu packages.
Comment 2 caulier.gilles 2008-03-27 14:42:06 UTC
Marcel,

With a huge tags list from database, "Assign Tag" pop-up menu entry is not really suitable. 

I propose to always display the 10 most recent tags assigned in a reduced pop-up menu and provide a "More..." option to get the complete Tags list.

What do you think about ?

Gilles Caulier
Comment 3 caulier.gilles 2008-03-27 14:50:52 UTC
*** Bug 144179 has been marked as a duplicate of this bug. ***
Comment 4 Antonio E. 2008-03-27 14:58:01 UTC
What do you think about a combobox with autocompletion? The user could always 
display a scrollable list using the combobox or just type the text for a fast 
search of the desired tag.

El Jueves, 27 de Marzo de 2008, Gilles Caulier escribi
Comment 5 Dotan Cohen 2008-03-27 22:21:30 UTC
Created attachment 24089 [details]
Just before opening parent tag with many subtags 

You can see the first few subtags in the tree on the left.
Comment 6 Dotan Cohen 2008-03-27 22:22:02 UTC
Created attachment 24090 [details]
With subtags open 

Note that that the last tags defined are Zz08, Zz09, Zz10. The last tag does
not appear, because there are too many tags on the screen.
Comment 7 Ferdinand Gassauer 2008-06-16 10:29:10 UTC
*** Bug 164187 has been marked as a duplicate of this bug. ***
Comment 8 Ferdinand Gassauer 2008-06-16 10:34:29 UTC
another idea -
* show the last 10 and the 10 most frequently used tags (=20)
* provide a combobox with autocompletion 
** one or more letters "at beginning of" tag
** two or more letters "in" tag (sort of fuzzy search for multiword tags)
Comment 9 Andi Clemens 2008-06-16 11:14:26 UTC
If you have so many tags, why not use the tagging sidebar?
There is a lineedit with autocompletion for entering tags as well as a search field for finding tags. Also there is a button for the "recently used tags".
If this is not in your version right now, digiKam 0.9.4 will provide all those tools in a sidebar.
But maybe I'm misunderstanding the questions / suggestions here.
Comment 10 Ferdinand Gassauer 2008-06-16 11:54:11 UTC
The heading of the right sidebar "Tag Filters" confused me.
I didn't realize that the tags can be D&D onto the images - which is a nice feature indeed, combined with the search, which does exactly what I was asking for.
I am using digikam 9.3

Nevertheless the overflow problem "Assign Tag" should be solved eventually even if there is another solution, because people will simply run into it.
Comment 11 Andi Clemens 2008-06-16 12:17:30 UTC
Well actually the sidebar I was talking about is called "Captions / Tags" just above "Tag Filters" ...
:-)
Comment 12 Ferdinand Gassauer 2008-06-16 15:40:03 UTC
Created attachment 25383 [details]
my sidebar - no "Captions / Tags" text here in 9.3

Ah I see have first to select the sidebar tag "Caption/Tags" 
may be a better wording could help
"Add Caption/Tags" 
or just issue a message at the end of the (full) list "Please use also the
right sidebar Caption/Tags"

If one gets used to use one way one does not look for another....
Comment 13 caulier.gilles 2008-12-06 08:23:04 UTC
Dotan,

Using digiKam 0.9.4 and new simple entry of string tags with auto completion from Caption and Tags sidebar, this file still valid ?

Gilles Caulier
Comment 14 Mikolaj Machowski 2008-12-06 17:55:47 UTC
+1 from me for WONTFIX. Implementation of everything is not possible.
Comment 15 Dotan Cohen 2008-12-06 19:06:37 UTC
Implementation of everything might not be possible, but this is an important issue. Although the tags in my screenshots are dummy tags (as I do not want to put personal information on the web and the tags are part of my testing suite), I discovered the issue because in our real Digikam install we have too many tags for the screen. It is part of our workflow. Digikam might not implement _everything_, but this is an issue affecting real Digikam users and current workarounds are kludges that interfere with the ability to use the application normally.
Comment 16 Mikolaj Machowski 2008-12-06 21:36:05 UTC
Sorry Dotan, you are wright

-1 for WONTFIX

Especially that KDE can generally break menus into several columns - why not digiKam?
Comment 17 Andi Clemens 2010-09-25 17:42:50 UTC
Closing some old bugreports that are related to old digiKam version, and that have not received answers for two years now.

If you think the reports are still valid, feel free to re-open them, but please provide updates and do not just open them without giving feedback.
Comment 18 caulier.gilles 2015-07-04 06:02:24 UTC
New digiKam 4.11.0 is available.

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?
Comment 19 caulier.gilles 2016-07-15 21:15:38 UTC
With digiKam 5.0.0, this problem is not reproducible.
I close this file now. Don't hesitate to re-open if necessary.
Gilles Caulier