Bug 144179 - Tag hierarchy or popups is difficult to follow/understand.
Summary: Tag hierarchy or popups is difficult to follow/understand.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Tags-Engine (show other bugs)
Version: 0.9.1
Platform: Fedora RPMs Linux
: NOR normal with 2 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-13 16:22 UTC by Dotan Cohen
Modified: 2016-07-15 21:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments
Screenshot demonstrating problem. (238.63 KB, image/png)
2007-04-13 16:23 UTC, Dotan Cohen
Details
Just before opening parent tag with many subtags (721.89 KB, image/png)
2008-03-27 22:07 UTC, Dotan Cohen
Details
With subtags open (210.11 KB, image/png)
2008-03-27 22:14 UTC, Dotan Cohen
Details
Displays tag hierarchy many levels deep (240.93 KB, image/png)
2008-03-27 22:19 UTC, Dotan Cohen
Details
Mockup based on screenshot from Comment #1 (238.63 KB, image/png)
2008-12-05 10:06 UTC, Dotan Cohen
Details
Fix (238.59 KB, image/png)
2008-12-05 10:10 UTC, Dotan Cohen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2007-04-13 16:22:11 UTC
Version:           0.9.1 (using KDE KDE 3.5.6)
Installed from:    Fedora RPMs
OS:                Linux

I have tag hierarchies up to 6 levels deep. When adding tags via the right-click menu, Digikam pops the newest level over the former level. This gets difficult to keep track of after 3 or 4 levels. I propose one solution to the problem, maybe someone can propose yet another:

To have the former levels turn a slightly lighter shade of colour in the background. Currently, the background of the menus is #F1E9E7. Maybe when a new menu level is opened the older one could become #F8ECEA, and after that #FBEDEC, then #FDEEEE, and finally #FFFFFF (white).

Any other solutions proposals welcome.
Comment 1 Dotan Cohen 2007-04-13 16:23:52 UTC
Created attachment 20261 [details]
Screenshot demonstrating problem.

This image is a screenshot demonstrating the problem.
Comment 2 Dotan Cohen 2008-01-05 23:43:44 UTC
I can confirm this bug in Digikam 0.92 installed from Ubuntu packages.
Comment 3 caulier.gilles 2008-03-27 14:50:51 UTC
Dotan,

For me, this file is a duplicate of #144176. Also, using multiple color background for menu entries is not the better solution.

Gilles Caulier

*** This bug has been marked as a duplicate of 144176 ***
Comment 4 Dotan Cohen 2008-03-27 21:39:04 UTC
Gilles, this bug is _not_ a dupe of 144176 (also filed by me).

Bug 144176 deals with instances in which there are many tags, all at the same level.
This bug deals with instances in which there are many levels of tags.

I will add a screenshot to 144176 to demonstrate, and I will add another screenshot to this bug to demonstrate.
Comment 5 Dotan Cohen 2008-03-27 22:07:19 UTC
Created attachment 24086 [details]
Just before opening parent tag with many subtags

You can see the first few subtags in the tree on the left.
Comment 6 Dotan Cohen 2008-03-27 22:14:56 UTC
Created attachment 24087 [details]
With subtags open

Note that that the last tags defined are Zz08, Zz09, Zz10. The last tag does
not appear, because there are too many tags on the screen.
Comment 7 Dotan Cohen 2008-03-27 22:19:58 UTC
Created attachment 24088 [details]
Displays tag hierarchy many levels deep

Please disregard the two previous screenshots, I meant to attach them to Bug
144176.

In this screenshot, you can see that the tag hierarchy is very difficult to
follow.
Comment 8 caulier.gilles 2008-12-05 09:29:55 UTC
Andi, Marcel,

I'm totally agree with Dotan. Tag hierarchy is impossible to follow when tags list is huge. We need to found an optimal way. 

My proposal is :

1/ Display the most recent used Tags in menu (there is a method to query database). This way is already used in Captions & Tags sidebar. 

2/ If user want more tags, a special menu entry named "More..." can switch on  automaticaly Caption & Tags right sidebar and give focus to Tags list

What do you think about ?

Gilles
Comment 9 Andi Clemens 2008-12-05 09:42:56 UTC
Gilles,

I never liked this, too. I think your proposal sounds fine. You can quickly add tags that you just used, so the context menu will still make sense, but you are not overwhelmed by this huge tag list you might have.

I can only reference F-Spot again and the way they assign tags (the textedit field with autocompletion), still the best way I think. I would love to have something like this in digiKam, too. I know we can have autocompletion it Caption/Tags dialog, but this is not the same.
You don't see what you have already assigned, you need to click on this button first... it is just not that visible.
But there is a different bugreport where we can talk about this.

So for now only displaying the most recent tags is a good start.

Andi
Comment 10 Arnd Baecker 2008-12-05 09:52:59 UTC
Just one comment about the display of the most recent tags:
Somehow the ordering does not work properly for me. I.e., 
the last assigned tag is not necessarily displayed on top of the list.
This applies both to 0.9.5-svn and 0.10

Adding a few tags, everything works fine, but then somehow the
ordering does not work properly anymore, and may even change completely!
I would expect a first-in/first-out list with the last-added items on top.
(Hmm, maybe a separate wish for this would be better ... ;-)
Comment 11 Dotan Cohen 2008-12-05 10:06:41 UTC
Created attachment 29057 [details]
Mockup based on screenshot from Comment #1

I agree that [optionally] showing the most recent tags (or most popular tags) is a good idea, but I see that as a solution to Bug 144176, not to this bug. Bug 144176 deals with many tags at the same hierarchy level, for which that solution is appropriate, but this bug deals with many levels of tags.

When dialog boxes appear in KDE 4 the background darkens, which brings eye focus to the dialog box. Could something similar be done in Digikam, where each level of menus is made darker? See attached screenshot, based upon the screenshot from Comment #1, for an example.
Comment 12 Dotan Cohen 2008-12-05 10:10:04 UTC
Created attachment 29058 [details]
Fix

Oops, there was an error in the previous screenshot. See this fixed version. Thanks.
Comment 13 Andi Clemens 2010-09-25 17:42:54 UTC
Closing some old bugreports that are related to old digiKam version, and that have not received answers for two years now.

If you think the reports are still valid, feel free to re-open them, but please provide updates and do not just open them without giving feedback.
Comment 14 caulier.gilles 2015-07-04 06:03:08 UTC
New digiKam 4.11.0 is available.

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?
Comment 15 caulier.gilles 2016-07-15 21:21:46 UTC
With digiKam 5.0.0, this problem is not reproducible.
I close this file now. Don't hesitate to re-open if necessary.
Gilles Caulier