Bug 143487 - running filters steal focus on large mailboxes
Summary: running filters steal focus on large mailboxes
Status: RESOLVED DUPLICATE of bug 148069
Alias: None
Product: kmail
Classification: Applications
Component: message list (show other bugs)
Version: 1.9.5
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-26 16:02 UTC by morgajel
Modified: 2007-07-25 00:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description morgajel 2007-03-26 16:02:43 UTC
Version:           1.9.5 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

reproduction:
Simple to reproduce- get an imap mailbox between 200 and 1000 messages long, have 6 or 7 filters, highlight all of them and hit ctrl-J.

problem:
Now try to read every 3rd email, or 2 emails from the middle of the list.
the problem is whatever message the filter is filtering, the focus jumps to it, making it difficult to scroll through the list and a general pain to use.

story:
I'm in a position where I get 200+ emails a night because of an overzealous "mail on error" policy- when I come in on a monday, I have 600 new emails, 400 of which are less than useful. I basically have to wait 5-10 minutes for the filters to do their magic before I can read my 40 or 50 real email.

resolution:
basically I guess the complaint is to not have the filtering steal focus.
Comment 1 Thomas McGuire 2007-07-25 00:07:48 UTC

*** This bug has been marked as a duplicate of 148069 ***