Bug 143318 - Reply to author function does not work as expected
Summary: Reply to author function does not work as expected
Status: RESOLVED DUPLICATE of bug 104229
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-22 03:07 UTC by Al Muckart
Modified: 2007-03-27 19:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Al Muckart 2007-03-22 03:07:22 UTC
Version:           1.9.6 (using KDE 3.5.6, Kubuntu (edgy) 4:3.5.6-0ubuntu1~edgy1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17-11-generic

When I hit the plain reply button on a mailing list email, I expect that the mailer will parse the "Reply To" header and send a message back to the list.

When I use the "reply to author" option though, I expect that the mail will go to the From: address of the email, which on every mailing list I am on is the email address of the person who sent the post to the mailing list, not the mailing list address itself.

This does not happen, in *both* cases the email goes to the reply-to address and back to the mailing list. I can't work out a difference in the way that reply to author and plain reply are working. This should at least be configurable to always use the From: address if it isn't possible to parse the headers to work out what the mailing list address is.

Example header below:
--- cut ---
Return-Path: <sentto-1143331-1574-1174513730-silver=where.else.net.nz@returns.groups.yahoo.com>
Delivered-To: silver@paradise.gen.nz
Received: (qmail 9291 invoked by uid 1002); 21 Mar 2007 21:49:22 -0000
Delivered-To: silver-else-silver@where.else.net.nz
Received: (qmail 11316 invoked by uid 1057); 21 Mar 2007 21:49:22 -0000
Received: from 66.94.237.26 by tombstone (envelope-from <sentto-1143331-1574-1174513730-silver=where.else.net.nz@returns.groups.yahoo.com>, uid 71) with qmail-scanner-1.24 
 (clamdscan: 0.80/599. spamassassin: 3.0.1.  
 Clear:RC:0(66.94.237.26):. 
 Processed in 0.28205 secs); 21 Mar 2007 21:49:22 -0000
Received: from unknown (HELO n32.bullet.scd.yahoo.com) (66.94.237.26)
  by tombstone.paradise.gen.nz with SMTP; 21 Mar 2007 21:49:22 -0000
Comment: DomainKeys? See http://antispam.yahoo.com/domainkeys
DomainKey-Signature: a=rsa-sha1; q=dns; c=nofws; s=lima; d=yahoogroups.com;
	b=Rkh0OkWWBClYdWTXr7M/9j3lFlI6cNfBB6vHImdR/ybb0UwXM3PGTxZ8BfPR4ZzjayksM+4oSTgx0enI1SKVlpiUAbjq+2pz9wNhLu1qs2ZTFg18A3tLCxgZfwTeln7W;
Received: from [66.218.69.1] by n32.bullet.scd.yahoo.com with NNFMP; 21 Mar 2007 21:48:51 -0000
Received: from [66.218.67.103] by t1.bullet.scd.yahoo.com with NNFMP; 21 Mar 2007 21:48:51 -0000
X-Yahoo-Newman-Id: 1143331-m1574
X-Sender: ronch2@bellsouth.net
X-Apparently-To: medieval-leather@yahoogroups.com
Received: (qmail 40555 invoked from network); 21 Mar 2007 21:48:47 -0000
Received: from unknown (66.218.67.36)
  by m42.grp.scd.yahoo.com with QMQP; 21 Mar 2007 21:48:47 -0000
Received: from unknown (HELO imf21aec.mail.bellsouth.net) (205.152.59.69)
  by mta10.grp.scd.yahoo.com with SMTP; 21 Mar 2007 21:48:47 -0000
Received: from ibm63aec.bellsouth.net ([70.152.48.209])
          by imf21aec.mail.bellsouth.net with ESMTP
          id <20070321214742.EQDF7667.imf21aec.mail.bellsouth.net@ibm63aec.bellsouth.net>
          for <medieval-leather@yahoogroups.com>;
          Wed, 21 Mar 2007 17:47:42 -0400
Received: from ourhome.bellsouth.net ([70.152.48.209])
          by ibm63aec.bellsouth.net with ESMTP
          id <20070321214741.HGPQ2353.ibm63aec.bellsouth.net@ourhome.bellsouth.net>
          for <medieval-leather@yahoogroups.com>;
          Wed, 21 Mar 2007 17:47:41 -0400
X-Mailer: QUALCOMM Windows Eudora Version 7.1.0.9
To: medieval-leather@yahoogroups.com
In-Reply-To: <20070321.160150.560.11.SilverOak@juno.com>
References: <20070321.160150.560.11.SilverOak@juno.com>
Message-Id: <20070321214741.HGPQ2353.ibm63aec.bellsouth.net@ourhome.bellsouth.net>
X-Originating-IP: 205.152.59.69
X-eGroups-Msg-Info: 1:0:0:0
From: Ron Charlotte <ronch2@bellsouth.net>
X-Yahoo-Profile: al_thaalibi
Sender: medieval-leather@yahoogroups.com
MIME-Version: 1.0
Mailing-List: list medieval-leather@yahoogroups.com; contact medieval-leather-owner@yahoogroups.com
Delivered-To: mailing list medieval-leather@yahoogroups.com
List-Id: <medieval-leather.yahoogroups.com>
Precedence: bulk
List-Unsubscribe: <mailto:medieval-leather-unsubscribe@yahoogroups.com>
Date: Wed, 21 Mar 2007 17:47:45 -0400
Subject: Re: [medieval-leather] Best paints on Rawhide?
Reply-To: medieval-leather@yahoogroups.com
X-Yahoo-Newman-Property: groups-email-tradt
Content-Type: text/plain;
  charset=US-ASCII
Content-Transfer-Encoding: 7bit
X-Length: 4436
X-UID: 6029
--- cut ---
Comment 1 Thomas McGuire 2007-03-27 19:42:54 UTC

*** This bug has been marked as a duplicate of 104229 ***