Bug 143040 - handle MIME type application/mbox and message/rfc822
Summary: handle MIME type application/mbox and message/rfc822
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: mime (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 160248 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-16 05:24 UTC by Lars DIECKOW
Modified: 2008-04-02 15:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars DIECKOW 2007-03-16 05:24:08 UTC
Version:           1.9.6 (using KDE 3.5.6 "release 41.2" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.18.2-34-default

This is related to bug 142996 and bug 142997.

KMail should register itself to handle types application/mbox (*.mbox) and message/rfc822 (*.eml) in the KDE MIME types database. Launching such a file from e.g. Konqueror would then open KMail and display the mbox or mail message.
Comment 1 David Faure 2007-04-06 14:54:24 UTC
SVN commit 651064 by dfaure:

kmail --view  can also handle *.mbox files (such as the ones saved by kmail)
BUG: 143040


 M  +1 -1      kmail_view.desktop  


--- branches/KDE/3.5/kdepim/kmail/kmail_view.desktop #651063:651064
@@ -16,7 +16,7 @@
 Icon=kmail
 DocPath=kmail/index.html
 NoDisplay=true
-MimeType=message/rfc822
+MimeType=message/rfc822;application/mbox
 
 X-KDE-StartupNotify=true
 X-DCOP-ServiceType=Unique
Comment 2 Thomas McGuire 2008-04-02 15:48:22 UTC
*** Bug 160248 has been marked as a duplicate of this bug. ***