Bug 142997 - save messages as *.eml and *.mbox files
Summary: save messages as *.eml and *.mbox files
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 143789 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-15 10:09 UTC by Lars DIECKOW
Modified: 2010-01-03 23:18 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars DIECKOW 2007-03-15 10:09:43 UTC
Version:           1.9.6 (using KDE 3.5.6 "release 41.2" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.18.8-0.1-default

This bug should depend on bug 142996.

Currently File -> Save as... produces files without extension, also the filter at the bottom of the save dialog is set to All Files. I propose to use the extension *.eml, as the mail products from Mozilla do.
Comment 1 Allen Winter 2007-03-15 13:47:05 UTC
We recently put in a fix for this, but we use *.mbox for the Save As extension.

eml is for "Outlook Express Electronic Mail", according to filext.com.

So, IMO the .mbox extension is better.  But maybe others have an opinion?
Comment 2 Lars DIECKOW 2007-03-16 05:14:33 UTC
Now that you say that I just noticed some things:
* KMail is also able to save multiple selected messages; they go into one file.
* KMail always writes out the mbox-typical "From " header line, even if it's just a single message. (Moz MailNews omits it for single messages.)

Considering that, I agree the appropriate extension is mbox.

However, for compatibility's sake I'd like to be able to select between *.eml (no "From " line) and *.mbox (use "From " line) when saving only a single message, with *.eml being the default.
Comment 3 Thomas McGuire 2007-04-08 17:38:02 UTC
*** Bug 143789 has been marked as a duplicate of this bug. ***
Comment 4 Angel Blue01 2009-03-09 17:16:18 UTC
eml files are just saved messages, KDE recognizes them as "mime encapsulated web archive" in KDE 4.2.1 and open right up in Kmail
Comment 5 Björn Ruberg 2010-01-03 23:18:01 UTC
I get an extension when saving. So this is fixed I think.