Bug 141165 - kmail occupied 100% cpu after an imap account add. after deleting kmail configuration files, it crashed.
Summary: kmail occupied 100% cpu after an imap account add. after deleting kmail confi...
Status: RESOLVED DUPLICATE of bug 114087
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-04 13:03 UTC by xavier
Modified: 2007-03-04 11:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xavier 2007-02-04 13:03:33 UTC
Version:           3.5.5 (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages
OS:                Linux

After creating an imap account, kmail had almost 100% cpu utilize.

I thought than i can delete kmail configuration files.

During this, kmail showed a number of messages that it can not create an imap directory (about 100 windows :) ) and crashed.
Comment 1 Bram Schoenmakers 2007-02-04 13:09:09 UTC
Never remove config files of an app while it is running.

And can you provide a backtrace? Install the kdepim debug package and run KMail with gdb in order to get a backtrace when it's frozen.
Comment 2 xavier 2007-02-04 13:53:31 UTC
I forgot that kmail is still running.

in gdb i have a number of message:

kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)] ignoring empty path

is it enough?
Comment 3 Bram Schoenmakers 2007-03-04 11:30:01 UTC
Thanks, it is enough to assume that this is a duplicate of bug 114087.

*** This bug has been marked as a duplicate of 114087 ***
Comment 4 Bram Schoenmakers 2007-03-04 11:32:42 UTC
Please note that bug 122124 mentions a possible workaround, maybe it works for you.