Bug 114087 - Kmail freezes on startup, with > 90% CPU.
Summary: Kmail freezes on startup, with > 90% CPU.
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 141165 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-10-09 00:44 UTC by Alain Knaff
Modified: 2008-03-18 21:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alain Knaff 2005-10-09 00:44:14 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

In 3.5 beta1, when starting up kmail (in which a couple of imap accounts are enabled), it just sits there and consumes CPU. Most folders cannot be displayed. All GUY actions (scrollbar, attempt to open folder) are very slugish. It's close to unusable.

Never had a KDE beta that was this bad (2 kicker bugs, including one crash, and this kmail bug), and I've been using KDE since 1.x
Comment 1 Alain Knaff 2005-10-09 08:34:53 UTC
When this happens, the following is printed over and over to stdout:

kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)] ignoring empty path
ASSERT: debug output not ended with \n
[
0: /opt/kde3/lib/libkdecore.so.4(_Z11kdBacktracei+0x41) [0x4069e571]
1: /opt/kde3/lib/libkdecore.so.4(_Z11kdBacktracev+0x2b) [0x4069e90b]
2: /opt/kde3/lib/libkdecore.so.4(_ZN10kdbgstreamD1Ev+0x88) [0x406aaf88]
3: /opt/kde3/lib/libkmailprivate.so(_ZN12KMFolderImap11setImapPathERK7QString+0x6e) [0x40222b5e]
4: /opt/kde3/lib/libkmailprivate.so(_ZN12KMFolderImap10readConfigEv+0x355) [0x40365265]
5: /opt/kde3/lib/libkmailprivate.so(_ZN8KMFolderC1EP11KMFolderDirRK7QString12KMFolderTypebb+0x4cb) [0x40396f1b]
6: /opt/kde3/lib/libkmailprivate.so(_ZN11KMFolderDir12createFolderERK7QStringb12KMFolderType+0x6e) [0x40399f0e]
7: /opt/kde3/lib/libkmailprivate.so(_ZN12KMFolderImap14slotListResultERK11QStringListS2_S2_S2_RKN5KMail15ImapAccountBase7jobDataE+0x2ea) [0x403bb2ea]
8: /opt/kde3/lib/libkmailprivate.so(_ZN12KMFolderImap18slotCheckNamespaceERK11QStringListS2_S2_S2_RKN5KMail15ImapAccountBase7jobDataE+0x40c) [0x403bc03c]
9: /opt/kde3/lib/libkmailprivate.so(_ZN12KMFolderImap9qt_invokeEiP8QUObject+0x203) [0x40484a43]
10: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x17e) [0x40a6b98e]
11: /opt/kde3/lib/libkmailprivate.so(_ZN5KMail7ListJob15receivedFoldersERK11QStringListS3_S3_S3_RKNS_15ImapAccountBase7jobDataE+0x117) [0x402d8447]
12: /opt/kde3/lib/libkmailprivate.so(_ZN5KMail7ListJob14slotListResultEPN3KIO3JobE+0x1cf) [0x402d86df]
13: /opt/kde3/lib/libkmailprivate.so(_ZN5KMail7ListJob9qt_invokeEiP8QUObject+0x77) [0x402d8777]
14: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x17e) [0x40a6b98e]
15: /opt/kde3/lib/libkio.so.4(_ZN3KIO3Job6resultEPS0_+0x92) [0x41b4a922]
16: /opt/kde3/lib/libkio.so.4(_ZN3KIO3Job10emitResultEv+0x7c) [0x41baa84c]
17: /opt/kde3/lib/libkio.so.4(_ZN3KIO9SimpleJob12slotFinishedEv+0x4c) [0x41bb200c]
18: /opt/kde3/lib/libkio.so.4(_ZN3KIO7ListJob12slotFinishedEv+0x6e) [0x41bb23be]
19: /opt/kde3/lib/libkio.so.4(_ZN3KIO7ListJob9qt_invokeEiP8QUObject+0xfb) [0x41ba54eb]
20: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x17e) [0x40a6b98e]
21: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEi+0xc6) [0x40a6c136]
22: /opt/kde3/lib/libkio.so.4(_ZN3KIO14SlaveInterface8finishedEv+0x2c) [0x41b500ec]
23: /opt/kde3/lib/libkio.so.4(_ZN3KIO14SlaveInterface8dispatchEiRK9QMemArrayIcE+0x8b8) [0x41b84bb8]
24: /opt/kde3/lib/libkio.so.4(_ZN3KIO14SlaveInterface8dispatchEv+0x63) [0x41b5f8b3]
25: /opt/kde3/lib/libkio.so.4(_ZN3KIO5Slave8gotInputEv+0x2b) [0x41b60c5b]
26: /opt/kde3/lib/libkio.so.4(_ZN3KIO5Slave9qt_invokeEiP8QUObject+0x9a) [0x41b8801a]
27: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x17e) [0x40a6b98e]
28: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEii+0xed) [0x40a6bfbd]
29: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN15QSocketNotifier9activatedEi+0x30) [0x40dbfb90]
30: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN15QSocketNotifier5eventEP6QEvent+0x50) [0x40a8b400]
31: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN12QApplication14internalNotifyEP7QObjectP6QEvent+0x8f) [0x40a08c4f]
32: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x83) [0x40a0a813]
33: /opt/kde3/lib/libkdecore.so.4(_ZN12KApplication6notifyEP7QObjectP6QEvent+0x221) [0x40719a11]
34: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN10QEventLoop23activateSocketNotifiersEv+0x116) [0x409fcdf6]
35: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN10QEventLoop13processEventsEj+0x702) [0x409b6062]
36: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN10QEventLoop9enterLoopEv+0xa1) [0x40a20be1]
37: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN10QEventLoop4execEv+0x26) [0x40a20a26]
38: /usr/lib/qt3/lib/libqt-mt.so.3(_ZN12QApplication4execEv+0x1f) [0x40a0a6df]
39: kmail(_ZN12QApplication16x11ClientMessageEP7QWidgetP7_XEventb+0x2da) [0x804a696]
40: /lib/tls/libc.so.6(__libc_start_main+0xd0) [0x40fc5e80]
41: kmail(_ZN7QObject16checkConnectArgsEPKcPKS_S1_+0x35) [0x804a401]
]
Comment 2 Philip Rodrigues 2005-10-10 13:06:35 UTC
Not a crash.

Do you have multiple versions of KDE installed on your system? Looks like kmail might be picking up an old version of kdelibs/qt .
Comment 3 Alain Knaff 2005-10-20 00:09:52 UTC
Just tried the new Beta2.

Kmail no longer freezes permanently, but it still quite often temporarily climbs to 90% CPU usage (especially on startup, and when changing folders). In general it feels much less snappy than it used to in 3.4
Comment 4 Alain Knaff 2005-11-12 11:57:42 UTC
Just tried RC1.

Kmail is still slower than it used to be until 3.4.x (especially right after startup).

However, there seems to be some improvement since Beta2 ;-)


Comment 5 Philip Rodrigues 2006-02-11 19:27:13 UTC
does the problem persist in 3.5.0 or 3.5.1? If not, you should probably close this bug as WORKSFORME. If there are other problems (slowness, etc), put them in a separate bug report.
Comment 6 Alain Knaff 2006-02-14 00:31:11 UTC
The freeze and CPU usage still happen. Moreover, at kmail startup, the following message is printed over and over again to stderr:

kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)] ignoring empty path
Comment 7 Carsten Burghardt 2006-04-09 13:05:34 UTC
> kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)] ignoring
> empty path _______________________________________________


Your account seems to be corrupted if several folders do not have an imap 
path. Does it help to recreate it?
Comment 8 Alain Knaff 2006-04-10 15:12:29 UTC
I wiped all my kmail config, and tried to re-configure my account.

However, in the current kmail config dialogs there seems to be no place where to configure the mail directory...

And yes, while kmail tried to index all my files in my home-directory as if they were mail folders, it was dogslow as hell, while the UI was basically frozen (no refresh, no reaction to any mouse or keyboard events)

Time for kill -9.

Well, no big loss, I had switched to Thunderbird anyways a couple of months ago.
Comment 9 Ismail Onur Filiz 2006-04-11 02:25:45 UTC
The configuration file for KMail is: ~/.kde/share/config/kmailrc and the data directory is: ~/.kde/share/apps/kmail . Could you try moving this file and directory away and starting KMail?
Comment 10 Philip Rodrigues 2006-11-20 23:14:27 UTC
Does this problem persist with the latest KMail and a completely clean config (create a new user, and try with that user)?
Comment 11 Philip Rodrigues 2007-01-02 12:40:21 UTC
Feedback timeout, but please reopen if the problem persists (see comment 10)
Comment 12 Alain Knaff 2007-01-03 09:44:59 UTC
Sorry for the slow response. But due to this issue and numerous other kmail issues, I switched to Thunderbird a while ago.

However, just for testing I tried kmail again, from a clean config (wiping my old kde/share/apps/kmail kde/share/config/kmail.eventsrc kde/share/config/kmailrc, the problem could still be reproduced.

Immediately after connecting to server, kmail became slow (> 80% CPU consumed), and totally unresponsive (pthread issue?). Moreover, it was scanning non-mail related files just as if they were folders. Ok, back to Thunderbird. These stability and performance issues in kmail are a *major* drawback for me. Thunderbird, on the other hand, works just fine.
Comment 13 Philip Rodrigues 2007-01-05 21:15:28 UTC
Alain, do you have time to investigate this further? If so, we can probably think of some things to try, otherwise it's probably best to close the report.
Comment 14 Alain Knaff 2007-01-10 17:53:20 UTC
I do have a small amount of time, so let's give it a try.
Comment 15 Philip Rodrigues 2007-01-11 21:19:21 UTC
OK, some things that might be useful if you have the time:

* If you can, get the latest 3.5 branch version from SVN. If not, 3.5.6 will be out fairly shortly, so you might prefer to wait to try that.

* Just to be 100% sure that the problem isn't due to some old config files, create a new user, and run KMail with that user.

* If KMail freezes, kill it with "kill -SEGV <pid-of-kmail>". That should get you a backtrace dialog, from which you can paste the backtrace here. If there's debug output on the console, that might be useful too
Comment 16 Bram Schoenmakers 2007-03-04 11:30:06 UTC
*** Bug 141165 has been marked as a duplicate of this bug. ***
Comment 17 Tristan Hoffmann 2008-03-18 21:50:32 UTC
Please reopen, if you can provide the needed information (tests with a newer version of KMail), thanks.