Bug 141045 - application/rss+xml feeds do not get recognized
Summary: application/rss+xml feeds do not get recognized
Status: RESOLVED DUPLICATE of bug 103077
Alias: None
Product: akregator
Classification: Unclassified
Component: akregator konqueror plugin (show other bugs)
Version: 4.9.1
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-02 05:30 UTC by David Lee
Modified: 2012-11-14 14:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Lee 2007-02-02 05:30:28 UTC
Version:           알 수 없음 (using KDE 3.5.5, Kubuntu (edgy) 4:3.5.5-0ubuntu3)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17-10-generic

It seems that akregator (konqueror plugin) is not able to detect and handle feeds that have the MIME type "application/rss+xml". When clicking on a link that points to such a file, konqueror pops up the standard dialog that is shown when unknown file types are downloaded. Also, right clicking on the link itself does not display a "Add feed to Akregator" menu item.

To reproduce:
go to http://bugs.beryl-project.org/ticket/116
click (or right click) on "RSS Feed" at the bottom of the page.

Expected Behavior:
clicking on the link should add the feed to Akregator, or at least confirm if the user wants to.
Right clicking on the link should display a context menu that has the "Add feed to Akregator" option.

Possible explanations:
It is possible that the file is only sent with the MIME type upon clicking the link, and therefore, can only be determined to be an RSS feed once the file is requested. If this is the case, what should be the proper workaround for the Akregator plugin to notice such a link?
Comment 1 Adrián Chaves (Gallaecio) 2012-09-30 20:08:00 UTC
I could confirm this issue with:
- Webpage: http://page2rss.com/502909832d9a4de3c20c2d59b05d7a31 (the left-side pane has an RSS icon)
- Konqueror 4.9.2.
- Akregator Plugin 1.0.0.

I just clicked the icon, and I get nothing special about Akregator. I do not get anything special either with a right-click.
Comment 2 Maarten De Meyer 2012-11-14 14:22:03 UTC

*** This bug has been marked as a duplicate of bug 103077 ***