Bug 140198 - JJ: feature request: option to selectively disable submitting certain tracks/albums from collection to last.fm
Summary: JJ: feature request: option to selectively disable submitting certain tracks/...
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Services/Last.fm (show other bugs)
Version: 2.3-GIT
Platform: Gentoo Packages Linux
: NOR wishlist with 160 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords: junior-jobs
: 145641 160417 170532 211495 250489 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-17 17:34 UTC by Dariusz Dworznik
Modified: 2013-03-08 15:59 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments
Two screens of the official last.fm client, with scrobbling enabled/disabled. (17.32 KB, image/png)
2007-05-23 11:51 UTC, Antonio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dariusz Dworznik 2007-01-17 17:34:54 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
OS:                Linux

it would be nice to manage what music is to be sent to last.fm. it could be an addition to statistics tab in track information.
Comment 1 Peter C. Ndikuwera 2007-01-23 13:27:05 UTC
That's a very unhelpful request! You need to give more detail about your request...

What features would you like added? How would you want them presented?
Comment 2 Dariusz Dworznik 2007-01-23 14:51:55 UTC
I thought that this is self-explanatory. amaroK comes with really nice last.fm support. It could be a great addition if it could be configurable what music is submitted to last.fm and what is not. If last.fm is enabled, the default action would be to submit unless stated otherwise in track/album options (it could be a flag to be set in 'Edit track information' maybe in 'statistics' tab?). It would be very helpful to avoid sending unwanted information to last.fm profile - like badly tagged music, samples, unknown music that is listen just to check what it is. 

This is just a proposal. I hope this explanation is more helpful. 
Comment 3 Sebastian Krämer 2007-03-07 00:42:48 UTC
I'm looking for something like it. But I don't want that to be stored in a database or even an id3 tag (I don't think that this would be reasonable -- nor is my request about disabling only certain songs). (Speaking about badly tagged files, they're eventually rejected by last.fm anyway btw.)

What I have in mind is a small button/icon that /can/ be integrated to the main toolbar, where you can 1-click enable/disable scrobbling. Although I scrobble most of the songs I play, you sometimes don't want that for whatever reason (new, untagged music, radio stream with crappy id3 tags..). Opening and clicking through the main configuration is more work than necessary IMO.
The idea I'm having is basically a green/red circle/button like the one used in the last.fm standalone app, that's just perfect!

Dariusz, would that be ok for (since you filed this request) or do you "insist" on automatic disabling (I'd open another feature request then *g)
Comment 4 Dariusz Dworznik 2007-03-11 09:03:23 UTC
I agree on any change that makes that easier. I think that your suggestion is quite convenient and not that hard to develop.. so I opt for it.
Comment 5 Bram Schoenmakers 2007-05-18 19:44:13 UTC
*** Bug 145641 has been marked as a duplicate of this bug. ***
Comment 6 Antonio 2007-05-23 11:51:27 UTC
Created attachment 20677 [details]
Two screens of the official last.fm client, with scrobbling enabled/disabled.

This is a feature I've been sorely missing from amaroK as well. There are many
cases where scrobbling songs seems awkward and unnecessary, as already pointed
out. And if you're a musician and need listen to a single song in a loop many
times or listen to yet unreleased songs of yourself, scrobbling really makes no
sense.

I really find the behavior of the official last.fm client very handy: one
button and one click to disable/enable.

So maybe we could have a similar button somewhere prominent, but only if a
last.fm profile is configured. Right next to the repeat/shuffle buttons would
be a good place IMHO.
Comment 7 Daniel Aleksandersen 2007-06-06 19:35:23 UTC
How about having a separate folder tree in the Last.fm configuration tab? Then users could check/uncheck which folders songs should be submitted from.
Comment 8 Michael Helmling 2007-06-06 19:47:42 UTC
That might be a good thing for one of the problems, but if you just want to temporarily disable ALL last.fm submission this completely unhandy. Maybe we should consider two improvements:

- excluding folders from last.fm
- temporarily disable last.fm even if it's activated under settings

The first is a good option if you for some reason just don't want specific files to appear on your profile. The second is e.g. handy in the case of a musician that has to listen to a file many times, as s/o mentioned above.
Comment 9 Daniel Aleksandersen 2007-06-06 19:58:53 UTC
I disagree with a temporary disable button. It will clutter the user interface for non-Last.fm users. If Last.fm Radio/Suggestions had it's own browser tab such a button could be placed under that tab.

NB: Please vote for the bug, guys!!
Comment 10 Michael Helmling 2007-06-06 20:03:43 UTC
Why not add a button to the list of buttons that can be added to the toolbar but aren't there by default? (like burn on CD, mix playlist, statistics etc) This way other users are not affected.
Comment 11 Daniel Aleksandersen 2007-06-06 20:11:17 UTC
That could be an option. But it should not be a default option in the toolbar! However I still think a Last.fm browser tab with radio, suggestions, and disable/enable would be the best option.

Exclusing Last.fm folder tree... Could that be combined with the current folder tree, by the way? One click in the check box for selct, two click for selct and scrubbling, and tree clicks for unselect.
Comment 12 richlv 2007-06-07 10:56:28 UTC
just a quick note : it would make sense to make this a dcop call.
that is, unless scoring disabling does not disable last.fm submissions already (there is a dcop call for that).
Comment 13 Daniel Aleksandersen 2007-06-23 15:13:34 UTC
The official scrubling application (Last.fm Player) uses a folder tree.
Comment 14 Alex Kelly 2008-02-16 18:56:55 UTC
*** This bug has been confirmed by popular vote. ***
Comment 15 Lydia Pintscher 2008-04-05 18:09:42 UTC
*** Bug 160417 has been marked as a duplicate of this bug. ***
Comment 16 chinese_chater 2008-09-06 14:05:50 UTC
*** Bug 170532 has been marked as a duplicate of this bug. ***
Comment 17 Myriam Schweingruber 2010-09-07 21:43:35 UTC
*** Bug 250489 has been marked as a duplicate of this bug. ***
Comment 18 Mikko C. 2010-12-11 16:20:34 UTC
*** Bug 211495 has been marked as a duplicate of this bug. ***
Comment 19 Matěj Laitl 2013-01-11 00:11:28 UTC
Implementation hint to myself (or someone other): add following QCheckBox to Last.fm plugin config:

[ ] Don't scrobble tracks with following label: QComboBox with prefilled labels used in collection.
Comment 20 vedant agarwala 2013-02-25 05:01:19 UTC
Matej could  you please expand on your "implementation hint"? I need help in developing a patch for this bug
Comment 21 Matěj Laitl 2013-02-25 10:55:38 UTC
(In reply to comment #20)
> Matej could  you please expand on your "implementation hint"? I need help in
> developing a patch for this bug

Not really, you must try yourself! :-) Actual scrobbling is done in StatSyncing::Controller.
Comment 22 Matěj Laitl 2013-03-08 15:59:00 UTC
Git commit 405c14ec387acfca28898494959a97ec7512efa1 by Matěj Laitl, on behalf of Vedant Agarwala.
Committed on 08/03/2013 at 16:35.
Pushed by laitl into branch 'master'.

Last.fm: support for filtering tracks to scrobble (by label)

FEATURES:
 * Added support to filter tracks to scrobble to Last.fm by label. Patch by
   Vedant Agarwala. (BR 140198)

Vedant, I had to make a couple of changes for this to actually work:
 a) actually save and read setting to file in LastFmServiceConfig
 b) prevent null pointer dereference in updateNowPlaying()
Please test the feature just implemented thoroughly next time!
FIXED-IN: 2.8
REVIEW: 109283
DIGEST: Amarok now supports filtering tracks to scrobble to Last.fm
CCMAIL: Vedant Agarwala <vedant.kota@gmail.com>

M  +2    -0    ChangeLog
M  +45   -17   src/services/lastfm/LastFmConfigWidget.ui
M  +4    -0    src/services/lastfm/LastFmServiceConfig.cpp
M  +10   -0    src/services/lastfm/LastFmServiceConfig.h
M  +45   -7    src/services/lastfm/LastFmServiceSettings.cpp
M  +9    -0    src/services/lastfm/LastFmServiceSettings.h
M  +25   -0    src/services/lastfm/ScrobblerAdapter.cpp
M  +7    -0    src/services/lastfm/ScrobblerAdapter.h
M  +1    -0    src/statsyncing/Process.cpp
M  +2    -1    src/statsyncing/ScrobblingService.h

http://commits.kde.org/amarok/405c14ec387acfca28898494959a97ec7512efa1