Bug 140136 - Aspect ratio crop and selection widget improvements
Summary: Aspect ratio crop and selection widget improvements
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-Crop (show other bugs)
Version: 4.9.0
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-16 00:48 UTC by JM
Modified: 2016-06-29 19:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 0.9.1


Attachments
Implementation (35.72 KB, patch)
2007-01-16 00:50 UTC, JM
Details
implementation (35.08 KB, patch)
2007-01-16 10:21 UTC, JM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JM 2007-01-16 00:48:12 UTC
Version:           svn (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
OS:                Linux

Improvements in apect ratio crop image effect:
* Automatically adjust selection orientation.
* Hold CTRL to move the opposite corner too.
* Hold SHIFT to move the closest corner to the mouse pointer.
* Allows creating new selection (by dragging from a corner).

All of those improvements are in fact implemented in imageselectionwidget. I tried to keep the original behavior where possible.

To Dos:
* I need to gather more user experience on using the CTRL and SHIFT keys. Come up with you idea of command.

I already sent a previous version few months ago, but I'm unable to find it now in bugzilla. The old version is obsoleted by this version.
Comment 1 JM 2007-01-16 00:50:05 UTC
Created attachment 19297 [details]
Implementation
Comment 2 caulier.gilles 2007-01-16 07:33:24 UTC
JM,

The old B.K.O file is in digikamimageplugins, not digikam.

Gilles Caulier
Comment 3 caulier.gilles 2007-01-16 07:34:54 UTC
*** Bug 128472 has been marked as a duplicate of this bug. ***
Comment 4 caulier.gilles 2007-01-16 07:43:50 UTC
JM,

Your patch cannot be applied to svn trunk. Something is broken in your patch...

I'm agree to apply your improvement to the Ratio crop tool, but take a care to use the last implementation from svn "trunk" to build your patch, else, i will cannot apply it to source code.

Also, please take a look at "contrib" web page to learn how to do a patch properlly. 

http://www.digikam.org/?q=contrib

Thanks in advance for your help

Gilles Caulier
Comment 5 JM 2007-01-16 10:21:40 UTC
Created attachment 19300 [details]
implementation
Comment 6 caulier.gilles 2007-01-16 10:36:41 UTC
SVN commit 624083 by cgilles:

digiKam from trunk : Ratio Crop Image Plugin : Great Improvements from Jaromir Malenko :

* Automatically adjust selection orientation.
* Hold CTRL to move the opposite corner too.
* Hold SHIFT to move the closest corner to the mouse pointer.
* Allows creating new selection (by dragging from a corner).

Thanks to Jaromir for this nice job !

BUG: 140136
CCMAIL: digikam-devel@kde.org

 M  +39 -7     imageplugins/imageeffect_ratiocrop.cpp  
 M  +37 -32    imageplugins/imageeffect_ratiocrop.h  
 M  +413 -154  libs/widgets/imageplugins/imageselectionwidget.cpp  
 M  +10 -0     libs/widgets/imageplugins/imageselectionwidget.h  
Comment 7 caulier.gilles 2007-01-16 10:41:44 UTC
Jaromir,

I love your patch. It's excelent thanks again...

If you want to continue to maintain this tool in the future, no problem. Just take a look into bugzilla at this place :

http://bugs.kde.org/buglist.cgi?product=digikamimageplugins&component=Core%20Plugin&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED

... and try to fix the files #120450 and #128293 in first...

Thanks in advance for your future help (:=)))...

Gilles Caulier