Bug 128472 - Aspect ratio tool enchancements - auto orientation, new selection
Summary: Aspect ratio tool enchancements - auto orientation, new selection
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-Crop (show other bugs)
Version: 4.9.0
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-02 00:33 UTC by JM
Modified: 2021-04-04 08:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.3.0


Attachments
imageeffect_ratiocrop.cpp (29.77 KB, text/x-c++src)
2006-06-02 00:34 UTC, JM
Details
imageeffect_ratiocrop.h (3.18 KB, text/x-c++hdr)
2006-06-02 00:35 UTC, JM
Details
imageselectionwidget.cpp (44.07 KB, text/x-c++src)
2006-06-02 00:35 UTC, JM
Details
imageselectionwidget.h (6.72 KB, text/x-c++hdr)
2006-06-02 00:36 UTC, JM
Details
diff -u patch (27.51 KB, text/x-diff)
2006-06-02 08:08 UTC, JM
Details
svn patch (untested) (26.98 KB, text/x-diff)
2006-06-02 08:20 UTC, JM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JM 2006-06-02 00:33:37 UTC
Version:            (using KDE KDE 3.5.3)
Installed from:    Gentoo Packages

I implemented various enhancements to aspect ratio plug-in. The changes include
1) Automatic setting of orientation
2) It is possible to "click and draw" a new selection. You do not need to move the actual selection to desired position.

I changed imageselectionwidget and aspect ratio dialog.

Minor issues
- Enhancement 2) slightly changes original behavior.  Clicking outside of selection start drawing a new selection now. Before it moved the selection to this position. This can be reverted by changing m_allowCreatingNewRegion to false. If this version will be approved then this this variable can be removed from source code.
- I was not able to catch the "CTRL released" event. (This is due to my minor knowledge of qt.) The relevant code is prepared in function keyReleased. The code works perfectly now, but somebody might wish to look at it. Remove the calling of this function from mouseReleaseEvent() afterwards.

I wish every photographer fun when cropping the pictures. Bye
Comment 1 JM 2006-06-02 00:34:57 UTC
Created attachment 16419 [details]
imageeffect_ratiocrop.cpp
Comment 2 JM 2006-06-02 00:35:29 UTC
Created attachment 16420 [details]
imageeffect_ratiocrop.h
Comment 3 JM 2006-06-02 00:35:53 UTC
Created attachment 16421 [details]
imageselectionwidget.cpp
Comment 4 JM 2006-06-02 00:36:23 UTC
Created attachment 16422 [details]
imageselectionwidget.h
Comment 5 Chris Howells 2006-06-02 01:02:02 UTC
Hi,

Please attach unified diffs created with the diff -u command.

Thanks.
Comment 6 caulier.gilles 2006-06-02 07:59:51 UTC
Hi JM

I'm interresed to test your implementation. please use "svn diff > mypatch" against trunk to make a patch. Thanks in advance

Gilles
Comment 7 JM 2006-06-02 08:08:38 UTC
Created attachment 16425 [details]
diff -u patch
Comment 8 JM 2006-06-02 08:20:22 UTC
Created attachment 16426 [details]
svn patch (untested)

I was not able to test this as I haven't found configure
Comment 9 JM 2006-06-02 08:41:22 UTC
I forgot to mention another feature.
3) when resizing selection and holding CTRL the center of selection keeps its place and the opposite corner is moved.
Comment 10 caulier.gilles 2006-06-02 08:50:13 UTC
JM,

Your implementation have been done using current stable implementation of digiKam not trunk.

Stable branch is now just a bugfix release. New features must be add to trunk branch now.

Your patch cannot be apply on trunk branch of digiKam (future 0.9.0). I'm very interresed by your new features. Please backport your code using svn trunk, not svn stable.

Thanks in advance

Gilles Caulier
Comment 11 caulier.gilles 2006-07-28 14:40:41 UTC
Some new about porting code to 0.9.0 (svn trunk) ? Thanks in advance

Gilles
Comment 12 caulier.gilles 2007-01-16 07:34:53 UTC
This file is now obsolete.

Gilles Caulier

*** This bug has been marked as a duplicate of 140136 ***
Comment 13 caulier.gilles 2021-04-04 08:36:25 UTC
Fixed with #140136