Bug 139341 - Filters + dIMAP causes filtered messages to temporarily disappear until folder is refreshed
Summary: Filters + dIMAP causes filtered messages to temporarily disappear until folde...
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: disconnected IMAP (show other bugs)
Version: 1.9.9
Platform: Debian testing Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 159693 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-12-29 02:33 UTC by Adam Porter
Modified: 2010-01-01 23:26 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Porter 2006-12-29 02:33:58 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages

I've noticed this behavior for some time, but I think I finally understand what's happening well enough to be able to report it.

Disconnected IMAP account used with incoming message filters:

1.  Message arrives in "inbox", the root folder for the dIMAP account.
2.  KMail downloads the message when the account is synced.
3.  After downloading the message, KMail runs the configured filters on it, finding a header match, and moving it to a subfolder in the dIMAP account.
4.  The message disappears from "inbox" and appears in the subfolder.
5.  The sync process has continued while this is going on, and *after the message is moved to the subfolder*, the sync process reaches the subfolder that the message was moved to.
6.  According to the IMAP server, the message that was just moved to the subfolder is not in the subfolder, so KMail removes it from the local copy of the  subfolder.  Hence, message disappears.
7.  KMail uploads messages in the subfolder to the IMAP server that are not currently on the IMAP server's copy of the subfolder.
8.  The sync process continues to other subfolders in the dIMAP account.
9.  On the *next* account sync or refresh of that individual subfolder, KMail redownloads the filtered message from the server.  Hence, message reappears.

This behavior is very consistent; I've been seeing it for months.  It's quite reliable too; the messages always reappear in the right place on the second sync/refresh.  It's quite annoying, though, to have to double-sync/refresh your account to see all your new messages.
Comment 1 Adam Porter 2006-12-29 02:35:58 UTC
And let me add, I really don't know how KMail still uploads the message after it disappears from the local view of the subfolder, but it always does.
Comment 2 Bjoern Mohrmann 2007-05-12 10:15:06 UTC
Same issue here. Message that is moved manually (NOT during a running sync) to another folder, disappeares on next sync. After another sync the message reappears.

This is also reproducable. Locally created items (same happening with calendar and  contact items) disappear on sync and reappear on second sync.

System: Ubuntu feisty
KDE Version: 3.5.6
KMail Version: 1.9.6
Comment 3 Bjoern Mohrmann 2007-05-12 10:23:36 UTC
Perhaps I should add some information about the mail server. The server is running qmail and courier-imapd.

courier-imapd versions:

psa-courier-imap-3.0.8-suse10.0.build80060614.16
psa-courier-imap-add-8.0.1-suse10.0.build80060614.16
Comment 4 Thomas McGuire 2008-04-03 20:36:21 UTC
*** Bug 159693 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Werner 2008-04-03 20:56:28 UTC
Sorry for the duplicate.

I see the described behavior with kde 3.5.9, earlier versions didn't show it (for me). I don't know what is running on the imap-server. Is it possible that this could be triggered by changes/updates to the server?
Comment 6 Björn Ruberg 2010-01-01 23:26:44 UTC
I don't see that behaviour in recent KDE 4.3.4. Please report if you do.