Bug 136821 - deleted message not marked as read
Summary: deleted message not marked as read
Status: RESOLVED DUPLICATE of bug 117717
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.1
Platform: Debian testing Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 160632 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-04 15:57 UTC by Tarlika Elisabeth Schmitz
Modified: 2009-12-30 23:45 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tarlika Elisabeth Schmitz 2006-11-04 15:57:45 UTC
Version:           1.9.1 (using KDE KDE 3.5.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Deleting an IMAP message is implemented in 2 steps:
1) copy to Trash
2) mark original as deleted

KMail does not mark the original IMAP message as read (seen). Hence mail notifiers such as Gnubiff, Korn, or even KMail's own mail notification count these messages still as new.

When deleting a message, Thunderbird and Evolution mark it as seen. This way mail notifiers will not include deleted messages in the new message count.

This has been reported before (72424 + 65418). Both bugs have been closed as a duplicate of bug 26986, which they are not; the latter requests two functions: "delete" and "mark for deletion".

From a user point of view, the KMail behaviour is not comprehensible, and it renders mail notifiers useless. Or people resort to compressing the inbox manually as a fudge (http://lists.kde.org/?l=kde&m=116257270628700&w=2).

When I get 100 spam messages, I have *seen* enough of them to delete them and don't want to have to manually expunge them, too. (The "Auto-compact folders" does not seem to take effect until exit.)
Comment 1 Bram Schoenmakers 2008-04-10 18:18:26 UTC
*** Bug 160632 has been marked as a duplicate of this bug. ***
Comment 2 Björn Ruberg 2009-12-30 23:45:56 UTC

*** This bug has been marked as a duplicate of bug 117717 ***