Bug 136566 - Connecting to ICQ doesn't work anymore
Summary: Connecting to ICQ doesn't work anymore
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 140 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 136568 136613 136624 136639 136697 136698 136717 136785 136787 136839 136905 136906 136914 137012 137092 137147 143919 143998 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-31 14:13 UTC by Patrick
Modified: 2008-01-13 15:21 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
strace output (97.87 KB, text/plain)
2008-01-13 10:58 UTC, Pavel Zheltobryukhov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick 2006-10-31 14:13:11 UTC
Version:           0.12.3 (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
OS:                Linux

Since today (around 11:50 UTC), connecting to the ICQ network doesn't work anymore for me.

As somebody in freenode/#kopete pointed out, version 0.12.2 still works. Other clients also still work, so this seems as if a change in kopete-0.12.3 causes this problem.
Comment 1 Patrick 2006-10-31 14:26:22 UTC
The discussion in #kopete just brought up the following:

- Problem exists on gentoo, Kubuntu
- Problem doesn't exist on Debian, Fedora Core 5

(???)
Comment 2 Robert Penz 2006-10-31 14:26:54 UTC
I've the same problem with 0.12.3 (KDE 3.5.5 packages for Kubuntu 6.06)

get following debug output

kutils (KSettings::Dispatcher): [void KSettings::Dispatcher::registerInstance(KInstance*, QObject*, const char*)] kopete
kdecore (KNetwork resolver): shouldResInit: /etc/resolv.conf updated
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
Comment 3 Mathias Soeken 2006-10-31 14:46:09 UTC
Using kubuntu 6.10. Kopete seems to set my status online, because I can receive messages. But the kopete keeps in Connecting... status in the UI.
Comment 4 Roland Wolters 2006-10-31 14:51:30 UTC
I can *confirm* the problem here in Fedora Core 5. In that case I have to disagree with comment #1.

kopete-version: 0.12.3
Comment 5 mrdocs 2006-10-31 15:22:20 UTC
Suse 10.1 both 0.12.3 and 0.11.1 do not login to AIM. GAIM works

as mentioned in #kopete on freenode, perhaps a more global issue ? This ceased working this morning early CET time at a guess
Comment 6 Felix Oppermann 2006-10-31 15:24:46 UTC
For me icq and AIM are broken since today. Both do not connect. 
By the way, I am still able to receive messages on icq, though kopete things I am offline.

Kopete-version: 0.12.3 (KDE 3.5.5) on gentoo

The error messages I get are similar to the ones above.
Comment 7 Mathias Soeken 2006-10-31 15:27:12 UTC
When I am logging in while "Connecting" (so twice clicking on online) I can see my contacts and kopete says that someone else is logged in using by uin.
Comment 8 Vladimir Fuka 2006-10-31 15:31:26 UTC
I also confirm on SuSE 10.0 KDE 3.5.5.

kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No
presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No
presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No
presence exists for internal status 99! Returning Offline
Comment 9 Bram Schoenmakers 2006-10-31 15:34:57 UTC
I had this as well today, but all works OK now. I guess it was a server error.
Comment 10 Robert Penz 2006-10-31 15:39:53 UTC
does still not work here (just tried it)
Comment 11 Vladimir Fuka 2006-10-31 15:40:28 UTC
> I had this as well today, but all works OK now. I guess it was a server error. 

I think that no. For me the bug continues.
Comment 12 Lorenz Röhrl 2006-10-31 15:55:03 UTC
I just connected succesful to icq. Gentoo, Kde 3.5.5-r1, Kopete 0.12.3
Comment 13 Patrick 2006-10-31 16:18:11 UTC
Still not working here. So probably it depends on what server someone is trying to logon, and not on the distro (I suspected extra patches there)...
Comment 14 Tobias Linke 2006-10-31 16:28:55 UTC
*** This bug has been confirmed by popular vote. ***
Comment 15 Maksim Orlovich 2006-10-31 16:31:08 UTC
I have an old build here --- 0.11 -- and it did something rather funny --- it's not connecting, but I actually got incoming messages..
Comment 16 Patrick 2006-10-31 16:36:23 UTC
That's because it is in fact connecting, just that kopete does somehow not "know" / show it. I captured the network traffic, and there is a successful login going on, including buddy list transfer, away messages and incoming messages. The same in version 0.12.3. So it seems both my assumptions were wrong: It's neither a kopete version dependant nor a distribution (patch-) dependant problem.

The fact that it works for some could be caused by an inconsistency in versions of the server software on the AOL servers. But I'll stop making assumptions now ;)

Comment 17 Tobias Langner 2006-10-31 17:50:00 UTC
I have the same problems as the posters above using Ubuntu 6.06 with KDE 3.5.4 and Kopete 0.12.2.
Comment 18 Gilles Schintgen 2006-10-31 18:06:56 UTC
Same problem with kopete-0.11.3 (kde-3.5.3) an a gentoo system.
Comment 19 Florian Merz 2006-10-31 18:21:03 UTC
Same for me here with version 0.12.3. The UI tells me it's trying to connect and I can't send message but I do receive messages. The only hint is this warning but this might be unrelated:

kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline

This is with Archlinux packages. There's only one patch applied by the archlinux developers which might be related to the problem, but I don't know if it actually is:

--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/oscartypes.h  2006/07/11 18:00:43 561016
+++ branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/oscartypes.h  2006/07/31 16:42:04 568263
@@ -237,7 +237,7 @@
  const WORD ICQ_MAJOR      = 0x0014;
  const WORD ICQ_MINOR      = 0x0034;
  const WORD ICQ_POINT      = 0x0000;
- const WORD ICQ_BUILD      = 0x0A0F;
+ const WORD ICQ_BUILD      = 0x0BB8;
  const char ICQ_OTHER[]      = { 0x00, 0x00, 0x04, 0x3d };
  const char ICQ_COUNTRY[]    = "us";
  const char ICQ_LANG[]       = "en";
Comment 20 Marcel Dischinger 2006-10-31 18:38:25 UTC
I have the same problem here with KDE 3.5.5 in Debian etch and a backported 3.5.0 for sarge. Licq works by the way. It really looks like something generic in kopete causing this, as the login apparently works but kopete ends up in a funny state (thinking it is not connected while it is in fact.).
Comment 21 Alex 2006-10-31 19:47:59 UTC
The same probleme appeared today :( Mandriva 2007, KDE 3.5.4, Kopete 0.12.2 - my contacts flash for a second and then disappear, then kopete says something like I tried logging on too many times or something. I have certain suspicions about ICQ itself, not Kopete, because it worked perfectly well before that.
Comment 22 Roman Jarosz 2006-10-31 19:51:17 UTC
SVN commit 600778 by rjarosz:

Fix bug 136566: Connecting to ICQ doesn't work anymore.

OSCAR server stops sending own user info at logon, we have to send own user info request like ICQ5.

BUG: 136566



 M  +1 -0      client.cpp  


--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/client.cpp #600777:600778
@@ -340,6 +340,7 @@
 		//we've finished logging in. start the services setup
 		kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "stage two done. setting up services" << endl;
 		initializeStaticTasks();
+		d->ownStatusTask->go();
 		ServiceSetupTask* ssTask = new ServiceSetupTask( d->connections.defaultConnection()->rootTask() );
 		connect( ssTask, SIGNAL( finished() ), this, SLOT( serviceSetupFinished() ) );
 		ssTask->go( true ); //fire and forget
Comment 23 Denis 2006-10-31 20:11:00 UTC
The patch works, Roman.
Thanks.
Comment 24 Robert Penz 2006-10-31 21:58:23 UTC
Fixed Kubuntu 6.06 Dapper packages are available under:

http://ubuntu.lnix.net/misc/kopete-fix/

(the Kubuntu 6.10 Edgy ones are just being compiled)

BIG thx to Frode M. Doeving !!!
Comment 25 Robert Penz 2006-10-31 21:59:26 UTC
ah the Dapper packages are for KDE 3.5.5
Comment 26 Patrick 2006-10-31 22:17:18 UTC
Patch is in Gentoo portage (thanks to flameeyes!) and works. Got ICQ again :)
Comment 27 Roland Wolters 2006-10-31 22:50:49 UTC
Confirmed as well, here on Fedora Core 5. Hope they will include the fix soon, I already submitted a patch at the bugzilla.

Thanks for the fast fix!
Comment 28 Will Stephenson 2006-10-31 23:05:30 UTC
SUSE packages will be available shortly under http://repos.opensuse.org/KDE:/KDE3
Comment 29 Christian Fritz 2006-11-01 01:34:25 UTC
Running Fedora Core 6, Kopete 0.12.3, I had the same problem the whole day. Funnily, creating a 'global identity' in the Kopete configuration resolves the problem (at least for me, for now).

-- just in case you can't wait till your distro-update arrives ;-)
Comment 30 Jens Krause 2006-11-01 12:11:52 UTC
adding + d->ownStatusTask->go();  to client.cpp worked fine on first try...kopete 0.12.2 got "online" and not only connecting status. Second try  
"kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No
presence exists for internal status 99! Returning Offline"
was back. While playing around icq got online status randomly with or without + d->ownStatusTask->go();
Comment 31 Michal Petrus 2006-11-01 12:32:56 UTC
I've performed update and I have still the same problem (Debian unstable)
Comment 32 Jan Ritzerfeld 2006-11-01 12:40:14 UTC
*** Bug 136613 has been marked as a duplicate of this bug. ***
Comment 33 Jan Ritzerfeld 2006-11-01 12:50:20 UTC
@Jens: The debug output you posted is just a WARNING. The internal status 99 is the internal connecting status. But there is no corresponding ICQ::Presence for this status because there is no need to have one in, e.g., the ICQ account context menu or the contact list.
Comment 34 Jan Ritzerfeld 2006-11-01 15:23:38 UTC
*** Bug 136568 has been marked as a duplicate of this bug. ***
Comment 35 Jan Ritzerfeld 2006-11-01 15:24:09 UTC
*** Bug 136639 has been marked as a duplicate of this bug. ***
Comment 36 Mathias Panzenböck 2006-11-01 16:05:39 UTC
With version 0.12.2 and 0.12.1 it dosn't work on my PC (KUbuntu 5.10) either.
Comment 37 Roman Jarosz 2006-11-01 16:14:05 UTC
SVN commit 600976 by rjarosz:

Fix bug when going online with any other status than online i.e. away, n/a... Kopete indicates the account as online.
The status on a server is correct.

Reported by Jan Ritzerfeld, thanks.
Please test it.

CCBUG: 136566



 M  +4 -2      liboscar/client.cpp  
 M  +1 -1      oscaraccount.cpp  


--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/client.cpp #600975:600976
@@ -340,7 +340,6 @@
 		//we've finished logging in. start the services setup
 		kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "stage two done. setting up services" << endl;
 		initializeStaticTasks();
-		d->ownStatusTask->go();
 		ServiceSetupTask* ssTask = new ServiceSetupTask( d->connections.defaultConnection()->rootTask() );
 		connect( ssTask, SIGNAL( finished() ), this, SLOT( serviceSetupFinished() ) );
 		ssTask->go( true ); //fire and forget
@@ -398,9 +397,12 @@
 	d->active = true;
 
 	if ( isIcq() )
-	{
 		setStatus( d->connectAsStatus, d->connectWithMessage );
 
+	d->ownStatusTask->go();
+
+	if ( isIcq() )
+	{
 		//retrieve offline messages
 		Connection* c = d->connections.connectionForFamily( 0x0015 );
 		if ( !c )
--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/oscaraccount.cpp #600975:600976
@@ -560,7 +560,7 @@
 	/* We're not even online or connecting
 	 * (when getting server contacts), so don't bother
 	 */
-	if ( !myself()->isOnline() )
+	if ( !engine()->isActive() )
 	{
 		kdDebug(OSCAR_GEN_DEBUG) << k_funcinfo << "Can't add contact, we are offline!" << endl;
 		return false;
Comment 38 Bram Schoenmakers 2006-11-01 23:03:03 UTC
*** Bug 136624 has been marked as a duplicate of this bug. ***
Comment 39 Jan Ritzerfeld 2006-11-02 11:17:21 UTC
*** Bug 136697 has been marked as a duplicate of this bug. ***
Comment 40 Jan Ritzerfeld 2006-11-02 11:43:12 UTC
*** Bug 136698 has been marked as a duplicate of this bug. ***
Comment 41 Jan Ritzerfeld 2006-11-02 18:25:02 UTC
*** Bug 136717 has been marked as a duplicate of this bug. ***
Comment 42 Thomas Kubelka 2006-11-02 20:31:46 UTC
same problem: recieve messages in icq, but can't send, kopete are not able to connect! i'new to linux and not really good in installing programms!! is there any other possibility to solve this?
Comment 43 Robert Penz 2006-11-02 22:50:11 UTC
Following packages fix the problem for dapper standard, dapper kde 3.5.5 and edgy: http://ubuntu.lnix.net/misc/kopete-fix/
Comment 44 Jan Ritzerfeld 2006-11-03 18:31:08 UTC
*** Bug 136785 has been marked as a duplicate of this bug. ***
Comment 45 Jan Ritzerfeld 2006-11-03 18:54:29 UTC
*** Bug 136787 has been marked as a duplicate of this bug. ***
Comment 46 Dipl. -Ing. (FH) Lechner Thomas 2006-11-03 21:51:37 UTC
Is there any way to solve this bug with SuSe 10.0 KDE 3.4.2. level"b".
I m lookin 4 an "easy" way (d-load -install- update etc..) since I am not a programmer but a user...
Using Kopete 0.11.92 (0.12 beta 1) I can no more connect to ICQ since a few days.....
Comment 47 Stefan Stefanov 2006-11-03 22:18:02 UTC
I can confirm that the trick with "non-online" status works. While kopete was claiming it is "connecting", I changed the status to "away" and the contact list instantly appeared. Next, after changing the status to "online", everything was ok.

I'm using kopete 0.12.3, KDE 3.5.5 FC5
Comment 48 Dipl. -Ing. (FH) Lechner Thomas 2006-11-03 22:44:52 UTC
Unfortunately this trick does NOT work on my system....
Comment 49 Volker Lanz 2006-11-04 04:27:32 UTC
Did anyone have any success with the patch from #37? I haven't tested extensively or debugged anything, just applied it to the SUSE 10 source rpm, rebuilt and installed that, but nothing appears to have changed.
Comment 50 Robert Penz 2006-11-04 09:27:14 UTC
I've the SVN commit 600976 applied here and icq works without any problems. I'm running kde 3.5.5 on kubuntu dapper.
Comment 51 Alexander Gran 2006-11-04 14:54:08 UTC
On my debian unstable, the trick doesn't work, either..
Comment 52 Volker Lanz 2006-11-04 15:50:49 UTC
Ah, okay. I've found and fixed the problem, now it works. If anyone needs a temporary SUSE 10.0 RPM to replace "kdenetwork3-InstantMessenger-3.5.5-7.3.i586.rpm" until SUSE/Novell publish an updated one, contact me.
Comment 53 Navina 2006-11-04 16:14:25 UTC
I'd need an rpm for Suse 10.1 .. kopete doesn't connect. If I move a contact into a different group, I can go online no matter which status I choose for 20 to 30 seconds, then it diesonnects, showing that my UIN had already been connected to the server and it would be rejected.
Comment 54 Robert Penz 2006-11-04 16:25:08 UTC
Please stop complaining about the bug and describing it. Use the patch provided by the kopete developers and compile it by yourself or wait for the package for your distribution. If no package is provided write to the packager of the original package, but not to this bug tracking system. The kopete developers can do nothing about it.

So report only if the patch is not working at your system. But in this case you need to provide more information than "it does not work". e.g. Version of Kopete, what you're doing excatly, debug output, strace, ...
Comment 55 k606dlts 2006-11-04 17:27:07 UTC
Does anyone know what was fixed with the kopete bug? I use micq 0.5.1 on Kubuntu 6.06 Dapper and it doesn't work, and unfortunatelly there is still no update for micq :-(

I would also be very happy if somebody could tell me why kopete could not connect, because at the moment I don't know anything about the problem...
Comment 56 Robert Penz 2006-11-04 17:45:13 UTC
The fix has been pasted into the Comment #37 From Roman Jarosz 2006-11-01 16:14  - just scroll up.
Comment 57 k606dlts 2006-11-04 18:33:54 UTC
Sorry, but I'm not a program developer :-(
I've read the program-code, but that doesn't tell me anything, so it would be very nice if someone can describe in "normal" language what the problem was and how it was fixed :-)
Comment 58 Robert Penz 2006-11-04 18:45:29 UTC
In short: AOL changed the ICQ interface in a way that kopete was not able anymore to detect that it is connected. The new way is not wait that we get user info but send it ourself (first patch - ICQ5 like) and assume that we're connected if we get the contacts send. (second patch). 
Comment 59 Roman Jarosz 2006-11-04 20:50:28 UTC
*** Bug 136839 has been marked as a duplicate of this bug. ***
Comment 60 Bram Schoenmakers 2006-11-05 18:55:29 UTC
*** Bug 136905 has been marked as a duplicate of this bug. ***
Comment 61 Bram Schoenmakers 2006-11-05 18:55:56 UTC
*** Bug 136906 has been marked as a duplicate of this bug. ***
Comment 62 Jan Ritzerfeld 2006-11-05 22:54:59 UTC
*** Bug 136914 has been marked as a duplicate of this bug. ***
Comment 63 Marco 2006-11-07 17:18:20 UTC
I haven't time to download from SVN, recompile, reinstall. Worse, probably my KDE 3.4.2 is incompatible with this patch and therefore I would need to upgrade the whole KDE. Since it's not unusual that a client type is broken by protocol changes on server side, it would be wonderful if the protocol implementation could be downloaded and installed as a sort of plug-in, so that one would not need a complete reinstallation from last SVN.
Comment 64 Patrick 2006-11-07 17:27:52 UTC
Well, those "plug-ins" would also have to be supplied by your distributor, just as your distributor should have supplied the patch DAYS ago. Go and complain to them, not to the kopete team, which fixed the bug quite fast.

Of course things like this wouldn't happen if IM developers wouldn't have to care about AOL jerks messing up the protocol every now and then... but that's another topic.
Comment 65 Bartosz Fabianowski 2006-11-07 18:49:27 UTC
*** Bug 137012 has been marked as a duplicate of this bug. ***
Comment 66 Steven Mulvay 2006-11-08 12:24:57 UTC
Note to kubuntu users:
If your're using Dapper you can fix the kopete icq problem by downloading a modified version of kopete here (http://ubuntu.lnix.net/misc/kopete-fix/kopete-dapper/kopete_3.5.5+kopete0.12.3-0ubuntu2~dapper3_i386.deb)

If your're using Edgy you can fix the kopete icq problem by downloading a different modified version of kopete here (http://ubuntu.lnix.net/misc/kopete-fix/kopete-edgy/kopete_3.5.5+kopete0.12.3-0ubuntu3_i386.deb) 
Comment 67 Jan Ritzerfeld 2006-11-09 12:11:32 UTC
*** Bug 137092 has been marked as a duplicate of this bug. ***
Comment 68 Jan Ritzerfeld 2006-11-10 12:40:17 UTC
*** Bug 137147 has been marked as a duplicate of this bug. ***
Comment 69 Marco 2006-11-10 15:07:17 UTC
<i>Well, those "plug-ins" would also have to be supplied by your distributor, just as your distributor should have supplied the patch DAYS ago. Go and complain to them, not to the kopete team, which fixed the bug quite fast. 
</i>

Unfortunately we don't live in a perfect world, OSS developers are great and mine is not a complain, rather a proposal. It seems that protocol problems occur quite often, an indipendent binary distribution of protocol implementations would be very useful. 
 
<i>Of course things like this wouldn't happen if IM developers wouldn't have to care about AOL jerks messing up the protocol every now and then... but that's another topic.</i>

In a perfect world an IM protocol would be standardized and widely used at a certain point. In a perfect world... 
Comment 70 Christian D. 2006-11-11 17:16:02 UTC
Still no fix available on Ubuntu. Can't use ICQ now for about two weeks!
Comment 71 Robert Penz 2006-11-11 17:33:00 UTC
What are you talking about? Can't you read? Scroll up!! There was a fix within 24h!
Comment 72 Christian D. 2006-11-11 18:14:03 UTC
I'm using Ubuntu edgy/feisty on AMD64 and there is no update available in the ubuntu repos. A normal user can't be expected to apply a diff or compile their own kopete! Thats what I meant.
Comment 73 Robert Penz 2006-11-11 18:20:33 UTC
here (http://ubuntu.lnix.net/misc/kopete-fix/kopete-edgy/ posted 2 times above) is the package for i386 and the source files for edgy - a simple rebuild of the package for amd64 is enough. and its really simple just read:

http://www.debian-administration.org/articles/20

ps: provide the package on a webserver so others can use it.
Comment 74 Patrick 2006-11-11 18:49:53 UTC
I have to agree with Christian. It's ridiculous to expect all kubuntu users to come here and download something, or search on the net (especially with kubuntu being a distro also aimed at Linux beginners). That's "the Windows way" - searching updates on the net, because there is no repository you can rely on.
The fix should have been supplied through the repository just as every other critical fix.
Comment 75 Robert Penz 2006-11-11 18:57:35 UTC
It's no security update, and the edgy-updates repository is not opend as far as I know, or was not opened when the problem occured. For dapper the update should be provided, but I'm not an ubuntu developer and so I'm not sure.
Comment 76 Roman Stanec 2006-11-11 19:41:53 UTC
As far as kopete v0.12.3 didn't work for me on Fedora 6, I tried the SVN version. And unfortunatelly it doesn't work either (kopete can't connect).
Exact procedure:
1) svn co -N svn://anonsvn.kde.org/home/kde/branches/KDE/3.5/kdenetwork
2) cd kdenetwork
3) svn co svn://anonsvn.kde.org/home/kde/branches/KDE/3.5/kde-common/admin
4) svn up kopete
5) make -f Makefile.cvs
6) ./configure --enable-debug --disable-smsgsm --disable-slp
7) cd kopete
8) make
9) cd kopete
10) ./kopete
11) tried to connect, but the kopete is connecting forever :-(
12) Kopete answered, that the account is already connected somewhere and it is disconnecting me :-( (Something like "You have logged in more than once....")
13) What I see in the terminal is:
kbuildsycoca running...
[user@localhost kopete]# QObject::connect: No such signal Kopete::AccountManager::accountUnregistered(Kopete::Account*)
QObject::connect:  (sender name:   'KopeteAccountManager')
QObject::connect:  (receiver name: 'unnamed')
Very strange! got a DCOPReplyFailed opcode, but we were not waiting for a reply!
Very strange! got a DCOPReplyFailed opcode, but we were not waiting for a reply!

14) That's all

Please note, that I didn't uninstall the official FC6 kopete version (v0.12.3) and I run the SVN version of kopete from the directory where it compiled itself

Any idea where I'm doing something wrong?
Please let me know if you need more info/debug. I really need to get it working asap. I don't want to change the messenger :-)
Comment 77 Hans Meier 2006-11-11 20:08:18 UTC
The bug in Kubuntu is not really specific when a corrected version will get into a repository, so I've posted this question there (https://launchpad.net/distros/ubuntu/+source/kopete/+bug/69494).
Comment 78 Jan Ritzerfeld 2006-11-11 20:13:37 UTC
@roman: AFAIK you have to uninstall the parallel, official FC6 kopete version first. Or, you have to customize your some environment variables I do not remember (KDE_DIRS, LD_LIBRARY_PATH...). And even then, only parts of the local installation will be used. Ask Thiago for more information about that.
Comment 79 Roman Stanec 2006-11-11 20:43:50 UTC
Thanks, I didn't realize that. Now it's working, great!
Comment 80 Andrew 2006-11-13 04:42:30 UTC
Hate to be one of the "unhappy" people. But mine :
Qt: 3.3.7
KDE: 3.5.5-0.2.fc5 Fedora-Core
Kopete: 0.12.3

is not working..
Please advise
Andrew
Comment 81 Andrew 2006-11-16 16:21:11 UTC
I meant that it produces the same "unable to connect" message as mentioned in this thread/bug. And , yes, the workaround is not helping.
Comment 82 Roman Jarosz 2007-04-07 11:24:51 UTC
*** Bug 143919 has been marked as a duplicate of this bug. ***
Comment 83 Roman Jarosz 2007-04-09 15:21:58 UTC
*** Bug 143998 has been marked as a duplicate of this bug. ***
Comment 84 Pavel Zheltobryukhov 2008-01-13 10:55:37 UTC
Kopete 0.50.0
KDE 4.0.0
OpenSUSE 10.3

is not working too
Comment 85 Pavel Zheltobryukhov 2008-01-13 10:58:38 UTC
Created attachment 22988 [details]
strace output

There is no errors, when kopete start from Konsole, so I ran it under strace.
May be, this strace output will be useful
Comment 86 Matt Rogers 2008-01-13 15:21:48 UTC
if it doesn't work for KDE 4, then you need to open a new bug and provide a packet dump (using wireshark or a similar program) rather than strace output