Bug 135053 - System tray icon toggles muting on middle mouse button click (complete patch included)
Summary: System tray icon toggles muting on middle mouse button click (complete patch ...
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
: 137705 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-03 18:09 UTC by Jens Rutschmann
Modified: 2007-11-11 01:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
patch based on KMix 2.6 (kde 3.5.4) (4.73 KB, patch)
2006-10-03 18:11 UTC, Jens Rutschmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Rutschmann 2006-10-03 18:09:05 UTC
Version:            (using KDE KDE 3.5.4)
Installed from:    Gentoo Packages
Compiler:          GCC 4.1.1 
OS:                Linux

The attached patch allows the user to choose which action a middle mouse button click on the tray icon executes:
 - Default is the old behaviour (open / close the mixer window)
 - New behaviour is muting / unmuting

I created a new checkbox in the configuration dialog to change the behaviour.

I'd love to see this code in the repository because I mute / unmute far more often than I use the mixer window (which is also accessible by the left mouse button click and the popup menu).
Comment 1 Jens Rutschmann 2006-10-03 18:11:07 UTC
Created attachment 18000 [details]
patch based on KMix 2.6 (kde 3.5.4)
Comment 2 Becheru Petru-Ioan 2007-01-17 03:23:01 UTC
U should try "Sound Mixer"  kicker applet, the fastest way to change the volumes with mouse! Anyway I give u my votes
Comment 3 Becheru Petru-Ioan 2007-01-17 03:24:09 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Christian Esken 2007-06-16 22:52:55 UTC
*** Bug 137705 has been marked as a duplicate of this bug. ***
Comment 5 Hans Chen 2007-09-28 12:18:49 UTC
Is this feature included in the latest KDE versions or just with Kubuntu?
Comment 6 Jens Rutschmann 2007-09-28 13:31:19 UTC
As far as I know the code is not in the official KDE repository yet. I never knew that Kubuntu has this functionality.
Comment 7 Christian Esken 2007-11-11 01:00:15 UTC
I have implemented the "middle mouse button mute/unmute" for KDE4.
The patch from Jens Rutschmann as seen in Comment #1 is not in the KDE3.x branch, as I am only doing bugfixing there (maintenance mode).

Conclusion: Will not be done for KDE3. Is done for KDE4. => Fixed
Comment 8 Christian Esken 2007-11-11 01:00:39 UTC
SVN commit 735136 by esken:

Cleanup layout code, and fix VerticalText widget layouting issues.
New: MiddleMouse button on SysTray mutes/unmutes Master.

BUGS: 135053


 M  +11 -0     kmixdockwidget.cpp  
 M  +1 -0      kmixdockwidget.h  
 M  +0 -2      kmixerwidget.cpp  
 M  +0 -13     mdwenum.cpp  
 M  +10 -19    mdwslider.cpp  
 M  +0 -1      mdwslider.h  
 M  +0 -10     mdwswitch.cpp  
 M  +5 -6      mixer.cpp  
 M  +15 -14    verticaltext.cpp  
 M  +1 -0      verticaltext.h  
 M  +0 -8      viewdockareapopup.cpp  
 M  +1 -4      viewsliders.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=735136