Bug 133944 - Digikam crashes when choosing an icon for a tag
Summary: Digikam crashes when choosing an icon for a tag
Alias: None
Product: digikam
Classification: Applications
Component: Tags-Engine (show other bugs)
Version: 0.9.0
Platform: unspecified Linux
: VHI crash
Target Milestone: ---
Assignee: Digikam Developers
Depends on:
Reported: 2006-09-12 04:24 UTC by Daniel
Modified: 2022-01-22 14:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2006-09-12 04:24:49 UTC
Version:           0.9.0-beta1 (using KDE 3.5.4 "release 62.1" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release

Using 0.9.0beta1:

Choosing an image / icon for a tag consistently crashes Digikam.

To reproduce:
1. Create a new tag, (or choose existent tag and Right-Click > Edit Tag).
2. Choose and icon and press EITHER "OK" OR "CANCEL"
3. Crash and the following message

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1239468368 (LWP 16225)]
[KCrash handler]
#6  0x080502cd in ?? ()
Comment 1 caulier.gilles 2006-09-12 07:25:58 UTC
There is no suitable backtrace into your report. Please compile digiKam using "./configure --enable-debug=full" and running digiKam under "gdb".

Gilles Caulier
Comment 2 Daniel 2006-09-13 21:53:50 UTC
Downgraded DigiKam to 8.2 - same issue. This did not occure with DigiKam 8.2 prior a recent OpenSuse update.

There are also other "icon-set-related" issues in the latest KDE packages for OpenSuse. Will file a bug there and get back to you if this turns out DigiKam-related.
Comment 3 Daniel 2006-09-18 17:40:29 UTC
It is very likely related to this:


Comment 4 Daniel 2006-09-24 02:04:00 UTC

Upgraded to Digikam 0.9.0-beta2 from
Still, same OpenSuSE 10.1 with latest KDE packages from 
other icon-related issues discussed in 


Running gdb /opt/kde3/bin/digikam produces the following:

(this is a second run from gdb, 1st run took several minutes to figure out what gdb is)

(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) y
Starting program: /opt/kde3/bin/digikam
[Thread debugging using libthread_db enabled]
[New Thread -1239128400 (LWP 15914)]
[New Thread -1242199136 (LWP 15915)]
[New Thread -1250591840 (LWP 15916)]
[Thread -1242199136 (LWP 15915) exited]
[Thread -1250591840 (LWP 15916) exited]
QInputContext: cannot create input context for non-toplevel widgets
QInputContext: cannot create input context for non-toplevel widgets
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1239128400 (LWP 15914)]
0x080502c8 in ?? ()
(gdb) cont
KCrash: Application 'digikam' crashing...
Program exited with code 0375.

This is KDE Crash window output from running digikam from console:
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1238964560 (LWP 15934)]
[KCrash handler]
#6  0x080502c8 in ?? ()
#7  0x080502c8 in ?? ()
#8  0x0847f3d8 in ?? ()
#9  0x00000020 in ?? ()
#10 0x00000031 in ?? ()
#11 0x00000002 in ?? ()
#12 0x00000060 in ?? ()
#13 0x00000060 in ?? ()
#14 0x00000018 in ?? ()
#15 0x0000062b in ?? ()
#16 0x08468a98 in ?? ()
#17 0x00000000 in ?? ()

This is the stuff in console:
dd@kasper:~> digikam
QInputContext: cannot create input context for non-toplevel widgets
QInputContext: cannot create input context for non-toplevel widgets
KCrash: Application 'digikam' crashing...

Choosing icons for shortcuts and in other places in KDE works fine. In digicam, the crash occurs after I choose the icon in the dialog, REGARDLES of if I press "OK" or "Cancel"
Comment 5 mikel 2006-10-09 20:43:51 UTC
digikam crashes for me when I select the icon from the browser for system icons, (don't even have to pick OK or cancel. Fedora Core 5, digikam 0.8.2, KDE 3.5.4-0.3.fc5
Comment 6 Daniel 2006-10-09 20:59:51 UTC
Filed a report with Novell. It contains more information about versions of DigiKam affected and steps to replicate the problem.

Comment 7 Daniel 2006-10-15 03:36:29 UTC
(From bugreport on bugzilla.novell)


Upgraded to KDE 3.5.5 release 19.5. The problem remains with all:
DigiKam v 9b2, 8.2 from back ports, 8.1 from the original OpenSuSe 10.1 DVD.

This bug affects both of my computers: one with OpenSuse continuously upgraded
from 10.1 beta times, the other with OpenSuse 10.1 final DVD installed in mid
September and both updated from the same sources as described above. Both
exhibit the bug. The problem started on both of them at the same time.

The only major difference between you and me:
I run OpenSuse 10.1 with Suse's updates for it + KDE from backports et all, NOT

Again. the problem only affects digikam's "choose icon" window. Choosing icons
in other places in KDE is fine.


This is probably beyond KDE. The persistence of the problem despite kde and
digikam version change shows it's somewhere deeper in libs, or something. There
were a few other, non-kde packages updated right before the bug surfaced...
ImageMagic, or, something like that..

None of the digikam versions available seem to produce the "proper" bug report.
Could you recommend compile options and set up so I can try to compile digiKam
myself and try to get a more sensible crash report out of it?
Comment 8 caulier.gilles 2006-10-17 08:09:53 UTC

I'm use digikam & co on 2 computers (home + office) under suse 10.1 without problem.

Comment 9 Daniel 2006-10-17 08:20:40 UTC
 I'm use digikam & co on 2 computers (home + office) under suse 10.1 without problem. 

Gilles, can you tell what version of KDE you are running?
Also, what was the last time you updated your suse 10.1?

I was also running it fine with Suse 10.1, until mid-september updates of system and KDE.
Comment 10 caulier.gilles 2006-10-17 08:36:15 UTC
KDE 3.5.1 without major system update, (only security update).

Comment 11 Adam Porter 2006-10-19 10:12:45 UTC
I'm running Debian testing/unstable, with KDE 3.5.5a packages.  With both 0.8.2 and 0.9.0beta2, I have this problem.

Comment 12 Daniel 2006-10-19 17:59:53 UTC
Tested with digikam 0.9 beta 3
(OpenSuse 10.1, KDE 3.5.5 "Release 19.1")

Problem IS still PRESENT. I am still unable to get a more meaningfull bug report out of the crash.. :(

Changing icons in the rest of KDE is still fine.

Can someone suggest compile options for digiKam to ensure that it gives enough info upon crash?
Comment 13 Adam Porter 2006-11-07 12:55:11 UTC
This is fixed in Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=393505  Though I can't tell from the changelog if the patch is included in upstream, so I don't know if this can be closed yet here.
Comment 14 Daniel 2006-11-13 18:57:53 UTC
Tested with Digikam 0.9.0 Beta 3, on KDE 3.5.5 ("release 39.1" OpenSuse)

Problem is still there, but there is new, exciting error:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1239165264 (LWP 16315)]
[KCrash handler]
#5  0x080503e8 in ?? ()
#6  0x080503e8 in ?? ()
#7  0x085422f0 in ?? ()
#8  0x00000020 in ?? ()
#9  0x00000019 in ?? ()
#10 0x08137f70 in ?? ()
#11 0x00000031 in ?? ()
#12 0xb72cb6ae in typeinfo name for QPtrList<QButtonItem> ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x00000001 in ?? ()
#14 0x00000000 in ?? ()
Comment 15 caulier.gilles 2006-11-13 18:59:32 UTC
This problem must be fixed before 0.9.0-final release

Gilles Caulier
Comment 16 caulier.gilles 2006-11-14 12:52:01 UTC
Checking in Debian bug:


The diff file relevant do not contain a fix in digiKam source code. 

Question: how Debian team have fixed this bug ? Achim ?

Comment 17 caulier.gilles 2006-11-14 13:04:47 UTC
Also, to have checked with valgrind, I have only see this warning :

==3845== Conditional jump or move depends on uninitialised value(s)
==3845==    at 0x1CDB6C4F: QIconView::showEvent(QShowEvent*) (in /usr/lib/qt3/lib/libqt-mt.so.3.3.4)

Witch is relevant of Qt library.

Comment 18 caulier.gilles 2006-12-14 12:41:29 UTC
Someone can try to run digiKam under valgrind like it explained at end of HACKING file and report me all messages form the console. Thanks in advance.

Comment 19 Thomas McGuire 2007-03-27 23:54:16 UTC
*** Bug 142984 has been marked as a duplicate of this bug. ***
Comment 20 Adam Porter 2007-03-28 05:43:06 UTC
I have built and installed Digikam 0.9.1 from source from digikam.org on Debian testing/unstable, and I don't seem to have this problem.
Comment 21 Arnd Baecker 2007-06-06 16:07:52 UTC
I check the problem as described in #0, and do not observe any crash
with current svn under debian etch.

Daniel, could you maybe give it another try (either with svn or 0.9.2.beta3)
to see if the problem persists for you?
Maybe we are lucky and this can be closed...
Comment 22 Arnd Baecker 2007-06-26 09:50:45 UTC
Closing this bug now. 
This does not mean it is invalid by itself, but
the positive reports suggest, that the problem is solved

Please feel free to re-open if there is any new information.

Thanks a lot for your understanding,