Bug 132827 - Create Tag from address-book entry
Summary: Create Tag from address-book entry
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Tags-AddressBook (show other bugs)
Version: 0.9.0
Platform: unspecified Linux
: NOR normal with 135 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-22 23:07 UTC by m.wege
Modified: 2022-01-22 21:50 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.2.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2006-08-22 23:07:47 UTC
Version:            (using KDE 3.5.4, Debian Package 4:3.5.4-3 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17.8-slh-up-1

When I am in the tag list, right click on a tag, there is the menu entry for linking the tag to an addressbook entry. There a to problems with this: First, I can not pass the menu entry, if want to get further down for another menu entry, because, when I get on that entry, my screen is flooded with all my contacts in the addressbook so the right click menu is hidden. The second problem is the point itself. I have a lot of contact, they are not all shown on the screen an there seems no way to pass further then the contacts shown on the screen. In general I think this way of doing this is rather not very usable. I would suggest to use the same way kopete allows to connect to an addressbook windows, that is really easy and usable
Comment 1 Anton Pussep 2006-12-18 16:52:48 UTC
Hey, I fully agree, I have the same problem that I have more contacts than can be displayed in the menu! It is a great feature, but a menu is not suitable for this, some other window (with pictures form addressbook maybe) would be wonderful!
Comment 2 m.wege 2006-12-18 17:01:38 UTC
As suggested Kopete has a menu which does exactly this. I have also seen it in another KDE-programme, but can not remember. So it may be easy to copy the code.
Comment 3 Luis Silva 2008-04-16 14:45:50 UTC
This bug is still in kde 3.5.9. A simple solution would be to use the same kind of menu used in, say, kicker folder menus.
Comment 4 Luis Silva 2008-04-16 14:47:18 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 caulier.gilles 2008-12-06 08:18:50 UTC
Andi, Marcel,

To solve this problem, we need to use adressbook dialog from Konversation...

Gilles Caulier
Comment 6 Andi Clemens 2010-09-25 17:42:47 UTC
Closing some old bugreports that are related to old digiKam version, and that have not received answers for two years now.

If you think the reports are still valid, feel free to re-open them, but please provide updates and do not just open them without giving feedback.
Comment 7 m.wege 2010-09-26 01:25:57 UTC
The problem still exists in KDE 4.5.1 (Digikam 1.3.0) in exact the same way as described above.
Comment 8 caulier.gilles 2011-12-16 12:23:24 UTC
*** Bug 159667 has been marked as a duplicate of this bug. ***
Comment 9 caulier.gilles 2011-12-16 12:23:51 UTC
*** Bug 111600 has been marked as a duplicate of this bug. ***
Comment 10 caulier.gilles 2011-12-16 12:48:51 UTC
*** Bug 134041 has been marked as a duplicate of this bug. ***
Comment 11 BartOtten 2011-12-22 00:29:48 UTC
No problem anymore, cause it does not work ;-) Is the feature disabled or should I file another bugreport?

Version: Digikam 2.4.1, however it never worked the last half year
Distro: openSUSE 12.1
Addressbook: Populated with Google Contacts and Facebook Contacts
Comment 12 caulier.gilles 2011-12-22 07:44:08 UTC
KDE adress-book support in digiKAm is optional. you need to install kdepimlibs and recompile digiKam. Look in README file for details.

Gilles Caulier
Comment 13 BartOtten 2011-12-23 22:19:45 UTC
If it's optional, and not enabled (I guess, cause it don't work at my install) why is there the menu-entry?
Comment 14 Daniel Aurich 2012-01-06 12:35:29 UTC
Hi, I have installed kdepimlibs 4.7.4 and digikam 2.5.0 on my gentoo system. Address book search in kmail and kopete does work properly, addressbook support compiled for digikam. If I select "Create Tag from Address Book" the submenue is empty. I think this is because of the use of 
#include <kabc/stdaddressbook.h>
which is not used anymore in favor of akonadi. There was a similar thing going on with kmail
http://osdir.com/ml/kde-commits/2009-11/msg05382.html
but I'm not quite sure how to do this for digikam.
Comment 15 caulier.gilles 2014-07-29 16:22:12 UTC
I fixed this entry with this commit. KDEPimLibs now work again with digiKam...

https://projects.kde.org/projects/extragear/graphics/digikam/repository/revisions/61b9adcd8eb77954283fd0ae5db9daecfc3aeb27

But KDEPimLibs dependency must be replaced by AKonadi in the future...

Gilles Caulier