Bug 126286 - Kopete shouldn't access tv card at startup
Summary: Kopete shouldn't access tv card at startup
Status: RESOLVED LATER
Alias: None
Product: kopete
Classification: Unclassified
Component: Audio/Video Plugin (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 147726 150873 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-26 13:54 UTC by Cédric Bellegarde
Modified: 2008-01-24 04:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Bellegarde 2006-04-26 13:54:37 UTC
Version:           0.12 svn (using KDE KDE 3.5.2)
Installed from:    Ubuntu Packages
OS:                Linux

I think kopete video part should be desactivated by default and available via an option.

Why? Because when i'm watching tv with tvtime (for exemple), if i launch kopete, it stop tv in tvtime :-(
Comment 1 Michaël Larouche 2006-04-26 15:18:00 UTC
I know why. I use libavdevice in MSN plugin to check if we have a webcam. To don't broadcast that we have a webcam when it's not the case.
Comment 2 Cédric Bellegarde 2006-05-03 19:29:02 UTC
maybe using dbus/hal to check that will fix the bug?
Comment 3 dienadel 2007-06-01 09:56:25 UTC
Me too, it's really anoying.

I don't have a webcam, tvcard, instead. But kopete "crashes" my TV sesion.

Also, since last upgrade to kde 3.5.7, often (80%), once started kopete and closed, i must rmmod "bttv and bt878" and reload again, to have access to kdetv.
Comment 4 Cláudio da Silveira Pinheiro 2008-01-22 10:22:32 UTC
*** Bug 150873 has been marked as a duplicate of this bug. ***
Comment 5 Cláudio da Silveira Pinheiro 2008-01-22 10:53:35 UTC
*** Bug 147726 has been marked as a duplicate of this bug. ***
Comment 6 Cláudio da Silveira Pinheiro 2008-01-24 04:57:01 UTC
Tested here with TVtime and Kopete accessing a bttv PCI card, Kopete does change tvtime's current input, but neither program crashes or stops working.

The problem resides in the fact Linux's V4L2 kernel API allows multiple simultaneous access to a given device, although the 2nd and later accesses are limited. It's an expected behavior by the driver, and not a lot can be done to prevent it while we're detecting devices' capabilities, and removing proper detection would hamper a lot of other Kopete characteristics.

I aknowledge the validity of this bug, but as the practical impossibility (feasible, but impractical) of fixing it with the present linux video architecture while preserving other needed features implemented in Kopete, I'll close this bug with the LATER status, and address this issue again when the architecture allows it.