Bug 122199 - imap account constantly downloading over & over - worked correctlly with kde <3.5
Summary: imap account constantly downloading over & over - worked correctlly with kde ...
Status: RESOLVED DUPLICATE of bug 121866
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.1
Platform: unspecified FreeBSD
: NOR normal
Target Milestone: ---
Assignee: kdepim bugs
: 125113 (view as bug list)
Depends on:
Reported: 2006-02-18 03:46 UTC by Ian
Modified: 2007-09-14 12:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Ian 2006-02-18 03:46:20 UTC
Version:           1.9.1 (using KDE 3.5.1, compiled sources)
Compiler:          gcc version 3.4.2 [FreeBSD] 20040728
OS:                FreeBSD (i386) release 5.4-RELEASE-p11

Since I upgraded to KDE 3.5, imap has stopped working correctly in kmail. I was using the kmail versions that came with kde 3.4.x to access an imap account on a remote server.
When I upgraded KDE to 3.5 (including it's version of kmail), the imap account has not worked. Upgrading to kde 3.5.1 didn't help, nor did deleting the imap account and start from scratch (I've done that several times now).
What seems to be happening is that kmail downloads all the email headers from the server, then it starts downloading the bodies and deletes them as it goes until it gets down to the most recent message. Then it starts the whole process again and keeps doing that for as long as kmail is running.
As a result kmail runs very slowly and I can never access my imap mail. Pop mail works fine and I haven't changed anything on the remote server that may have caused a problem.
I've tried changing all sorts of options in order to make it work, but here's the relevant part of kmailrc with my current settings:

[Account 8]
Name=IMAP Account
Comment 1 Ian 2006-02-18 03:50:15 UTC
BTW, my imap server is:
map-uw-2004g_1,1   University of Washington IMAP4rev1/POP2/POP3 mail servers
Comment 2 Juha Tuomala 2006-02-18 08:54:45 UTC
Looks like duplicate to bug 121866.
Comment 3 Carsten Burghardt 2006-02-18 10:03:59 UTC
This can only happen when the server send false uids.
Can you try to start ethereal and get a log of the communication when that 
Comment 4 Ian 2006-02-18 12:27:15 UTC
> Looks like duplicate to bug 121866. 
Similar kind of thing, yes, though that one says it only happens once unless kmail crashes - mine just seems to keep doing it endlessly.
Comment 5 Juha Tuomala 2006-02-18 12:37:42 UTC
So it does for me sometimes when I have big attachments and without crash. That actually happened after that bug has been submitted. So I wouldn't be that sure that it's crash related. My kmail seems to be very prone to crash If I stress it (autocheck activated, multiple activities before last ones have been finished).
Comment 6 Ian 2006-02-18 12:52:17 UTC
I've disabled autocheck for the imap account, I just have check on on startup enabled. I don't have crashes, kmail is quite stable for me, though I think it crashed a lot with the KDE 3.5 version.
Then again, the mail on the imap server is just server logs and some hylafax notifications, so it's all short, plain text emails. Even so, they take forever to download/upload.

I'm just installing ethereal at the moment and will post a trace - it could get pretty big, so I might upload it to my website and provide a link to it.
Comment 7 Ian 2006-02-18 14:07:57 UTC
Ok, my packet trace is at http://home.swiftdsl.com.au/~imoore/imap_trace
There's 2 minutes worth there, that's from when I click on the IMAP folder and kmail starts downloading the headers, through to when it starts downloading the message bodies and deleting the emails.
Hope it's of some help! PS I've changed my password already, just in case!
Comment 8 Juha Tuomala 2006-02-18 14:10:11 UTC
 You don't have permission to access /~imoore/imap_trace on this server.
Comment 9 Ian 2006-02-19 00:56:18 UTC
Oops, it's fixed now.
Comment 10 Carsten Burghardt 2006-04-05 21:58:01 UTC
The connection is encrypted therefore the trace is unfortunately useless. Any 
chance for a test account?
Comment 11 Carsten Burghardt 2006-05-29 14:35:47 UTC
*** Bug 125113 has been marked as a duplicate of this bug. ***
Comment 12 Thomas McGuire 2007-08-12 13:02:06 UTC

*** This bug has been marked as a duplicate of 121866 ***