Bug 121736 - Window position not remembered for certain apps
Summary: Window position not remembered for certain apps
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-11 00:23 UTC by Michael Stather
Modified: 2006-07-11 17:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stather 2006-02-11 00:23:19 UTC
Version:           Unbekannt (using KDE 3.5.0 Level "a" , SUSE 10.0 UNSUPPORTED)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15.7-default

There´s a strange bug with session managemant on my machine. Almost all KDE apps work normal, they remember the window size and position between launches (and KDE sessions when terminated by KDE shutdown).
However some apps don´t remember the window positon. I experienced this with bot kaffeine and kjobviewer. The window position is always remembered correctly, but the windows appear every time in the upper left corner of the window. I think the problem isn´t specific to these apps, since none of the authors could reproduce it on his machine. Perhaps it´s specific to my system.
Comment 1 Thiago Macieira 2006-02-12 23:29:49 UTC
So, how do we reproduce this? :-)
Comment 2 Michael Stather 2006-02-12 23:45:12 UTC
That´s a really good question *g
I´d really like to track this down and I know C++ and debugging, but perhaps there are some other steps to see if there´s an error on saving the window size. I don´t know I haven´t programmed KDE before...
Comment 3 Michael Stather 2006-03-10 23:01:32 UTC
Please do comment on this, I really want this fixed.
It also happens on some other machines as well so it´s not a specific problem.
Comment 4 Michael Stather 2006-07-11 00:22:31 UTC
Do you want me to help fixing this or not :(
This bug happens on all linux distros which I know, is there a core kde team who focuses on the core kde bugs or does everyone just fixes what he experiences for himself? I really like to help making KDE better, but it´s really discouraging waiting months on bug reports and getting no replies :(
If those components are rewritten for e.g. KDE 4 thre´s no problem, but do you want to ship KDE 4 with such bugs? probably not...
Comment 5 Stefan Borggraefe 2006-07-11 12:22:05 UTC
Duplicate of bug 15329?
Comment 6 Michael Stather 2006-07-11 14:48:00 UTC
What I don´t understand is that it works for almost all apps but for some like kaffeine it doesn´t work
Comment 7 Stefan Borggraefe 2006-07-11 15:13:03 UTC
It's more suprising that some apps remember their window position/size than the opposite. ;-) A general solution for all apps doesn't exist yet. This would be bug 15329.

If you want certain windows to remember their size/position, you have to configure such windows one by one currently.

As far as I understand, you thought something like bug 15329 was already implemented and you wanted to report, that it doesn't always work. Right?
Comment 8 Michael Stather 2006-07-11 16:12:44 UTC
The majority of apps (e.g. kmail, kopete) supports this feature. Even old ones which are unmaintained for a long time, so I thought there´s a general framework for this.
It´s really not usable IMHO when you´ve to set this hint for every app in the system menu, this should be handled by the app itself.
Comment 9 Stefan Borggraefe 2006-07-11 17:32:07 UTC
KMail 1.9.3 doesn't remember its window position unless you configured it manually to do so. I just tested it. KMail always opens its main window in the upper left corner for me.

You're right with respect to Kopete's main window (the position of the chat windows are not remembered!). There is also a special option in konqueror to save the window position in profiles. But I couldn't find any other KDE app where the window position is remembered. I tried kedit, kolf, k3b, kmail and kcalc before it got tiresome. ;-)

Nevertheless, what you want is bug 15329.

*** This bug has been marked as a duplicate of 15329 ***
Comment 10 Michael Stather 2006-07-11 17:59:38 UTC
OK you´re right with the window position. What I usually do is to maximize windows, and this is remembered by many apps, kontakt, kdetv, ark, k3b, ... :)