Bug 117952 - Align to grid not working, file browser not responding to keyboard in detailed view
Summary: Align to grid not working, file browser not responding to keyboard in detaile...
Status: CLOSED FIXED
Alias: None
Product: kdesktop
Classification: Miscellaneous
Component: icons (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 30 votes (vote)
Target Milestone: ---
Assignee: Benoit Walter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-08 20:33 UTC by RedShift
Modified: 2009-01-02 20:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Align to grid switched on, icons not aligned (46.72 KB, image/png)
2006-02-21 10:56 UTC, Sergey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RedShift 2005-12-08 20:33:12 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Unlisted Binary Package
Compiler:          GCC 4.0.2 
OS:                Linux

When I select Align to grid when right-clicking the desktop -> icons, nothing happens. Altough it is marked on, the icons don't align to a grid.

Also, when putting the file browser in "Detailed list view", it doesn't respond to keyboard typing anymore. In normal view, when I for example type "L" it would go to the first file starting with an L. In detailed view nothing happens.

Glenn
Comment 1 madman 2006-01-05 16:43:24 UTC
I can confirm this bug on 3.5.0, compiled from sources (Gentoo)
Comment 2 Martin Koller 2006-01-08 20:38:53 UTC
Which one you can confirm ? The Align to grid ?
I can't confirm here. Align to grid works as expected. (Of course the icons muts be not aligned before ;-) ) 
Comment 3 madman 2006-01-08 22:02:11 UTC
I have experienced both unexpected behaviours. Strange thing is, align to grid works on one of my computers, doesn't on the other one.
Both computers had Ubuntu with kde 3.4 before. They were "upgraded" to gentoo with kde 3.5

It might be the matter of configuration files coming from broken ubuntu compilations of 3.4.3 on the computer having the problem. I might try adding a new user to check if grid alignment works as expected and commenti it later here.
Comment 4 Johannes Eberleh 2006-02-05 19:09:21 UTC
Re Comment #2 from Martin Koller:
is it possible, that this is the same bug then bug 116341 and perhaps also bug 114766? Of course with different synthoms as described in these bugs.
Comment 5 madman 2006-02-05 19:23:09 UTC
Tried methods described in different bugreports mentioned in comments. Shutting down kdesktop and starting it from a console definately helps - icon arrangement finally works as expected. I'll have to check if it is still working after KDE restart
Comment 6 Sergey 2006-02-21 10:56:54 UTC
Created attachment 14792 [details]
Align to grid switched on, icons not aligned
Comment 7 Sergey 2006-02-21 11:00:31 UTC
Comment on attachment 14792 [details]
Align to grid switched on, icons not aligned

Bug still exists on kde 3.5.1 compiled from sources, on KDE 3.5.1, Gentoo Linux
(i686) release 2.6.15-gentoo-r1, gcc version 3.4.5 (Gentoo 3.4.5,
ssp-3.4.5-1.0, pie-8.7.9)
Comment 8 Maciej Mrozowski 2006-04-03 22:40:43 UTC
I have exactly same issue with kdesktop

kde 3.5.1, gcc (GCC) 3.4.5 (Gentoo 3.4.5-r1, HTB-3.4.4-1.00, ssp-3.4.5-1.0, pie-8.7.9)
Comment 9 Dirk Mueller 2006-06-23 02:14:40 UTC
SVN commit 554047 by mueller:

fix align-to-grid option which regressed due to the startup performance
patches. 
BUG: 122001
BUG: 127672
BUG: 114766
BUG: 117952


 M  +9 -0      desktop.cc  


--- branches/KDE/3.5/kdebase/kdesktop/desktop.cc #554046:554047
@@ -735,6 +735,15 @@
     // hurra! kicker is alive
     if ( m_waitForKicker ) m_waitForKicker->stop();
 
+    // -2: all screens
+    // -1: primary screen
+    // else: screen number
+
+    if (screen <= -2)
+       screen = kdesktop_screen_number;
+    else if (screen == -1)
+       screen = kapp->desktop()->primaryScreen();
+
     if ( (screen == kdesktop_screen_number) && m_pIconView )
         m_pIconView->updateWorkArea(area);
 }
Comment 10 FiNeX 2009-01-02 20:31:59 UTC
Bug closed. Kdesktop is no more mantained.