Bug 117420 - Code Completion Database Building Crashes Boost PGSql
Summary: Code Completion Database Building Crashes Boost PGSql
Status: RESOLVED DUPLICATE of bug 78978
Alias: None
Product: kdevelop
Classification: Applications
Component: Language Support: CPP (old) (show other bugs)
Version: 3.3.0
Platform: openSUSE Linux
: NOR crash with 25 votes (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-01 11:25 UTC by Tomislav Petrovic
Modified: 2013-03-31 00:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
KDevelop backtrace when integer_traits.hpp is parsed. (1.71 KB, text/plain)
2005-12-01 11:31 UTC, Tomislav Petrovic
Details
integer_traits.hpp (7.40 KB, text/plain)
2005-12-01 11:33 UTC, Tomislav Petrovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomislav Petrovic 2005-12-01 11:25:36 UTC
Version:           3.3.0 (using KDE KDE 3.5.0KDE 1.2)
Installed from:    I Don't KnowSuSE RPMs
Compiler:          gcc version 3.3.3 (SuSE Linux) 
OS:                Linux

OS: SLES 9
KDevelop: 3.3.0 built from source.
KDE: 3.2.1 installed from RPM

I have several problems building code completion database of my /usr/include/boost/ and /usr/include/pgsql/ dirs recursively.

1. When building code completion database of /usr/include/boost/ KDevelop crashes trying to parse following file /usr/include/boost/integer_traits.hpp. KDE Crash handler is displayed and following backtrace: kdevelop_backtrace.txt can be obtained.

2. If I remove problematic file from 1. and try again to build code completion database of /usr/include/boost/ KDevelop blocks and then crashes on file /usr/include/boost/preprocessor/iteration/detail/finish.hpp. KDE Crash handler is not displayed, it just prints out follwoing to lines on terminal where KDevelop was started: "KCrash: Application 'kdevelop' crashing... Alarm clock". However, if I just try to build code completion database of /usr/include/boost/preprocessor/ everything works fine.

3. If I try to build code completion database of /usr/include/pgsql/ KDevelop blocks and then crashes on file /usr/include/pgsql/server/catalog/pg_operator.h. KDE Crash handler is not displayed, it just prints out follwoing to lines on terminal where KDevelop was started: "KCrash: Application 'kdevelop' crashing... Alarm clock". Moreover, if I just try to build code completion database of /usr/include/pgsql/server/ same error occurs. However, if I just try to build code completion database of /usr/include/pgsql/server/catalog/ everything works fine.

BZipped tarbals of my /usr/include/boost/ and /usr/include/pgsql/ are provided, together with backtrace for problem 1.

Problem number 1 might be similar to: http://bugs.kde.org/show_bug.cgi?id=83468, although I'm not sure.
Comment 1 Tomislav Petrovic 2005-12-01 11:30:21 UTC
OK, I did not post tarbals :), I'll just attach problematic hpp file and backtrace.
Comment 2 Tomislav Petrovic 2005-12-01 11:31:27 UTC
Created attachment 13703 [details]
KDevelop backtrace when integer_traits.hpp is parsed.
Comment 3 Tomislav Petrovic 2005-12-01 11:33:24 UTC
Created attachment 13704 [details]
integer_traits.hpp
Comment 4 Joseph Garvin 2005-12-25 04:03:05 UTC
I can confirm this bug for boost, haven't tried for psql. Running Ubuntu Breezy.
Comment 5 David Holm 2006-01-10 17:55:41 UTC
I'm having the same problem with KDE 3.3.0 and boost 1.33.1 although I was unable to get a reasonable backtrace (even with debug support enabled in my kdevelop build) I assume it is at least similar to this bug. This is on a Gentoo system (in case it matters).
Comment 6 Philip Belemezov 2006-03-14 20:12:02 UTC
I can verify this bug for boost 1.33.1.
SUSE 10 with Linux (x86_64) 2.6.13-15
KDevelop 3.3.1 (installed from RPM)
KDE 3.4.2 Level "b"
Comment 7 Jens Dagerbo 2006-05-01 22:31:38 UTC
Probable dupe.

*** This bug has been marked as a duplicate of 78978 ***
Comment 8 Tomislav Petrovic 2006-05-12 13:05:40 UTC
Sorry to bother you via mail, somehow bugs.kde.org doesn't seem to listen to me today :(

Tried this today.
Compiled todays checkout of:
svn co svn://anonsvn.kde.org/home/kde/branches/KDE/3.5/kdevelop/ kdevelop 

KDevelop still keeps crashing on boost include dir :(.

From: Jens Dagerbo <jens.dagerbo@swipnet.se>
To: t.petrovic@inet.hr
Subject: [Bug 117420] Code Completion Database Building Crashes Boost PGSql   
Date: 1 May 2006 20:31:39 -0000

----- Original Message Follows -----
<blockquote>
[bugs.kde.org quoted mail]
</blockquote>
Comment 9 Amilcar do Carmo Lucas 2006-05-12 13:44:47 UTC
You used the wrong branch!

Please use:
svn co svn://anonsvn.kde.org/home/kde/branches/kdevelop/3.4 kdevelop
Comment 10 Tomislav Petrovic 2006-05-12 16:47:05 UTC
Unfortunately, at the moment, I cannot.
I do not have the required KDE version >= 3.4.

Can this patch be included in the KDE/3.5 branch?
Comment 11 Aleix Pol 2013-03-31 00:47:23 UTC
Moving all the bugs from the CPP Parser. It was not well defined the difference between it and C++ Language Support and people kept reporting in both places indistinctively