Bug 83468 - Import of boost C++ libraries fails.
Summary: Import of boost C++ libraries fails.
Status: RESOLVED DUPLICATE of bug 78978
Alias: None
Product: kdevelop
Classification: Applications
Component: Language Support: CPP (old) (show other bugs)
Version: 3.0.3
Platform: Gentoo Packages Linux
: NOR crash with 55 votes (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
: 108433 121982 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-16 09:32 UTC by Jonathan Merritt
Modified: 2013-03-31 00:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The crash backtrace (12.55 KB, text/plain)
2006-04-30 19:25 UTC, greatbunzinni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Merritt 2004-06-16 09:32:09 UTC
Version:           3.0.3 (using KDE KDE 3.2.2)
Installed from:    Gentoo Packages
Compiler:          gcc (GCC) 3.3.2 20031218 (Gentoo Linux 3.3.2-r5, propolice-3.3-7) 
OS:                Linux

Attempting to import the boost C++ libraries using "Project->Import Existing Project..." fails.  The failure is characterized by an apparent infinite loop, and sometimes a segfault.  I have been able to track down at least one problem.  The importer apparently cannot parse duplicated nested namespaces like this:

namespace a {
 namespace b {
  namespace b {
  }
 }
}

This pattern occurs quite frequently in the boost libraries.  I am not certain that this is the only problem, but is certainly one of them.
Comment 1 Jens Dagerbo 2004-07-17 05:19:29 UTC
Can't reproduce. I tried importing boost_1_31_0/boost as a Generic C++ custom makefiles project. No problems.
Comment 2 Paul Schneider 2004-08-31 22:50:45 UTC
Add persistant class store (boost 1_31) crashes both kdevelop 3.0.4 and 3.1 on gentoo, reproducible every tiome for me
Comment 3 Matt Rogers 2004-12-15 21:03:30 UTC
anybody have a backtrace?
Comment 4 Thomas Porschberg 2005-01-11 15:03:33 UTC
KDevelop 3.1.0 (KDE-3.3.0)
If I try to import boost_1_30_0 kdevelop crashes:

backtrace-->


[New Thread 16384 (LWP 16113)]
[New Thread 32769 (LWP 16114)]
[New Thread 16386 (LWP 16115)]

[KCrash handler]
#4  0x415eeffd in QGList::QGList(QGList const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#5  0x425556b3 in TagCreator::parseBaseClause(QString const&, BaseClauseAST*)
    () from /opt/kde3/lib/kde3/libkdevcppsupport.so
#6  0x425532d2 in TagCreator::parseClassSpecifier(ClassSpecifierAST*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#7  0x4269c849 in TreeParser::parseTypeSpecifier(TypeSpecifierAST*) ()
   from /opt/kde3/lib/libkdevcppparser.so.0
#8  0x425521f9 in TagCreator::parseSimpleDeclaration(SimpleDeclarationAST*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#9  0x4269c648 in TreeParser::parseDeclaration(DeclarationAST*) ()
   from /opt/kde3/lib/libkdevcppparser.so.0
#10 0x42550c97 in TagCreator::parseDeclaration(DeclarationAST*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#11 0x425521a3 in TagCreator::parseTemplateDeclaration(TemplateDeclarationAST*)
    () from /opt/kde3/lib/kde3/libkdevcppsupport.so
#12 0x4269c63a in TreeParser::parseDeclaration(DeclarationAST*) ()
   from /opt/kde3/lib/libkdevcppparser.so.0
#13 0x42550c97 in TagCreator::parseDeclaration(DeclarationAST*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#14 0x42552f26 in TagCreator::parseLinkageBody(LinkageBodyAST*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#15 0x4269c6bf in TreeParser::parseNamespace(NamespaceAST*) ()
   from /opt/kde3/lib/libkdevcppparser.so.0
#16 0x4255115c in TagCreator::parseNamespace(NamespaceAST*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#17 0x4269c5f4 in TreeParser::parseDeclaration(DeclarationAST*) ()
   from /opt/kde3/lib/libkdevcppparser.so.0
#18 0x42550c97 in TagCreator::parseDeclaration(DeclarationAST*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#19 0x4269c536 in TreeParser::parseTranslationUnit(TranslationUnitAST*) ()
   from /opt/kde3/lib/libkdevcppparser.so.0
#20 0x42550dda in TagCreator::parseTranslationUnit(TranslationUnitAST*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#21 0x425bb018 in CreatePCSDialog::RppDriver::fileParsed(QString const&) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#22 0x4266bb01 in Driver::parseFile(QString const&, bool, bool) ()
   from /opt/kde3/lib/libkdevcppparser.so.0
#23 0x42587b2c in CreatePCSDialog::slotSelected(QString const&) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#24 0x425a5626 in CreatePCSDialogBase::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#25 0x42586813 in CreatePCSDialog::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#26 0x41316607 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x41316d40 in QObject::activate_signal(int, QString) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x416ade17 in QWizard::selected(QString const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x414dfd24 in QWizard::showPage(QWidget*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x414e00da in QWizard::next() () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x4258752d in CreatePCSDialog::next() ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#32 0x416ae055 in QWizard::qt_invoke(int, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x425a55ff in CreatePCSDialogBase::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#34 0x42586813 in CreatePCSDialog::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#35 0x41316607 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x413164a7 in QObject::activate_signal(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x4168319b in QButton::clicked() () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0x413ab1a1 in QButton::mouseReleaseEvent(QMouseEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0x4134e4bc in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0x412b2ecf in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0x412b24e3 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0x40dfba42 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kde3/lib/libkdecore.so.4
#43 0x41244e76 in QApplication::sendSpontaneousEvent(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0x4123d877 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0x4123b6a2 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0x41256785 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0x412c7495 in QEventLoop::enterLoop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0x412b3097 in QApplication::enter_loop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0x414b3b28 in QDialog::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0x42533769 in CCConfigWidget::slotNewPCS() ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#51 0x42590c2d in CCConfigWidgetBase::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#52 0x42533b64 in CCConfigWidget::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/kde3/libkdevcppsupport.so
#53 0x41316607 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#54 0x413164a7 in QObject::activate_signal(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#55 0x4168319b in QButton::clicked() () from /usr/lib/qt3/lib/libqt-mt.so.3
#56 0x413ab1a1 in QButton::mouseReleaseEvent(QMouseEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#57 0x4134e4bc in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#58 0x412b2ecf in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#59 0x412b24e3 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#60 0x40dfba42 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kde3/lib/libkdecore.so.4
#61 0x41244e76 in QApplication::sendSpontaneousEvent(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#62 0x4123d877 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#63 0x4123b6a2 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#64 0x41256785 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#65 0x412c7495 in QEventLoop::enterLoop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#66 0x412b3097 in QApplication::enter_loop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#67 0x414b3b28 in QDialog::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#68 0x08096e02 in ProjectManager::slotProjectOptions() ()
#69 0x0809a088 in ProjectManager::qt_invoke(int, QUObject*) ()
#70 0x41316607 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#71 0x413164a7 in QObject::activate_signal(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#72 0x40b80059 in KAction::activated() () from /opt/kde3/lib/libkdeui.so.4
#73 0x40b7f9fd in KAction::slotActivated() () from /opt/kde3/lib/libkdeui.so.4
#74 0x40b80111 in KAction::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/libkdeui.so.4
#75 0x41316607 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#76 0x4167b0c7 in QSignal::signal(QVariant const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#77 0x413336d2 in QSignal::activate() () from /usr/lib/qt3/lib/libqt-mt.so.3
#78 0x4142c681 in QPopupMenu::mouseReleaseEvent(QMouseEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#79 0x4134e4bc in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#80 0x412b2ecf in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#81 0x412b24e3 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#82 0x40dfba42 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kde3/lib/libkdecore.so.4
#83 0x41244e76 in QApplication::sendSpontaneousEvent(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#84 0x4123d5b0 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#85 0x4123b6a2 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#86 0x41256785 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#87 0x412c7495 in QEventLoop::enterLoop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#88 0x412c73ae in QEventLoop::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#89 0x412b303b in QApplication::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#90 0x080b5004 in main ()
#91 0x41af48ae in __libc_start_main () from /lib/libc.so.6
Comment 5 Jens Dagerbo 2005-07-25 22:34:33 UTC
*** Bug 108433 has been marked as a duplicate of this bug. ***
Comment 6 Joseph Garvin 2005-12-25 04:01:34 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Amilcar do Carmo Lucas 2006-02-15 11:28:29 UTC
*** Bug 121982 has been marked as a duplicate of this bug. ***
Comment 8 greatbunzinni 2006-04-30 19:22:27 UTC
I'm running KDevelop 3.3.2 under KDE 3.5.2 (kubuntu 5.04) and I can reproduce this bug every single time I try to import the boost directory into the code completion database.
Comment 9 greatbunzinni 2006-04-30 19:25:44 UTC
Created attachment 15861 [details]
The crash backtrace

This is a crash backtrace produced after I tried to import the boost include
directory.
Comment 10 Jens Dagerbo 2006-05-01 22:30:54 UTC
Probable dupe.

*** This bug has been marked as a duplicate of 78978 ***
Comment 11 Aleix Pol 2013-03-31 00:48:40 UTC
Moving all the bugs from the CPP Parser. It was not well defined the difference between it and C++ Language Support and people kept reporting in both places indistinctively