Bug 117168 - mkisofs reported error code 1
Summary: mkisofs reported error code 1
Status: RESOLVED FIXED
Alias: None
Product: k3b
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 81003 111693 113924 118105 118597 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-27 21:47 UTC by Rik
Modified: 2005-12-19 00:02 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rik 2005-11-27 21:47:46 UTC
Version:           0.12.3 (using KDE 3.4.2 Level "b" , SUSE 10.0)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15-default

I was trying to backup my downloaded files. I will include the debug output report.

System
-----------------------
K3b Version: 0.12

KDE Version: 3.4.2 Level "b" 
QT Version:  3.3.4
Kernel:      2.6.13-15-default
Devices
-----------------------
SAMSUNG CDRW/DVD SM-332B T408 (/dev/hdc, ) at /media/cdrecorder [CD-R; CD-RW; CD-ROM; DVD-ROM] [DVD-ROM; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96R; RAW/R16; RAW/R96R]

K3b
-----------------------
Size of filesystem calculated: 112307

Used versions
-----------------------
mkisofs: 2.1
cdrecord: 2.1

cdrecord
-----------------------
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Warning: not running as root user, fs= option ignored.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version (okir@suse.de-scsi-linux-sg.c-1.83-resmgr-patch '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
Cdrecord-Clone 2.01 (i686-suse-linux) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to http://www.suse.de/feedback
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 3 = CD-ROM XA mode 2
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'SAMSUNG '
Identifikation : 'CDRW/DVD SM-332B'
Revision       : 'T408'
Device seems to be: Generic mmc2 DVD-ROM.
Current: 0x0009
Profile: 0x0010 
Profile: 0x0008 
Profile: 0x0009 (current)
Profile: 0x000A 
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96R RAW/R16 RAW/R96R
Drive buf size : 1353728 = 1322 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data   219 MB        
Total size:      251 MB (24:57.45) = 112309 sectors
Lout start:      252 MB (24:59/34) = 112309 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is unrestricted
  Is not erasable
  Disk sub type: Medium Type B, low Beta category (B-) (4)
  ATIP start of lead in:  -12366 (97:17/09)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 69
Manufacturer: Moser Baer India Limited
Manufacturer is guessed because of the orange forum embargo.
The orange forum likes to get money for recent information.
The information for this media may not be correct.
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 247540
Starting to write CD/DVD at speed 8 in real TAO mode for multi session.
Last chance to quit, starting real write in 2 seconds.
   1 seconds.
   0 seconds. Operation starts.
/usr/bin/cdrecord: Caught interrupt.
Waiting for reader process to fill input buffer ... BURN-Free was never needed.
/usr/bin/cdrecord: fifo had 12 puts and 0 gets.
/usr/bin/cdrecord: fifo was 1 times empty and 0 times full, min fill was 0%.

cdrecord command:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=8 -tao driveropts=burnfree -eject -multi -xa -tsize=112307s - 

mkisofs
-----------------------
112307
INFO: UTF-8 character encoding detected by locale settings.
 Assuming UTF-8 encoded filenames on source filesystem,
 use -input-charset to override.
Using SUPER_CYBERTRON_SLACKW000.THEME;1 for  Stuff to burn for Suse/Theme Stuff/superkaramba/super_cybertron/Super_Cybertron_slackware2.theme (Super_Cybertron_slackware1.theme)
Incorrectly encoded string (Português(pt-BR)) encountered.
Possibly creating an invalid Joliet extension. Aborting.

mkisofs command:
-----------------------
/usr/bin/mkisofs -gui -graft-points -volid K3b data project -volset  -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-rik/k3bCkCirc.tmp -rock -hide-list /tmp/kde-rik/k3b91qCYa.tmp -joliet -hide-joliet-list /tmp/kde-rik/k3bNRfE5b.tmp -full-iso9660-filenames -disable-deep-relocation -iso-level 2 -path-list /tmp/kde-rik/k3bNJjILb.tmp
Comment 1 Thiago Macieira 2005-11-27 23:29:25 UTC
What is your $LANG?
Comment 2 Rik 2005-11-28 03:19:17 UTC
English language.
Comment 3 Thiago Macieira 2005-11-28 03:35:42 UTC
Heh, sorry, that's not what I asked.

I meant: what's the value of your $LANG variable? (open a shell and type: echo $LANG)
Comment 4 Dieter.Stuebinger 2005-12-01 08:28:09 UTC
I´ve got $LANG de_DE.UTF-8
what can I do to solve that problem ?
Comment 5 Thiago Macieira 2005-12-01 11:10:28 UTC
If I am correct in my assessment, setting $LANG to something UTF-8 would fix this. But I need to know what $LANG was set to for the reporter.
Comment 6 Dieter.Stuebinger 2005-12-01 13:55:44 UTC
Sorry for my intervention but I´ve got the same problem und trying to send my report I was guided to that bug report. 
See my bug report:

System
-----------------------
K3b Version: 0.12.8

KDE Version: 3.4.2 Level "b" 
QT Version:  3.3.4
Kernel:      2.6.13-15-default
Devices
-----------------------
IDE DVD-ROM 16X 3.10 (/dev/hdc, ) at /media/dvd [CD-Rom; DVD-Rom] [DVD-Rom; CD-Rom] [Keine]

BENQ DVD DD DW1625 BBHA (/dev/hdd, ) at /media/dvdrecorder [CD-R; CD-RW; CD-Rom; DVD-Rom; DVD-R; DVD-RW; DVD+R; DVD+RW; DVD+R doppelschichtig] [DVD-Rom; DVD-R Sequentiell; DVD-RW Sequentiell; DVD+RW; DVD+R; DVD+R Doppelschicht; CD-Rom; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96R; RAW/R16; RAW/R96R; Eingeschränktes Überschreiben]
K3b
-----------------------
Size of filesystem calculated: 1627883

Used versions
-----------------------
mkisofs: 2.1
growisofs: 5.21

growisofs
-----------------------
Executing 'builtin_dd if=/dev/fd/0 of=/dev/hdd obs=32k seek=0'
/dev/hdd: "Current Write Speed" is 8.2x1385KBps.
    622592/3333904384 ( 0.0%) @0.1x, remaining 356:55
/dev/hdd: flushing cache
/dev/hdd: updating RMA
/dev/hdd: closing disc

growisofs command:
-----------------------
/usr/bin/growisofs -Z /dev/hdd=/dev/fd/0 -use-the-force-luke=notray -use-the-force-luke=tty -use-the-force-luke=tracksize:1627883 -dvd-compat -speed=8 -overburn 

mkisofs
-----------------------
1627883
INFO: UTF-8 character encoding detected by locale settings.
 Assuming UTF-8 encoded filenames on source filesystem,
 use -input-charset to override.
Using ......
......
.......
Incorrectly encoded string (05 Träumereien.mp3) encountered.
Possibly creating an invalid Joliet extension. Aborting.

mkisofs command:
-----------------------
/usr/bin/mkisofs -gui -graft-points -volid Literatur -volset  -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-dieter/k3bJpJsBa.tmp -rational-rock -hide-list /tmp/kde-dieter/k3bXaFaWa.tmp -joliet -hide-joliet-list /tmp/kde-dieter/k3bWqFJ5b.tmp -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-dieter/k3bTt7JIb.tmp 
Comment 7 Thiago Macieira 2005-12-01 14:16:40 UTC
Dieter:
>Incorrectly encoded string (05 Träumereien.mp3) encountered.
>Possibly creating an invalid Joliet extension. Aborting.

Fix that first.
Comment 8 Dieter.Stuebinger 2005-12-01 14:23:13 UTC
what has to be done when you "fix that first"?
Comment 9 Rik 2005-12-03 18:27:13 UTC
Sorry for my slow response. Mine is en_US.UTF-8
Comment 10 Thiago Macieira 2005-12-11 16:28:11 UTC
*** Bug 81003 has been marked as a duplicate of this bug. ***
Comment 11 Thiago Macieira 2005-12-11 16:28:14 UTC
*** Bug 111693 has been marked as a duplicate of this bug. ***
Comment 12 Thiago Macieira 2005-12-11 16:28:15 UTC
*** Bug 113924 has been marked as a duplicate of this bug. ***
Comment 13 Thiago Macieira 2005-12-11 16:28:20 UTC
*** Bug 118105 has been marked as a duplicate of this bug. ***
Comment 14 Sebastian Trueg 2005-12-11 17:34:49 UTC
this is not a k3b bug nor a mkisofs problem. it is caused by incorrectly encoded filenames. this may happen if you updated your system and changed to another local encoding.
Use http://j3e.de/linux/convmv/ to fix the filename encodings.
k3b 0.12.9 will emit a proper error message here.
Comment 15 Sebastian Trueg 2005-12-11 17:34:59 UTC
*** Bug has been marked as fixed ***.
Comment 16 Rik 2005-12-11 17:42:35 UTC
Mind if I ask just how to use that?
Comment 17 Sebastian Trueg 2005-12-11 20:38:21 UTC
convmv --help
Comment 18 Andreas Schmoll 2005-12-11 20:53:49 UTC
Sorry, I installed convmv 1.09. convmv --help shows me that I use version 1.09. But the error message is the same. By the way the better command is: man conmv :-) 
Comment 19 Andreas Schmoll 2005-12-11 21:26:42 UTC
Okay, I got it now. I removed the affected files, then it worked. Thank you and have a nice Xmas time.
Comment 20 Thiago Macieira 2005-12-19 00:02:51 UTC
*** Bug 118597 has been marked as a duplicate of this bug. ***