Bug 116064 - Add GNUPlot syntax highlighting to Kate
Summary: Add GNUPlot syntax highlighting to Kate
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: syntax (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 325812 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-10 14:31 UTC by Dik Takken
Modified: 2014-04-24 15:17 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12


Attachments
kate syntax highlighting xml for gnuplot (39.31 KB, text/plain)
2012-04-13 16:49 UTC, Roberto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dik Takken 2005-11-10 14:31:39 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    Gentoo Packages
OS:                Linux

Kate does not seem to support syntax highlighting for GNUPlot scripts.
Comment 1 Anders Lund 2005-11-10 15:15:24 UTC
On Thursday 10 November 2005 14:31, Dik Takken wrote:
> Kate does not seem to support syntax highlighting for GNUPlot scripts.


It requires that someone who knows the GNUPlot syntax well writes a XML file 
for us. You can find documentation for kates syntax highlight file format 
(it's XML) in the docs for kate, and you are wellcome to seek help at 
kwrite-devel@kde.org and in channel #kate at the freenode irc network.

-anders
Comment 2 esigra 2005-12-20 11:20:11 UTC
Command completion would also be useful.
Comment 3 Konrad Urlichs 2006-10-26 16:41:40 UTC
I only want to emphasize that I also would really appreciate such a feature. I would do it myself, but I do not know the gnuplot syntax very well. There is an emacs gnuplot mode, maybe someone who knows both kate and emacs might be able to copy this highlighting modes?
Comment 4 Dominik Haumann 2006-10-26 19:39:52 UTC
as a sidenote: whenever you copy something, look at licensing issues.
Comment 5 Christoph Cullmann 2011-08-11 16:46:14 UTC
Valid wish, but we can't keep bugs open for any missing language ;)
Write one yourself or we hope to get submissions for one.
Comment 6 Roberto 2012-04-13 16:49:22 UTC
Created attachment 70366 [details]
kate syntax highlighting xml for gnuplot

tested working.
Comment 7 Dominik Haumann 2013-10-09 14:58:40 UTC
*** Bug 325812 has been marked as a duplicate of this bug. ***
Comment 8 Dominik Haumann 2013-10-09 15:00:12 UTC
Roberto, are you the author of this file?
Comment 9 Dominik Haumann 2013-10-09 15:01:09 UTC
Git commit afd626fe6fc74d014a9633f17724dd4c0af310de by Dominik Haumann.
Committed on 09/10/2013 at 15:00.
Pushed by dhaumann into branch 'master'.

add Gnuplot syntax highlighting file
FIXED-IN: 4.12

A  +888  -0    part/syntax/data/gnuplot.xml

http://commits.kde.org/kate/afd626fe6fc74d014a9633f17724dd4c0af310de
Comment 10 Robert Riemann 2013-11-04 13:27:19 UTC
I highly appreciate this!
Comment 11 Dominik Haumann 2013-11-04 16:09:03 UTC
@Robert: Are you the author of this file? It's currently missing this information, and there is no license information. Can you clarify?
Comment 12 Robert Riemann 2013-11-04 16:19:43 UTC
No, I am not. I was just looking for it and found this attachment and the information that the file was already commited. If the author doesn't respond one could the gnuplot mailinglist…